Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Could you help me with Quantum sync in AUM ?

Hi all!

Beginner here, your advices welcomed!

I am discovering the wonderful world of ios music. Having big fun with Animoog, iSEM, Ruismaker, Elastic drum, Fugue machine etc mainly in AUM.

I was in search of a step sequencer and got Quantum as it seems to fill my needs. However I cannot make it properly run in sync in AUM. I am in Ableton Link mode and there is a big latency, like a half note.

I have tried to mess with the options in Quantum, but with no success.

I could not find an answer on the web.

Chris

«1

Comments

  • Actually I just cannot make aum and Quantum start in sync...

  • edited February 14

    I think you might have to turn Link off for Quantum, and let it use the IAA sync from AUM instead (by hosting Quantum inside AUM).
    The latest version of Link is supposed to have Start/stop in sync functionality, but I guess that is not supported by both these apps yet.

    https://forum.audiob.us/discussion/26464/aum-patterning-zeeon-quantum-sync

  • @Kribee said:
    Actually I just cannot make aum and Quantum start in sync...

    Personally, I use Audiobus to host non-AU apps (like Quantum) in conjunction with AUM. In addition to state saving that allows your whole setup to be recalled and the sidebar / Audiobus Remote for remote control of background apps, it has a global transport that works very well.

    However...

    @Kribee said:
    I was in search of a step sequencer and got Quantum as it seems to fill my needs. However I cannot make it properly run in sync in AUM. I am in Ableton Link mode and there is a big latency, like a half note.

    Half of what note at what tempo? :)

    If you're writing about a major delay, it's probably just that AUM and Quantum are not in the same phase and starting offset from each other. In the Setup panel you can set Ableton Link Sequence Sync for each of the six sequencers to Phase, Beat or none. Make sure it's set to what you want.

    If you're writing about a subtle delay: There was a change in the timing engine for Quantum a while ago that resulted in a timing drift error. The latest version 1.10 resolves the timing drift, but I have noticed that while the timing is consistent, it is consistently late. My personal tests show this is not a massive amount (about 1/32 note at 60 bpm), but enough to notice flamming.

    I can adjust the Link pre-roll to 0.09 and get the timing correct; unfortunately that setting isn't persistent, so it has to be set for each session.

    @midiSequencer pretty please make it persistent!

  • edited February 14

    Thank you both for your kind answers.

    However I am still unable to have Quantum starting in time, in AUM . In audiobus it's even worse as I just have no sound at all. I guess I must have messed with the numerous options in Quantum. Pitty that the user manual is of no use at all in this regard.

    I cannot say if there is running latency, but for sure it does not start in time... I am totally lost. Very frustrating...

    I would be gratefull if somebody could post screen caps of the correct setting.

  • @Kribee said:
    Thank you both for your kind answers. I will try Quantum in Audiobus to see if it works better.
    Still wondering about ableton link or not though...

    I use personally use Link. I know that IAA sync is technically better, but I don't always want to have all my sequencers start at the same time. The Audiobus start is useful when I want to do that, otherwise I start sequencers manually to bring things in as needed.

  • Also when I try to change setting in Quantum's option it asks me to "stop sequencer playing first" even when the sequencer IS not playing, so I have to quit Quantum totally before beeing able to change anything.

    Actually Quantum is not even in sync with it's own metronome! Maybe that tells someone something ?

  • @Kribee said:
    Also when I try to change setting in Quantum's option it asks me to "stop sequencer playing first" even when the sequencer IS not playing, so I have to quit Quantum totally before beeing able to change anything.

    Well that's weird if it's actually not running.

    Actually Quantum is not even in sync with it's own metronome! Maybe that tells someone something ?

    Not in sync how? Correct tempo but off the count or different tempo?
    Quantum is complex and lots of things can affect its behavior. Detailed descriptions, screenshots, etc. can help

  • I am not able to give a detailed response now but somewhere in Quantum's settings there is an option to turn on MMC which is how AUM transport is controlled (I think). In AUM you have to turn on MMC and select Quantum for midi control. In Quantum you have to set the sync option to Phase (I think, sorry not near an ios device at the moment). You may have to change count in and sync settings in AUM. This allows Quantum to start AUM playing but I'm not sure whether AUM will start Quantum.

    If Quantum's metronome is not in time with itself then you may have changed some other settings which may need to be reset back to default.

  • Ok thanks I'll try again and again. Quantum is just what I need and I really want to make it work. I'll try to send screen shots later.
    To aplourde : When I say not in sync with it's own metronome, I mean that just looking at Quantum's lights (up the notes) when running I can SEE that it is not in sync with its metronome...

    (by the way sorry for my poor english..)

  • Best sync is with Link.

    Try this first to be sure you have it working
    Go into Options, tap top button to turn all Link options on in the pop up . Note: next to this button is a rotary to enable you to play a little ahead of Link timeline. 0.07 is supposed to be a good value.
    Go into Setup - look at the last two columns (AB Link) and set these to Phrase (so sync should be to the bar, other values are beat or None for no sync).

    Setup your synth in AUM - they can use Quantum as an input - its the default output of Quantum.

    Press Song Play (> button bottom left of the main screen) - it should say Play with Ableton Link. The Song Pos is yellow to also indicate its Link (rather than white).

    This is all without playing the Host transport.

    If thats not working tell me your host sampleRate etc.

  • @Kribee said:
    Ok thanks I'll try again and again. Quantum is just what I need and I really want to make it work. I'll try to send screen shots later.
    To aplourde : When I say not in sync with it's own metronome, I mean that just looking at Quantum's lights (up the notes) when running I can SEE that it is not in sync with its metronome...

    Did you change the sequencer's tempo division? Towards the bottom left of each sequencer rack there's "Tempo" and next to it should be "1/1" by default. With the default common time signature (4/4) each step would be a 16th note, so the metronome will be on steps 1, 5, 9 and 13. If you have a triplet or dotted division for the Tempo division value (any fraction with a D or T appended; e.g. "1/1D" or "1/1T") the steps won't line up as simply; they'll be 3/2x or 2/3x the base value.

  • I use Audiobus to start AUM and Quantum in sync, using Link. I just load up the 2 apps in Audiobus even if I want to host most of the other apps in AUM.
    I use the Audiobus play button to start everything. You still have to rewind in each app though.

    Here is an example:

    In Quantum, in the Settings panel, turn on Link here by setting it to Phase. Remember to do this for each rack/sequence. I only have one here.

    In AUM, I have Quantum connected to Phosphor through the AUM Midi Matrix. I have DM1 set for IAA tempo sync, so it starts when AUM starts.

    So just remember to use the Audiobus play button in the side toolbar when you are working in AUM. If you hit the AUM play button at the top (probably from habit) then Quantum won’t start, just AUM. Also, remember to hit rewind in each app when you need to start from the beginning. You can also use the Audiobus side toolbar to rewind the apps in their little control sections.

  • edited February 17

    Thanks lot @midiSequencer and @Cracklepot !

    Sorry for my late reply : I was lost having big fun with Animoog...

    So today I follow your steps, and Quantum behaves better! But still....

    To be sure I run the same kick (ruismaker) one from Quantum and one from Ruismaker own sequencer.

    I set "link set up & pre-roll" on 0.10.
    It starts right and starts to shift slightly very soon.. That was with 256 sample rate.

    With 512 sample rate it seems to play nicely right with 0.16, with shifting coming a bit later...

    So definitely shifting makes it unusable.

    More help welcomed!

    ps : I try to have every app at 512 sample rate

  • @Kribee said:
    Thanks lot midiSequencer and Cracklepot !

    Sorry for my late reply : I was lost having big fun with Animoog...

    So today I follow your steps, and Quantum behaves much better! I set "link set up & pre-roll" on 0.10.
    It starts right and starts to shift slightly after some time... That was with 256 sample rate.

    With 512 sample rate it seems to play nicely right with 0.16

    So thank you again! I really appreciate this forum!!

    Cheers
    Chris

    glad to help! Have fun

  • edited February 17

    Hi @midiSequencer!

    I have just updated my previous message : still experiencing time shifting... (quantum going faster)

    (I am using cracklepot's set-up, Quantum in Audiobus to Aum.. If I keep everything in Aum only, I cannot start quantum in time, and I can only start it from the play button at the bottom of Quantum...)

  • @Kribee said:
    Hi @midiSequencer!

    I have just updated my previous message : still experiencing time shifting... (quantum going faster)

    (I am using cracklepot's set-up, Quantum in Audiobus to Aum.. If I keep everything in Aum only, I cannot start quantum in time, and I can only start it from the play button at the bottom of Quantum...)

    Obvious question, but you’re up-to-date with Quantum, right? Prior to 1.10 (and starting with 1.7) there was a timing rate issue where Quantum was rushing or lagging and going out of sync over time. Since 1.10 it has, in my tests, been stable; there’s an offset, but that can be fixed with the preroll setting.

    I’m hosting Quantum in Audiobus 2, running with 512 frame latency on an iPad Pro 9.7 running iOS 12.1 and have done timing tests lasting 15 minutes.

    Specs, screenshots of settings and video of the issue would help figure out what’s happening here.

  • @aplourde thank you for your comment.

    Quantum was purchased last week so I guess it's the last version...
    I have tried to play with offset setting but it quickly drift off anyway.

    I'll try to post some pics/videos this week.

    Cheers!

  • Does quantum have sample accurate timing? I can’t sync it with AUM. Always slightly out.

  • @TrevorLlewellyn said:
    Does quantum have sample accurate timing? I can’t sync it with AUM. Always slightly out.

    Is it rushing or lagging or just off by a constant amount?

    As noted above, there was an issue where Quantum was rushing, but that should have been fixed with version 1.10. However, while the timing is consistent, it is consistently late (about 1/32 note at 60 bpm).

    Adjusting the Link pre-roll to somewhere around 0.09 can get the timing correct; unfortunately that setting isn't persistent, so it has to be set for each session.

    @midiSequencer pretty please make it persistent!

  • @aplourde said:

    @TrevorLlewellyn said:
    Does quantum have sample accurate timing? I can’t sync it with AUM. Always slightly out.

    Is it rushing or lagging or just off by a constant amount?

    As noted above, there was an issue where Quantum was rushing, but that should have been fixed with version 1.10. However, while the timing is consistent, it is consistently late (about 1/32 note at 60 bpm).

    Adjusting the Link pre-roll to somewhere around 0.09 can get the timing correct; unfortunately that setting isn't persistent, so it has to be set for each session.

    @midiSequencer pretty please make it persistent!

    You nailed it! To my ears it is consistently late. Please can we have quantum corrected.

  • @TrevorLlewellyn said:

    @aplourde said:

    @midiSequencer pretty please make it persistent!

    You nailed it! To my ears it is consistently late. Please can we have quantum corrected.

    It is going to vary per device, so I'm going to change Quantum to at least default it to about 0.09 & allow it to restore if you change it.

    The reason for the need for a pre-delay is that Quantum is focused on real-time control - i.e. it calculates the steps as you are about to play them so you can tweak it live. This takes cpu time, so the small adjustment enables Quantum to run ahead of the host beat.

  • @midiSequencer said:

    @TrevorLlewellyn said:

    @aplourde said:

    @midiSequencer pretty please make it persistent!

    You nailed it! To my ears it is consistently late. Please can we have quantum corrected.

    It is going to vary per device, so I'm going to change Quantum to at least default it to about 0.09 & allow it to restore if you change it.

    The reason for the need for a pre-delay is that Quantum is focused on real-time control - i.e. it calculates the steps as you are about to play them so you can tweak it live. This takes cpu time, so the small adjustment enables Quantum to run ahead of the host beat.

    So is Quantum timing sample accurate?

  • @TrevorLlewellyn said:
    So is Quantum timing sample accurate?

    Ableton Link isn't sample accurate - you have to poll it for the timing (e.g. beat 1.998754 returned when I'm waiting for 2.0)
    Quantum timer itself is - I use an audio callback to determine time

  • Sorry I don’t really understand but if you say you can get it to sync accurately to ableton link automatically in an update that’s great! 👍

    When you to think this can be implemented?

  • @TrevorLlewellyn said:
    Sorry I don’t really understand but if you say you can get it to sync accurately to ableton link automatically in an update that’s great! 👍

    When you to think this can be implemented?

    I think what he's saying is that it's not going to be automatic. Unlike a piano roll where the notes "known" and timing can be established more easily, with a step sequencer, where you can be constantly changing the timing and value of every step, there's a certain amount of latency that's unavoidable. The Pre-Roll is a way to account for that latency, but it varies per device.

    I think it's fine to have the user set the proper pre-roll (and have it default to roughly the right value), my only note was that the pre-roll setting wasn't persistent so it had to be reset every session! Glad to know that's going to change!

  • edited June 22

    Ok maybe I can’t work it out, I have stepbud sequencer and that uses ableton link and syncs automatically on start/stop no problem.

  • You do have Ableton Link turned on in the Options menu in Quantum? Also you may have to play around with Phase settings in the Setup menu in Quantum.

  • Yep I have ableton link on in quantum, the other link enabled iOS apps I have automatically sync no problem like stepbud as an example. I think the dev will correct it with an update so all good.

  • edited July 11

    @midiSequencer said:

    @TrevorLlewellyn said:

    @aplourde said:

    @midiSequencer pretty please make it persistent!

    You nailed it! To my ears it is consistently late. Please can we have quantum corrected.

    It is going to vary per device, so I'm going to change Quantum to at least default it to about 0.09 & allow it to restore if you change it.

    The reason for the need for a pre-delay is that Quantum is focused on real-time control - i.e. it calculates the steps as you are about to play them so you can tweak it live. This takes cpu time, so the small adjustment enables Quantum to run ahead of the host beat.

    Would be great if you can update this adjustment please.

    @midiSequencer

  • @TrevorLlewellyn said:

    @midiSequencer said:

    @TrevorLlewellyn said:

    @aplourde said:

    @midiSequencer pretty please make it persistent!

    You nailed it! To my ears it is consistently late. Please can we have quantum corrected.

    It is going to vary per device, so I'm going to change Quantum to at least default it to about 0.09 & allow it to restore if you change it.

    The reason for the need for a pre-delay is that Quantum is focused on real-time control - i.e. it calculates the steps as you are about to play them so you can tweak it live. This takes cpu time, so the small adjustment enables Quantum to run ahead of the host beat.

    Would be great if you can update this adjustment please.

    @midiSequencer

    And here it is. :)

Sign In or Register to comment.