Audiobus: Your virtual music studio.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

How do I use Network MIDI as an input in AB3?

There used to be a "Network Session" that would show up as an input from time to time, often not when needed and for no specific reason would it work or not. But now, it never shows up at all. How do I use Network MIDI as an input in AB3 when it doesn't show up in the list in MIDI inputs?

So far the only way I've figured out is to use the IAA version of an app instead of the AU, since I can't get the AU versions to accept Network MIDI in AB3.

Comments

  • AB actually adds a layer on top of the network session, and will show the network endpoints instead - so, if there's a network endpoint available, you'll see the name of the device. Tap that to select it.

  • edited February 10

    @Michael said:
    AB actually adds a layer on top of the network session, and will show the network endpoints instead - so, if there's a network endpoint available, you'll see the name of the device. Tap that to select it.

    Hmm. I guess I'm not entirely sure what that means. On my PC I send MIDI input to "Network MIDI Destination" (using rtpMIDI over WiFi). If i open up an app, say, Model D in IAAP mode (for simplicity), tap on the config icon, then MIDI, I can make sure that "Network Session 1" is enabled. Then, when I play my MIDI controller through my DAW, it plays the Model D app on my iPhone.

    In AUM, I can chose Network MIDI as an input. But in AB3, I cannot any longer do so (I'm even using the beta) in the MIDI tab. Do I need to make a different choice in AB3 somewhere? Thanks, Michael.

  • edited February 10

    Could be there's a bug somewhere - you should be seeing the name of your PC in the picker. Have you tried connecting AB with another iOS device, if you have one? I'm curious to see if that shows up.

  • At first I missed the new option icons at the bottom of the screen. You have to choose “system” to see the network MIDI options.

  • edited February 10

    I see only BT for MIDI Devices and V.M.B. for Virtual Midi when connected to my PC. However, if I'm outputting from my old iPad to Network Session 1, then the iPad does show up in MIDI Devices as expected. I'm using 3.4(107).

  • I'm not a PC user so I'm not familiar with the procedure, but I believe Bonjour has to be installed for it to work right. Is that definitely done?

  • edited February 10

    Yep! I'm absolutely sure Bonjour is installed and working - it's required for rtpMIDI to work (and I also checked in Windows and confirmed). MIDI over WiFi works great with every other app I use it with, so it's definitely something in AB3, especially the latest version since the option used to eventually show up in AB before. Usually but not always - I sometimes had to start a different app and have it connect to Network MIDI before AB would recognize that it's there, but that doesn't work anymore for AB, either. Here's hoping you can borrow a PC, install iTunes and install rtpMIDI to test it out!

    tobias-erichsen.de/software/rtpmidi.html

Sign In or Register to comment.