Anybody able to assist with a few Kauldron and AUM questions?

Hi all

I'm kind of a newbie user and I just purchased Kauldron. I like the app but there are some things I'm having trouble figuring out and I hoped some of you high level users could help a novice with some basics.

(Note, I'm using an SL88 Studio controller by Studiologic)

1) Is there a way to control Volume in Kauldron. Yes, it's seems wierd but Kauldron doesn't have a "volume" setting, and I'm trying to map it to the CC Pedal input from my Controller so I can turn the synth down. Same issue by the way when attempting to just turn it off with the volume controller from the StudioLogic, it won't respond to it. The best I've been able to do is "expression", but that affects other running synths too, so not a good solution.

2) I do have AUM and could use that to turn off the Kauldron's volume in the "mix", but then I have the opposite problem, I don't appear to be able to use the Key Range Limiter in AUM to limit Kauldron to just a series of note range, it plays down the whole synth.

Grateful for any help - thank you!

Comments

  • Load Kauldron as an AU in AUM. Hook up your KB. Open AUM Midi Matrix and send KB to Kauldron and Midi Control.

    Open AUM Midi Control. Open Channel # that Kauldron is loaded on. Open Kauldron section to reveal AU parameters.

    Now that Kauldron AU parameters are showing, scroll down the list, just past half-way down until you find the parameter (Synth) Master Volume. Select it to show the mapping controls. Set channel to match your KB. Press Learn and move the control on your KB. The CC should update to the # of the KB controller and you can control Kauldron’s master volume with your KB now. If you don’t have any faders or knobs, the mod wheel works fine.

  • Really helpful and I appreciate the screenshots. Thank you for that - I'll give it a shot.

  • Any ideas on the note range problem?

  • I checked out your KB controller, and I would recommend mapping the third x/y stick to volume, using either x or y. Don’t use the spring-loaded x/y sticks.

    Regarding the note range issue, I was able to get my mod wheel controlling volume and Kauldron to only respond to notes C4 - C5 by setting up these parameters in Kualdron’s channel in AUM.

  • edited February 4

    @advancingdagger
    Kauldron has its own midi settings. Even when running as AU they apply, and by default it will listen to all midi ports available.
    Meaning when loaded in AUM you dont have to route anything to it in order to play it. When you route midi ports through AUM you actually duplicate those midi events, probably that's why you can't filter ranges - while you're filtering those notes that routed through AUM, you're still triggering all of them because by default Kauldron is listening to all ports.

    You definitely want to avoid duplicated midi events, so you will need to disable this default behavior in Kauldron. PREFS/MIDI Settings

    Then you can use AUMs built in router, note range filters, channel filters etc.

    Note Kauldron offers many options in its PREFS. Keyrange, ch filtering, midi maps etc, so depending on your setup and how you want to use it you may use these instead of AUMs alternative, but avoid using both at the same time.

  • @rcccp This is not how it is working for me. When I use Kauldron in AUM as an AU, it behaves as expected, with none of duplicate Midi events you mentioned. The built in AUM midi filtering for channels and note ranges work as well. I have never changed those settings in the Kauldron app you pointed out, but as an AU in AUM it works as expected.

  • @CracklePot said:
    @rcccp This is not how it is working for me. When I use Kauldron in AUM as an AU, it behaves as expected, with none of duplicate Midi events you mentioned. The built in AUM midi filtering for channels and note ranges work as well. I have never changed those settings in the Kauldron app you pointed out, but as an AU in AUM it works as expected.

    Strange, if I load Kauldron I can play it from let's say Beatstep without any midi routings made in AUM, also if e.g Refraktions is running it will trigger Kauldron unless I disable midi in.

  • @recccp said:

    @CracklePot said:
    @rcccp This is not how it is working for me. When I use Kauldron in AUM as an AU, it behaves as expected, with none of duplicate Midi events you mentioned. The built in AUM midi filtering for channels and note ranges work as well. I have never changed those settings in the Kauldron app you pointed out, but as an AU in AUM it works as expected.

    Strange, if I load Kauldron I can play it from let's say Beatstep without any midi routings made in AUM, also if e.g Refraktions is running it will trigger Kauldron unless I disable midi in.

    It happened to me this morning. Kauldron started acting up like you described, but it was previously working correctly. I completely rebuilt my AUM setup, and it was back to behaving correctly, so it seems to be a bug of some sort. Try rebuilding your AUM setup, close out all apps first, then see if it works normally once you are back up and running.

  • THank you all for that feedback. I will attempt to do this and see what I can come up with. So far, Kauldron's auto mapping allows me to set the sticks on my SL88 for various functions, and I can also "mute" the Kauldron Zone while playing layered with other instruments. But unlike the others Kauldron doesn't respond to me setting note ranges either in the AUM or even in my SL88's hardware (it has the ability for me to limit the keyboard range per "Zone", and that works with module, CMP Piano etc., but not Kauldron).

    I have to assume that you are all correct, particularly the comment about duplicate MIDI Mapping. Makes no sense that my SL88 can send a "mute" command to turn it off, but "volume" and "Key range" don't respond at all. I will have to play with both AUM and also direct with Kauldron to figure this out. You've at least given me a jumping off point and I thank you for that.

    Anybody know why the hell Kauldron's CC 7 setting doesn't map? Seems like it has no volume control that's mappable, maybe it's that duplicate MIDI Thing again.

    Real quick in the screenshot above where MIDI in is circled, we basically want that "on" right? (to avoid the dupe MIDI thing...)

  • Update - so I hit MIDI Learn in Kauldron and lo and behold, these little green tooltips with numbers overlaid the controls. "Volume" was indicated as number 11, which is "Expression" in the MIDI world, but I went ahead and mapped that to my Stick 2 with the fixed Y axis, and....iT WORKED.

    I can now completely dial down Kauldron in the mix using that stick. Dialing actual Zone Volume in the SL88 down still doesn't work, but at least I can get the desired layering outcome using that.

    Thanks everyone - appreciate the help and suggestions!

  • One last thing to try if you haven’t already. You can set Kauldron’s Midi note range directly in Kauldron’s prefs. Maybe that will work, since the other 2 methods (KB controller and AUM settings) did not work.

  • Good suggestion, I'll give that a try.

  • And...it worked. Thanks CracklePot == that's much better!

Sign In or Register to comment.