Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

AudioBus Woes VIDS

edited October 2014 in Support and Feedback

I'm not sure why this happens but it is happening more and more...

iPad AIR 2, 1024 buffer, iOS 8.1, all the latest apps, latest AB...


  • With 8.1 I have found that setting latency or buffer in any app to anything other than 256 can cause problems. It is as if there is a hard coded value in the iOS. Even if I am not using AB at all.

  • With iOS 8 the NSA is taking too much bandwidth.
    I noticed similar woes on my Air 2.

  • DebDeb
    edited October 2014

    @tedBPhx I've tried everything...reinstalled apps, airplane mode, gets worse at lower buffers, even 256... I can load up 6 synths and a midi sequencer all at once no soon as I open AB or other audio FX apps...I get glitches switching between apps...

  • edited October 2014

    @Deb I'm having similar experiences on my iOS devices running iOS 8.1. You don't seem to be able to open as many apps and chain them together. It seems sporadic and frequently involves losing sound.

    I loaded an Audiobus preset I'd created on an iPhone 5S running iOS 8.1 onto an iPad Air 2 running iOS 8.1 and I got the grey dots the first time I ran it but the sound was okay. Ran it a second time and the icons appeared normally but there was no sound from one of the apps. I closed out the two input apps (closing out one of the input apps didn't fix the sound) and added them back in again and got sound. I closed out the apps and reloaded them again in Audiobus using the preset, had sound issues with the same app, this time I closed out the app that was working, took out the app from Audiobus that wasn't and added it back into Audiobus without closing it again. I was able to reproduce this sequence three consecutive times for getting all of the apps working together again.

    I tried the same preset on an iPad mini 2 running iOS 7.1.2. Got the "Port Unavailable" message on the two input apps and the last effect app but the sound chain worked. I repeated this loading of the preset three times with the same results including the "Port Unavailable" error messages. The apps in this setup were older versions and the Sample Wiz app had Audiobus buttons that were frozen.

    At this point I tried running the same preset on the iPhone 5S again and got the same results as with the iPad Air 2 where I had to unload and reload apps to get the sound working correctly. I did however get some "busy" error messages and got glitching when switching between apps. There wasn't glitching when I stayed in an app and used the Audiobus menu to control other apps though. I didn't get any audio glitching switching between apps on the iPad Air 2 unless I rapidly switched between multiple apps. I didn't get any audio glitching on the iPad mini 2 setup either. When I put the iPhone in Airplane mode, I was able to load the preset and the sound chain worked but all of the icons in Audiobus had three dots. This wasn't the case with the iPad Air 2 as the behavior was the same whether or not Airplane mode was on or off. There are orientation issues with the iPhone 5S as some apps are upside down but no orientation issues on the iPad Air 2.

    Here's the preset I used.

    Starting to feel like a lab rat running through a maze trying to figure out how to consistently get some cheese.

  • edited October 2014

    i have to agree that using Audiobus on ios8.1 for multi routing is a buggy mess...

    I tried to get it working using iSEM into Cubasis into Auria...fuzzy audio...

    iSEM and Alchemy into sound from Alchemy....

    not a good time for any of us iOS musicians or Sebastian & Michael :(

  • Yes I agree, I have stopped trying anything adventurous for the time being because every 'audio funtime session' which includes an audiobus chain ends up being a 'rebooting diagnostic session'.... luckily I have a 7 day old baby boy who is making the lull seem totally appropriate ;)

  • @skoptic said:

    Yes I agree, I have stopped trying anything adventurous for the time being because every 'audio funtime session' which includes an audiobus chain ends up being a 'rebooting diagnostic session'.... luckily I have a 7 day old baby boy who is making the lull seem totally appropriate ;)

    CONGRATS on dat baby!!!

  • edited October 2014

    Toto, I have a feeling we are not in Kansas anymore.


    I think it's ios8 and less audiobus freaking out. I get all of the symptoms mentioned here and Michael and Sebastian are working on it, but I also get dropouts from iTunes and the podcast app when safari reloads ect.
    safari freezed 2 times while writing this ...
    at first I thought it wasn't so bad but the longer it continues the more frustrating it gets, I'm used to stuff freaking out and pinpoint the stuff that triggers it, but there is so much going wrong that it feels like a jack in the box. Guess we have to wait for whatever apple comes up next with ...
    argh, freeze nr. 3,4,5 and 6 ate the rest of this comment. Im fed up for now, going back to the macbook until the next iOS update.

  • edited October 2014

    The 'fuzzy mess' most likely stems from a measurement mode bug (it's broken in iOS 8) which we've found out in the last few days. The good news about it is that measurement mode is not really essential. The bad news it that it messes with everything, even without Audiobus. Stay tuned.

  • edited October 2014


    follow the yellow brick road

  • @Sebastian would we benefit from turning the AB measurement mode always on or off?

  • edited October 2014

    Off, yes.

    EDIT: Although I'm not entirely sure if turning it off in Audiobus solves all problems. Some apps enable it on their own, too.

  • Oh yeah, I forgot I even did this, but I was playing with my apps the first night after upgrading to iOS 8 and I definitely had to go change the latency settings to 256 where it was working fine on my Air on any setting the day before. I just made the change to fix the fuzz and cracks and totally forgot about it. Sounds like something's in the works as far as a fix is concerned.

  • I'm glad I updated early and hopefully the video was helpful to illustrate some issues...waiting patiently for the fixes so I can use Audiobus again...........

Sign In or Register to comment.