Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Follow action timing

edited January 29 in Loopy Pro

I am trying to use follow actions to unmute and mute inputs but there seems to be a very tiny delay that can miss midi notes hit right on time. Anyone have a good workaround for this? I have been using "Begin Record" to unmute the instrument I want to record. Is here a better way that has no lag?
I thought of creating tiny sixteenth note dummy clips before the intended clip that could carry the follow action. Or... using the "Stop Clip" of the clip before it maybe?

Comments

  • @jred said:
    I am trying to use follow actions to unmute and mute inputs but there seems to be a very tiny delay that can miss midi notes hit right on time. Anyone have a good workaround for this? I have been using "Begin Record" to unmute the instrument I want to record. Is here a better way that has no lag?
    I thought of creating tiny sixteenth note dummy clips before the intended clip that could carry the follow action. Or... using the "Stop Clip" of the clip before it maybe?

    You may need to experiment. Are these midi notes you are playing or notes from a sequencer. There are a few possible issues:

    • the incoming midi is actually slightly early
    • the follow action is triggering at the same time which results in a race
    • The instrument takes just long enough to unmute to miss the note on

    I would try a few things:

    • use an AUv3 midi monitor. Add a send midi action to my follow action set to fire “with last” that sends midi to the midi monitor. (I use streambyter). Also make the midi monitor the destination for the midi going to the instrument. Compare the timing of the events.

    • as a test, don’t mute/unmute the instrument but toggle output volume of the mixer channel output. Muting idles an instrument and it is possible that it may take just long enough for the synth to wake up that a note gets missed.

    I don’t know if this is still the case, but follow actions were originally not executed as part of the system audio thread which at that time could result in some behavior like this but that was a long time ago and might not be the case now.

  • @jred - It might help to disable idling on the synth. If it doesn't need to wake up from idle state it should respond quicker. The recommended test of toggling output volume would accomplish the same thing by keeping the synth from going idle.

    I'm assuming by "instrument" here you mean a plugin and not a hardware audio input. Does it happen with only one plugin, all plugins, or selected plugins? Also, are they AU or IAA inputs?

  • They are AU plugins (digistix, numa player). Now that you mentioned it, the only one I really notice is digistix. It is possible it is just more noticable since it is drums that are missing the first strike of the clip rather than the strings sounds I am using in numa player. I will try the output volume toggle tomorrow and what happens. Thanks!

  • Ok I went back and reprogrammed everything with input gain adjustments instead of input mute changes. It does seem to make a difference on Digistix. The only problem is now I have random adjustments in gain on other instruments. I have gone through and removed all of the follow actions and put them all back in again but the problem persists. One track I have created a follow action to adjust the input gain of the bass all the way down but it ignores the follow action. The other time I set a follow action to turn the input gain of the acoustic up to unison and it ignores it. I have triple checked that there are no other interfering follow actions. Has anyone here had these sorts of problems? Are there workarounds?

  • @jred said:
    Ok I went back and reprogrammed everything with input gain adjustments instead of input mute changes. It does seem to make a difference on Digistix. The only problem is now I have random adjustments in gain on other instruments. I have gone through and removed all of the follow actions and put them all back in again but the problem persists. One track I have created a follow action to adjust the input gain of the bass all the way down but it ignores the follow action. The other time I set a follow action to turn the input gain of the acoustic up to unison and it ignores it. I have triple checked that there are no other interfering follow actions. Has anyone here had these sorts of problems? Are there workarounds?

    If you have any cases where a follow action doesn’t fire, please post it (as a zip) with instructions on how to trigger the problem.

    Are you using the latest App Store version?

  • I have now gone back through and reprogrammed again this time using muting again. Same sorts of problems. I will program a follow action and it is completely ignored. Is there some sort of setting that could override follow actions for a clip or a input?

    In one case I created three different follow actions trying to get the acoustic to unmute. Two at the end of preceding clips (end recording) and one in the acoustic clip (begin recording) none of them have the effect of unmuting the acoustic input. This is very glitchy and disappointing.

  • @jred said:
    I have now gone back through and reprogrammed again this time using muting again. Same sorts of problems. I will program a follow action and it is completely ignored. Is there some sort of setting that could override follow actions for a clip or a input?

    In one case I created three different follow actions trying to get the acoustic to unmute. Two at the end of preceding clips (end recording) and one in the acoustic clip (begin recording) none of them have the effect of unmuting the acoustic input. This is very glitchy and disappointing.

    It would be very helpful if you would post a project with instructions on how to reproduce the problem. Since no one has reported problems like this, it is hard to know what might cause them.

    Without an example, it is really hard to know why it isn’t working for you and impossible for Michael to fix if there is a problem…since follow actions seem to executing correctly in the cases we know about .

    Make sure you are using the latest version. 1.1.17 addressed a case where a stop follow action might not fire. It wouldn’t have been identifiable without an example.

    Being able to examine the project would allow Michael to identify the issue and resolve it and might give me a chance to advise you on an alternative.

  • edited January 31

    Ok, how do I post a project? I am using the latest version of the App.

  • Zip the project.

    If the zip isn’t huge, you can attach it to a forum post?

    If it is too large to post and you have Dropbox or Google Drive (or the like), you could post a link.

    Or you could email it to [email protected]

    Make sure to provide directions for reproducing the problem.

  • Thanks!

Sign In or Register to comment.