Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Cubasis and Moog arpeggiator issue SOLVED

I love making music on my iPad. I’m really trying to learn my way around but I admit it’s hard. Recently I’ve had increasing frustrations so I’ve decided to share these ‘issues’ where possible on short YouTube videos where I might get answers and you might share your solutions and knowledge with others

«1

Comments

  • tjatja
    edited January 21

    On a second look, this is a MIDI track.
    So you recorded the MIDI, not the audio.

    As far as I can remember, Cubasis STILL does not allow to record audio from an AU MIDI Synth. You need to freeze the track to get the audio.

  • tjatja
    edited January 21

    Out of curiosity, I wanted to test with an IAA instance of Model 15 in Cubasis 3.

    Two tries.

    In both cases, Cubasis just totally froze when tapping on "Model 15" in the (STILL not searchable) list of IAA plugins.

    I am short of finally deleting Cubasis 3, @LFS !

    Every time I go back and try something, it ends in a similar disaster.

    iPad Air 3, iPadOS 15.7.2

  • It may the au synth midi out issue

  • @tja said:
    On a second look, this is a MIDI track.
    So you recorded the MIDI, not the audio.

    As far as I can remember, Cubasis STILL does not allow to record audio from an AU MIDI Synth. You need to freeze the track to get the audio.

    Thanks for your replies. I can record it onto a separate audio track although the level is low? I’m about to show another video using Audio Evolution where I can’t even work out how to do that! Drives you mad 😡

  • Hang in there… music/audio production is a skill which needs to be practiced. And for most of us ‘practice’ means ‘doing it ALL the wrong ways until the right way is the only thing left’ !

    Hopefully solving the issues that emerge is fun too… it is for me.

    And although it’s trite , read the manual twice, and comb this forum ( and the Cubasis one at Steinberg ) for tidbits of info. You’ll be surprised at what you find.

  • @ltf3 said:
    Hang in there… music/audio production is a skill which needs to be practiced. And for most of us ‘practice’ means ‘doing it ALL the wrong ways until the right way is the only thing left’ !

    Hopefully solving the issues that emerge is fun too… it is for me.

    And although it’s trite , read the manual twice, and comb this forum ( and the Cubasis one at Steinberg ) for tidbits of info. You’ll be surprised at what you find.

    I do promise to post solution videos as well where possible as I’m sure a problem shared is still a problem but hopefully someone else’s with more experience and skill 😂. I do enjoy this hobby but it can be extremely frustrating to find such wide variations in how DAW’s stifle work flow.

  • @tja said:
    Out of curiosity, I wanted to test with an IAA instance of Model 15 in Cubasis 3.

    Two tries.

    In both cases, Cubasis just totally froze when tapping on "Model 15" in the (STILL not searchable) list of IAA plugins.

    I am short of finally deleting Cubasis 3, @LFS !

    Every time I go back and try something, it ends in a similar disaster.

    iPad Air 3, iPadOS 15.7.2

    IAA is depreciated; use AUV3. Always so much drama.

  • @musikeer said:

    @tja said:
    Out of curiosity, I wanted to test with an IAA instance of Model 15 in Cubasis 3.

    Two tries.

    In both cases, Cubasis just totally froze when tapping on "Model 15" in the (STILL not searchable) list of IAA plugins.

    I am short of finally deleting Cubasis 3, @LFS !

    Every time I go back and try something, it ends in a similar disaster.

    iPad Air 3, iPadOS 15.7.2

    IAA is depreciated; use AUV3. Always so much drama.

    You did not get the point.

    I wanted to test in how far, Cubasis can record the audio from an IAA App - without freezing the track.
    And I don't care if IAA is depricated or not - if you ask me wether either AU or IAA shall be removed, I may well opt to continue with IAA instead of AU!
    I very much prefer full-sized Apps and never ever had the need for multiple instances of an App.
    This will continue to be true for me, until all hosts allow for full-sized AU windows and there is no problem anymore with AU MIDI or AU audio ...

    Just to give some drama :wink:

  • Why fight it? And why blame Cubasis for not passing your test of outdated tech? Works fine for actually creating music. Size doesn’t matter if it sounds good. But whatever rows your boat, all good.

  • edited January 22

    @tja said:
    Out of curiosity, I wanted to test with an IAA instance of Model 15 in Cubasis 3.

    Two tries.

    In both cases, Cubasis just totally froze when tapping on "Model 15" in the (STILL not searchable) list of IAA plugins.

    I am short of finally deleting Cubasis 3, @LFS !

    Every time I go back and try something, it ends in a similar disaster.

    iPad Air 3, iPadOS 15.7.2

    I just tried recording Model 15 audio via IAA into Cubasis 3 and it worked fine. Model 15 presents the audio to Cubasis via its Audio Bridge module so you have to route the audio signal there within Model 15 ( you’ll have to follow the patch cords to work out what's going on! ) But Cubasis behaved well … and responded to the IAA controls shown in the Model 15 GUI when used this way. Hit the return to start button, then the record, got a count in and played the Model 15 on its screen keyboard. Stopped recording, pressed the Cubasis icon and returned to Cubasis with a nice audio track.

    Tried a few otheR IAA apps ( Model D, Guitarism, ) with no issues.

    Might go without saying that Model 15 audio directly into Cubasis is much easier to route using AudioBus 3 . Then you can just use the “ Model 15” main outs in AudioBus ( not the Audio Bridge connection) straight into CB . No patch cord fiddling.

    I’m on iOS 16.2 with an iPad Gen 9 … very base level.

  • @tja said:
    Out of curiosity, I wanted to test with an IAA instance of Model 15 in Cubasis 3.

    Two tries.

    In both cases, Cubasis just totally froze when tapping on "Model 15" in the (STILL not searchable) list of IAA plugins.

    I am short of finally deleting Cubasis 3, @LFS !

    Every time I go back and try something, it ends in a similar disaster.

    iPad Air 3, iPadOS 15.7.2

    Try opening Model 15 before you open Cubasis 3. Then open it as an IAA.

    But really, just use the AUV3 when given the option.

  • The OP video does show that the AUv3 version is used as far as I can tell(?), so seems the discussion has been sidetracked slightly.

    Anyway, could the problem be due to holding down the keys in Model 15 and only then start the recording in Cubasis? I.e. missing the MIDI event for note on. It does work fine for me if I start recording in Cubasis first and then start playing.

  • @Vip8888 said:
    The OP video does show that the AUv3 version is used as far as I can tell(?), so seems the discussion has been sidetracked slightly.

    Anyway, could the problem be due to holding down the keys in Model 15 and only then start the recording in Cubasis? I.e. missing the MIDI event for note on. It does work fine for me if I start recording in Cubasis first and then start playing.

    Thanks to all who have participated in the discussion. For clarity yes it was AUv3. I have no doubt it’s a resolvable user knowledge issue rather that a Cubasis issue. I do think though that having to overcome various challenges does slow us down. I think I will try to AudioBus option as it seems simple but that’s my point ANOTHER app required to just get on with your music making. Will we ever get the perfect DAW for iOS?

  • @Vip8888 said:
    The OP video does show that the AUv3 version is used as far as I can tell(?), so seems the discussion has been sidetracked slightly.

    Anyway, could the problem be due to holding down the keys in Model 15 and only then start the recording in Cubasis? I.e. missing the MIDI event for note on. It does work fine for me if I start recording in Cubasis first and then start playing.

    Going to try this solution later. Will let you know if it works for me. 🙏🏼

  • @Vip8888 said:
    The OP video does show that the AUv3 version is used as far as I can tell(?), so seems the discussion has been sidetracked slightly.

    Anyway, could the problem be due to holding down the keys in Model 15 and only then start the recording in Cubasis? I.e. missing the MIDI event for note on. It does work fine for me if I start recording in Cubasis first and then start playing.

    Tried this and unfortunately still hasn’t worked. What I’m left with is just odd midi notes as previously? Strange but true 😲.

  • Itf3. The AudioBus option does work. It’s inelegant given the promise of AUv3, but it does record the audio crystal clear unlike recording from a midi track to an audio track using only Cubasis which I found messed the audio levels. In addition it’s nowhere near as inelegant as using AUM to record into Cubasis which I find to be much more faffy! All just personal preferences I know. 🙏🏼.

  • Just wanted to underscore for anyone on here who like me doesn’t know or understand….as far as Cubasis goes it seems to me the simplest option to get audio live or sequenced out of other apps like gadget or ielectribe and so on and in to Cubasis AudioBus seems the way to go. I’ve had a few crashes etc but all in all over the past couple of days this has worked the best of all the various workarounds. Hope this helps some other poor sod stuck in La La land.

  • @ZooBaaDoo I just tried your setting on my iPad. In Cubasis 3, i added a midi track and loade Model 15. Then selected „Noonien/Organ Transplant“ as preset, selected the Animoog controller in Model 15 and enabled the ARP.

    Then i pressed Record and Play in Cubasis and started playing after the 4 ‚blips‘ of the pre-count metronom. First i played a single note, then added a second one to start arping. Next i played a new chord (that arped). After that i hit stop and rewind.

    The midi track contained my 5 notes and the playback sounded as initially played..

    .

    With this in mind i rewatched your video: You first started to play and then hit recor/play - this missed the first note pressed. And then if one looks closely, one can see that the bar/beat counter start at a negative number - so there was aa pre-count before the actual recording - this discarded more of the key presses. It seems that only the last key-press was recorded. (Note-offs without a previous note-on are discarded)

    IIRC one can disable the count-in In Cubasis - or try to wait until it finished and then start playing.

  • LFSLFS
    edited January 25

    @ZooBaaDoo said:
    I love making music on my iPad. I’m really trying to learn my way around but I admit it’s hard. Recently I’ve had increasing frustrations so I’ve decided to share these ‘issues’ where possible on short YouTube videos where I might get answers and you might share your solutions and knowledge with others

    Hi @ZooBaaDoo,

    You've pressed the Moog Model 15 keyboard first, and pressed the Cubasis record key afterwards.
    I'm sorry, but you have to press the recording button first.

    To learn more about the Cubasis workflow, please check out our "Getting started with Cubasis" tutorial, which also includes chapters about how to use AU effects and instruments plug-ins.

    Hope that helps!

    Stay safe,
    Lars

  • LFSLFS
    edited January 25

    Hi @ZooBaaDoo, Hi all,

    If you instead want to stick to the initial use case above to record an external instruments to an audio track (or better: "what's already audible"), here is a short example clip that demonstrates how to do this via using "Inter-App Audio Generators" with Cubasis:

    https://we.tl/t-9qdFYU9rw0

    The clip expires on Feb 1, 2023.

    In the clip example, Model 15 already "plays" before recording in Cubasis is started. The recording contains "everything audible" though...

    P.S.: Apple replaced Inter-App Audio many years ago with the introduction of Audio Unit support. Inter-App Audio comes with many limitations which we've described in this article (from Oct 2016). If you encounter IAA loading issues, it often helps to first launch the stand alone app version of the 3rd party instrument.

    Hope that helps!

    Best,
    Lars

  • edited January 25

    Hi all sorry tried to post a new screen shot video but failed. I tried pressing the record button first and got exactly the same result it didn’t record the sequence just odd notes?

  • edited January 25

    Here’s the video 😡😡
    What is most annoying is that other people seem to be able to do it! I feel victimised now😂

  • This would be SO easy to do if Cubasis had real busses...
    ...output any track to a bus and use the bus as an input for an audio track and record it...

    Will this happen during 2023 or do we have to wait a few more years?!

  • edited January 25

    very simple to explain.
    you recorded midi. and the arpeggiator output is not recorded, only the triggers.

    so either cubasis is not taking the arpeggiators output into account or you forgot to say the synth to output this, so that cusbasis can record this.

  • I've never gotten the Model 15 sequencer to output any midi...
    ...just the notes I play on the keyboard.

  • edited January 25

    @Samu said:
    This would be SO easy to do if Cubasis had real busses...
    ...output any track to a bus and use the bus as an input for an audio track and record it...

    Will this happen during 2023 or do we have to wait a few more years?!

    but any track can be routed to a track which just has an effect right?

    Think it does ( when I tested )

  • @sigma79 said:

    but any track can be routed to a track which just has an effect right?

    Only to 'effects' that have and support side-chain input...

  • @Samu said:

    @sigma79 said:

    but any track can be routed to a track which just has an effect right?

    Only to 'effects' that have and support side-chain input...

    I think sidechain means its built for using across channels.

    but normal apps etc

    All Id need is to build a song elsewhere 99%. Mix in cubasis.

    Then maybe add sub group effects.

    A reverb on synths. Ideally there might be send amounts.

    A compressor just for drums etc.

    Can I only choose sidechain apps?

    Is there send amounts?

  • edited January 25

    So then it is very strange.
    Just tried with the AudioUnit of Model 15 and it works as expected.
    Cubase records (merely) the triggers and the synth plays back the arpeggiator as supposed after the recording was made.

    So there is virtually no difference between the recording audio and the played back audio output.

    Another thing is, that this synth does not output the arpeggio but merely handles this internally. This makes it impossible to record the arp/sequencer output for usage with something different.

    But I do not know whether Cubasis would take the MIDI output of the synth then at all.

Sign In or Register to comment.