Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Can’t get my keystep pro to receive midi clock from aum

Hey everyone, I’m having trouble getting my keystep pro to receive midi clock from aum. I’ve toggled the options for it both on the keystep end and the aum end and I just can’t get it to send/receive.

Aum is set to send clock, and is routed to the keystep. The keystep is set to receive midi clock, but it still won’t link up.

Any suggestions would be more than welcome. Thanks in advance


  • When you say the KeyStep isn't receiving midi clock, do you mean it's not receiving tempo, or that it's not receiving start/stop from AUM's transport, or ... ?

    Is the KeyStep connected via USB? If so, did you select USB Mode for clock on the KeyStep and 24ppq for the clock rate?

  • edited December 2022

    Had something like this with the microfreak. Rebooting the iPad fixed it. Sometimes when it stops sending midi clock replugging the usb connection helps, but a reboot fixes it for sure.

  • @Alfred, @LazerJim
    Which iOS versions are you using?

  • @rs2000
    I am using 15.7 on the latest iPad mini.

  • I had the same issue… check this setting.
    When you choose the routing destination for MIDI clock this setting is not automatically checked.
    Hope that fixes it for you.

  • Thanks for getting back to me guys. So what I meant by receiving clock was tempo specifically. I reset the usb connection first, all good there. I then double checked all the settings on aum, all good there as well. I went back through the settings on the keystep and noticed that I had selected both clock send and clock receive derpy me lol. I of course changed that to just clock receive and also turned on transport receive. There are four different options for transport receive: off, mmc, realtime, or both. I selected both. After all that it linked right up. Success!! Thanks for helping this absolute novice lol!!

  • @LazerJim . MIDI Realtime transport control messages are one-byte messages for Start (0xFA), Continue (0xFB), and Stop (0xFC). MMC uses SysEx messages that allow more complete control of the device. You probably only need to enable one or the other, depending on how your app is configured. But it likely doesn't hurt to enable both.

Sign In or Register to comment.