Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Retrospective recording

@MisplacedDevelopment mentioned in another thread problems with or confusion about how retrospective recording works. Let’s use this thread to clarify the topic.

Basic rundown, retrospective looping when quantize is on, captures the last complete master cycle’s worth of input.

So if the cycle length is 8 and the clock is running and has run for 8 or more bars, you can tap on a loop at any time to capture the previous cycle’s content.

So, if you tap in bar 10 or 11, you capture bars 1-9 (the last complete cycle).

If quantize is off, you capture 8 bars back from when you tapped.

If you tap before 8 bars have passed , it will record and count out after 8 bars.

If something else happens, you may have run into a bug. If something strange happens, please post a demonstration that includes the settings.

Comments

  • Thanks for the explanation @espiegel123 . I will revisit my experimentation with retrospective recording later and hopefully it will make more sense with your comments to guide me.

  • @MisplacedDevelopment said:
    Thanks for the explanation @espiegel123 . I will revisit my experimentation with retrospective recording later and hopefully it will make more sense with your comments to guide me.

    There were some cases where it didn't work as it should and I believe they have been fixed. So, if something doesn't work as I've described please post a demo..also it is possible my explanation is poor.

  • I have had a little play and it makes more sense now, thank you. My misunderstanding came from thinking that the retrospective recording buffer was tied to the length of the clip rather than the master cycle. I changed the master cycle length to 10 to match the clip length and it now works like I expected it to without requiring further changes.

    Can we explain why resetting the tempo settings has, or at least appears to have, the same effect? In this case, I did a reset and manually set the tempo to the suggested 120 (cycle count remained the default of 1). After doing this the retrospective recording also worked as expected.

  • @MisplacedDevelopment said:
    I have had a little play and it makes more sense now, thank you. My misunderstanding came from thinking that the retrospective recording buffer was tied to the length of the clip rather than the master cycle. I changed the master cycle length to 10 to match the clip length and it now works like I expected it to without requiring further changes.

    Can we explain why resetting the tempo settings has, or at least appears to have, the same effect? In this case, I did a reset and manually set the tempo to the suggested 120 (cycle count remained the default of 1). After doing this the retrospective recording also worked as expected.

    I am not sure what you mean about tempo changing how things work.

    Can you say more?

    The retrospective record length should always be the master cycle length.

    You might find the section related to retrospective looping useful on https://wiki.audiob.us/doku.php?id=loopy_pro&s[]=retrospective

  • @espiegel123
    I think that clears things up perfectly

  • edited July 29

    @espiegel123 said:

    @MisplacedDevelopment said:
    I have had a little play and it makes more sense now, thank you. My misunderstanding came from thinking that the retrospective recording buffer was tied to the length of the clip rather than the master cycle. I changed the master cycle length to 10 to match the clip length and it now works like I expected it to without requiring further changes.

    Can we explain why resetting the tempo settings has, or at least appears to have, the same effect? In this case, I did a reset and manually set the tempo to the suggested 120 (cycle count remained the default of 1). After doing this the retrospective recording also worked as expected.

    I am not sure what you mean about tempo changing how things work.

    Can you say more?

    The retrospective record length should always be the master cycle length.

    You might find the section related to retrospective looping useful on https://wiki.audiob.us/doku.php?id=loopy_pro&s[]=retrospective

    Sorry, I realise I left a lot of detail out there. I came across the behaviour while running Loopy standalone in sync with NS2 but the behaviour is the same when hosted as an AU in AUM so I have provided some instructions for this as it is a simpler setup. Here are two scenarios, for comparison:

    Common setup:
    1. Load fresh Loopy into FX slot in AUM, recording MIC
    2. Set first orange donut to length 10, Playback Settings->Time Stretch OFF, Recording Settings->Retrospective Recording ENABLED, other options left as defaults
    3. Enable Ableton Link in AUM and Loopy (I discovered after doing these steps that this is not significant, host sync is the same)

    Scenario 1:
    1. Do steps in “Common setup”.
    2. Start AUM, wait until the end of the 10th bar and tap the donut.
    3. The donut starts recording rather than showing the previous 10 bars.

    This I can fix, thanks to your advice about setting the master cycle length to 10 before starting the transport.

    Scenario 2:
    1. Do steps in “Common setup”.
    2. Tap the tempo to bring up the control window
    3. Tap “Reset”
    4. Tap the “120” in the manual tempo selector scroller at the top. This causes the manual tempo entry popup to appear.
    5. Press return to accept 120 as the tempo
    6. Note that the master cycle is still set to 1 bar
    7. Exit the tempo control panel
    8. Start AUM, wait until the end of the 10th bar and tap the donut.
    9. This time the 10 bars I recorded are played back and the donut continues to keep in sync even after clearing and recording further takes.

    After writing these steps I quickly tested with just host sync rather than Link and the behaviour is the same. The only difference is that you do not get to choose the tempo after pressing Reset as it is blanked out with “External”.

    The problem I had is now sorted but I’m curious to know what is happening under the covers when I hit Reset which causes things to behave differently.

    Cheers.

  • @MisplacedDevelopment said:

    @espiegel123 said:

    @MisplacedDevelopment said:
    I have had a little play and it makes more sense now, thank you. My misunderstanding came from thinking that the retrospective recording buffer was tied to the length of the clip rather than the master cycle. I changed the master cycle length to 10 to match the clip length and it now works like I expected it to without requiring further changes.

    Can we explain why resetting the tempo settings has, or at least appears to have, the same effect? In this case, I did a reset and manually set the tempo to the suggested 120 (cycle count remained the default of 1). After doing this the retrospective recording also worked as expected.

    I am not sure what you mean about tempo changing how things work.

    Can you say more?

    The retrospective record length should always be the master cycle length.

    You might find the section related to retrospective looping useful on https://wiki.audiob.us/doku.php?id=loopy_pro&s[]=retrospective

    Sorry, I realise I left a lot of detail out there. I came across the behaviour while running Loopy standalone in sync with NS2 but the behaviour is the same when hosted as an AU in AUM so I have provided some instructions for this as it is a simpler setup. Here are two scenarios, for comparison:

    Common setup:
    1. Load fresh Loopy into FX slot in AUM, recording MIC
    2. Set first orange donut to length 10, Playback Settings->Time Stretch OFF, Recording Settings->Retrospective Recording ENABLED, other options left as defaults
    3. Enable Ableton Link in AUM and Loopy (I discovered after doing these steps that this is not significant, host sync is the same)

    Scenario 1:
    1. Do steps in “Common setup”.
    2. Start AUM, wait until the end of the 10th bar and tap the donut.
    3. The donut starts recording rather than showing the previous 10 bars.

    This I can fix, thanks to your advice about setting the master cycle length to 10 before starting the transport.

    Scenario 2:
    1. Do steps in “Common setup”.
    2. Tap the tempo to bring up the control window
    3. Tap “Reset”
    4. Tap the “120” in the manual tempo selector scroller at the top. This causes the manual tempo entry popup to appear.
    5. Press return to accept 120 as the tempo
    6. Note that the master cycle is still set to 1 bar
    7. Exit the tempo control panel
    8. Start AUM, wait until the end of the 10th bar and tap the donut.
    9. This time the 10 bars I recorded are played back and the donut continues to keep in sync even after clearing and recording further takes.

    After writing these steps I quickly tested with just host sync rather than Link and the behaviour is the same. The only difference is that you do not get to choose the tempo after pressing Reset as it is blanked out with “External”.

    The problem I had is now sorted but I’m curious to know what is happening under the covers when I hit Reset which causes things to behave differently.

    Cheers.

    I have no idea why it is behaving like that in the second case. In any case, setting a donut’s length isn’t how to set the retrospective recording length.

    If you stick to using the master cycle length, you shouldn’t have any trouble. It can be handy to have button set up that sets the master cycle length then retrospective records the next tapped loop.

    You can change the master cycle length on the fly just before the retrospective looping action AS LONG AS the length you are setting is no longer than the longest cycle length used in the session.

    Retrospective recording grows its buffer if needed when the cycle length changes and never shrinks it. So, if the cycle has been 16, you can set it to 2 or 4 or back to 16 on the fly.

  • Good idea on having a button to change the master cycle length, I shall look into that some more. Hopefully I won’t get caught out by the session master cycle limit but it is good to be aware of it.

    Perhaps a question for @Michael - is there any significant cumulative cost to having multiple loops sitting in retrospective recording state, or is there minimal overhead as we are just maintaining the single master cycle buffer which gets dumped from as needed? I was thinking along the lines of having multiple “best take” loops which might later be combined into a “best of all the best takes” using an audio editor.

  • edited July 30

    @MisplacedDevelopment said:
    Good idea on having a button to change the master cycle length, I shall look into that some more. Hopefully I won’t get caught out by the session master cycle limit but it is good to be aware of it.

    Perhaps a question for @Michael - is there any significant cumulative cost to having multiple loops sitting in retrospective recording state, or is there minimal overhead as we are just maintaining the single master cycle buffer which gets dumped from as needed? I was thinking along the lines of having multiple “best take” loops which might later be combined into a “best of all the best takes” using an audio editor.

    Nope, no additional cost - in fact no additional cost compared to not having retro on, as there’s always a buffer going. And it’s just one buffer

  • @Michael said:

    @MisplacedDevelopment said:
    Good idea on having a button to change the master cycle length, I shall look into that some more. Hopefully I won’t get caught out by the session master cycle limit but it is good to be aware of it.

    Perhaps a question for @Michael - is there any significant cumulative cost to having multiple loops sitting in retrospective recording state, or is there minimal overhead as we are just maintaining the single master cycle buffer which gets dumped from as needed? I was thinking along the lines of having multiple “best take” loops which might later be combined into a “best of all the best takes” using an audio editor.

    Nope, no additional cost - in fact no additional cost compared to not having retro on, as there’s always a buffer going. And it’s just one buffer

    Excellent, thanks.

  • @Michael said:

    @MisplacedDevelopment said:
    Good idea on having a button to change the master cycle length, I shall look into that some more. Hopefully I won’t get caught out by the session master cycle limit but it is good to be aware of it.

    Perhaps a question for @Michael - is there any significant cumulative cost to having multiple loops sitting in retrospective recording state, or is there minimal overhead as we are just maintaining the single master cycle buffer which gets dumped from as needed? I was thinking along the lines of having multiple “best take” loops which might later be combined into a “best of all the best takes” using an audio editor.

    Nope, no additional cost - in fact no additional cost compared to not having retro on, as there’s always a buffer going. And it’s just one buffer

    Plan to do the same when you introduce midi looping? Same retrospective recording of the midi buffer?

  • @AlmostAnonymous said:

    @Michael said:

    @MisplacedDevelopment said:
    Good idea on having a button to change the master cycle length, I shall look into that some more. Hopefully I won’t get caught out by the session master cycle limit but it is good to be aware of it.

    Perhaps a question for @Michael - is there any significant cumulative cost to having multiple loops sitting in retrospective recording state, or is there minimal overhead as we are just maintaining the single master cycle buffer which gets dumped from as needed? I was thinking along the lines of having multiple “best take” loops which might later be combined into a “best of all the best takes” using an audio editor.

    Nope, no additional cost - in fact no additional cost compared to not having retro on, as there’s always a buffer going. And it’s just one buffer

    Plan to do the same when you introduce midi looping? Same retrospective recording of the midi buffer?

    Yup

Sign In or Register to comment.