Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Wotja 22 - Generative Music App & Plug-in Host (Free, Pro; AUv3 / VST3)

1246719

Comments

  • @UMCorps said:
    On the last day of the year, a little ambient track looking forward to tomorrow.

    Sounds glorious. And deceptively simple looking :smile:

    Happy New Year to all!

    Pete

  • Really good, thanks, @UMCorps

  • @UMCorps That sounds really wonderful.

    A happy (Wotja) new year everybody.

  • The https://intermorphic.com website should be fully refreshed within the next 24 hours.

    The website update has been a monumental effort from Tim.

    Not all new Wotja 22 features are going to be fully documented on day 1 (!) but we’ll fill in the gaps soon.

    The site tracks 30+ years of continuous development and innovation. I hope you can find the time and root around; there is an awful lot of history to discover and ponder, as well as of course all the new stuff!

    Best wishes, Pete

  • I’m just trying to figure out something; on an intel mac stuck on 10.13.x there will only be the standalone version available from what I read, ie the plugin version needs 10.15+ ?

  • edited December 2021

    @Krupa said:
    I’m just trying to figure out something; on an intel mac stuck on 10.13.x there will only be the standalone version available from what I read, ie the plugin version needs 10.15+ ?

    Hi! Yes, that's right. AUv3 technology came-in with 10.15+

    https://developer.apple.com/documentation/audiotoolbox/audio_unit_v3_plug-ins/creating_custom_audio_effects

    That also means (of course) that the AUv3 hosting won't work prior to 10.15.x

    We've not got any of those very old macOS builds machines for testing on, so I'm not totally sure what would happen. I'd recommend you first try the Free version of Wotja 22, to see if that works OK on your Intel macOS machine, before considering buying Wotja 22 Pro.

    Best wishes, Pete

  • @impete said:

    @Krupa said:
    I’m just trying to figure out something; on an intel mac stuck on 10.13.x there will only be the standalone version available from what I read, ie the plugin version needs 10.15+ ?

    Hi! Yes, that's right. AUv3 technology came-in with 10.15+

    https://developer.apple.com/documentation/audiotoolbox/audio_unit_v3_plug-ins/creating_custom_audio_effects

    That also means (of course) that the AUv3 hosting won't work prior to 10.15.x

    We've not got any of those very old macOS builds machines for testing on, so I'm not totally sure what would happen. I'd recommend you first try the Free version of Wotja 22, to see if that works OK on your Intel macOS machine, before considering buying Wotja 22 Pro.

    Best wishes, Pete

    Ah gutted, I’m still on my ancient yet incredibly well preserved and functioning Mac Pro from 2009 😁

    I was considering a pre order as the price seems good for what it offers over the two systems… maybe you’re right, I’ll try the free and see, maybe a month or two of sub will push me over the edge later; I’m promising myself I’ll finally upgrade to a silicon Mac at some point this year, just my old one keeps on being so good still it’s hard to justify the thousands it’ll cost to beat it 😅

    Thanks,

    Chris

  • @Krupa said:
    Ah gutted, I’m still on my ancient yet incredibly well preserved and functioning Mac Pro from 2009 😁

    Hi Chris,

    Great work - they last for ever if you're lucky! However, my keyboards keep wearing out :smile: - my new M1 is very nice however.

    I was considering a pre order as the price seems good for what it offers over the two systems… maybe you’re right, I’ll try the free and see, maybe a month or two of sub will push me over the edge later; I’m promising myself I’ll finally upgrade to a silicon Mac at some point this year, just my old one keeps on being so good still it’s hard to justify the thousands it’ll cost to beat it 😅

    Don't forget - you can use the Free one without a subscription, just to verify first that it works OK for you.

    Best wishes, Pete

  • Cheers Pete 👍👍

  • The site update is now live at https://intermorphic.com

    Best wishes, Pete

  • Hi @impete happy 2022! I downloaded Wotja 22 Pro, rebooted and it fails on start every time while scanning hosted plug-ins. It seems to be scanning all my AU3s and I've got a few hundred installed so may be hitting a capacity issue.

    Any thoughts? If there's Wotja logs anywhere that you can point me to, I'm happy to either go through them or forward them to you. No rush, as it's 36C here in Melbourne Australia today so I'm gonna hit the beach

    256Gb iPad Air 3rd gen (2019?) running iOS 15.2. I've got 35Gb free so space doesn't seem to be the issue

  • edited December 2021

    Does last year's Wotja 21 still work just fine and stable with the most current macOS and iOS? And, does the full "Pro" fee of $3.99 get you pretty much everything in the app... just no more updates?

    I've still got an older version (2017) from before they went with this subscription/annual fee, and it still pretty much works as well as it did back when I purchased it. Can those who've been using Wotja 21 verify if that's the same case now?

    Will the paks that work in my 2017 Wotja still import/load into Wotja 21?

  • @skiphunt said:
    Does last year's Wotja 21 still work just fine and stable with the most current macOS and iOS? And, does the full "Pro" fee of $3.99 get you pretty much everything in the app... just no more updates?

    I've still got an older version from before they went with this subscription/annual fee, and it still pretty much works as well as it did back when I purchased it. Can those who've been using Wotja 21 verify if that's the same case now?

    Yes, Wotja 21 was being updated till last month anyway, and is fine with the latest version of Monterey on M1 Macs; I haven't kept up with iOS 15, so somebody else will need to chip in there, but I'd be surprised if there were any issues.

  • edited December 2021

    @Masanga said:

    @skiphunt said:
    Does last year's Wotja 21 still work just fine and stable with the most current macOS and iOS? And, does the full "Pro" fee of $3.99 get you pretty much everything in the app... just no more updates?

    I've still got an older version from before they went with this subscription/annual fee, and it still pretty much works as well as it did back when I purchased it. Can those who've been using Wotja 21 verify if that's the same case now?

    Yes, Wotja 21 was being updated till last month anyway, and is fine with the latest version of Monterey on M1 Macs; I haven't kept up with iOS 15, so somebody else will need to chip in there, but I'd be surprised if there were any issues.

    Well, I just opened up my old install from 2017 on my iPad Pro 10.5 running 15.2. I got a pop-up that said this version of Wotja 2017 needs to be updated to run on this version of iOS. I updated (hoping it didn't sign me up for a sub or anything) and then it opened and ran just fine. Didn't charge me anything. It's still Wotja 2017 but it did an update to make sure it would still run.

    I thought the older versions don't get updates?

    This isn't a complaint of course. It's really kind of impressive that this 2017 version still seems to run just fine almost 5 years later without any regular updates.

    I'm averse to subs, even annual ones... but if this old 2017 is STILL this solid, I think I'll at least buy the 21 version.

  • @monch1962 said:
    Hi @impete happy 2022! I downloaded Wotja 22 Pro, rebooted and it fails on start every time while scanning hosted plug-ins. It seems to be scanning all my AU3s and I've got a few hundred installed so may be hitting a capacity issue.

    Any thoughts? If there's Wotja logs anywhere that you can point me to, I'm happy to either go through them or forward them to you. No rush, as it's 36C here in Melbourne Australia today so I'm gonna hit the beach

    256Gb iPad Air 3rd gen (2019?) running iOS 15.2. I've got 35Gb free so space doesn't seem to be the issue

    Hi! I've not yet seen any crash reports uploaded, but we'll get them through as normal and I'll do the usual of checking them out, and figuring-out a fix for anything we see.

    The hosting work has been in development since March, and in Beta probably for the last 6 months; and stable for a long time, but there are always unforeseen bugs early on in a major update, so you'll just have to bear with us!

    Certainly - I think you probably have more AUv3 plug-ins than any of our Beta testers :smile:

    Best wishes, Pete

  • @skiphunt said:
    This isn't a complaint of course. It's really kind of impressive that this 2017 version still seems to run just fine almost 5 years later without any regular updates.

    Thanks Skip. I'm always working to improve the stability of Wotja; it is a never-ending battle as there are more than half a million lines of code now, we run on several platforms, and we keep adding and reworking stuff...

    Best wishes, Pete

  • @impete said:

    @skiphunt said:
    This isn't a complaint of course. It's really kind of impressive that this 2017 version still seems to run just fine almost 5 years later without any regular updates.

    Thanks Skip. I'm always working to improve the stability of Wotja; it is a never-ending battle as there are more than half a million lines of code now, we run on several platforms, and we keep adding and reworking stuff...

    Best wishes, Pete

    Cool. I've always loved your apps. I bought all the updates up until the annual ones. I understand that you had to change your model in order to keep the development going.

    I AM slowly warming up to the subscription model a little. These annual versions seem reasonable to me. Loopy Pro appears to have adopted a similar model and I'll likely pay the annual update when it comes due.

    Glad you're still developing and Happy New Year :)

  • @impete said:

    @monch1962 said:
    Hi @impete happy 2022! I downloaded Wotja 22 Pro, rebooted and it fails on start every time while scanning hosted plug-ins. It seems to be scanning all my AU3s and I've got a few hundred installed so may be hitting a capacity issue.

    Any thoughts? If there's Wotja logs anywhere that you can point me to, I'm happy to either go through them or forward them to you. No rush, as it's 36C here in Melbourne Australia today so I'm gonna hit the beach

    256Gb iPad Air 3rd gen (2019?) running iOS 15.2. I've got 35Gb free so space doesn't seem to be the issue

    Hi! I've not yet seen any crash reports uploaded, but we'll get them through as normal and I'll do the usual of checking them out, and figuring-out a fix for anything we see.

    The hosting work has been in development since March, and in Beta probably for the last 6 months; and stable for a long time, but there are always unforeseen bugs early on in a major update, so you'll just have to bear with us!

    Certainly - I think you probably have more AUv3 plug-ins than any of our Beta testers :smile:

    Best wishes, Pete

    I’m also getting crashes during the scanning, so far seems to be on looking at atom… might be good to put in a marker that skips / quarantines crashed ones as a quick fix, I think this is how Roland did it with zenbeats… I’ve got an embarrassing amount of AUv3 installed, so any process of elimination would be a truly sysiphean task ☺️

  • Same problem with the scanning here, crashes to home screen every time in the middle of scanning.

  • Same here crashes scanning midi route (instrument)

  • I think it varies with devices and number of plugins; I got it every time on Kaspar on my (admittedly elderly) iPad Pro 9.7", but it has no problem with Kaspar on my daughter's 12.9" running (almost) the same version of iOS 13. (That hosting works at all on 13.x is something of a bonus, though.)

  • also here hangs on the “ scanning midi route (instrument)”
    Ipad pro 10.5, ios 15.0.2

    Inside AUM when I want to play anything the counter starts under the stop button, but there is no movement or sound whatsoever, tried mixes from 20, 21 or make a new flow, nothing works

  • @mingxiu said:
    also here hangs on the “ scanning midi route (instrument)”
    Ipad pro 10.5, ios 15.0.2

    Inside AUM when I want to play anything the counter starts under the stop button, but there is no movement or sound whatsoever, tried mixes from 20, 21 or make a new flow, nothing works

    Working in AUM for me, even on my ancient iOS 13.5 device. Maybe check the Audio MIDI+ settings (under the gearwheel at top right)? – make sure the "WAE For Sounds & FX and Hosted Plug-ins" box is checked.

  • @Masanga said:

    @mingxiu said:
    also here hangs on the “ scanning midi route (instrument)”
    Ipad pro 10.5, ios 15.0.2

    Inside AUM when I want to play anything the counter starts under the stop button, but there is no movement or sound whatsoever, tried mixes from 20, 21 or make a new flow, nothing works

    Working in AUM for me, even on my ancient iOS 13.5 device. Maybe check the Audio MIDI+ settings (under the gearwheel at top right)? – make sure the "WAE For Sounds & FX and Hosted Plug-ins" box is checked.

    Thanks for the info, but WAE For Sounds & FX is checked.
    Must be another reason, if it works by you it must be a user error, I’ll keep looking. (Also tried a reboot)

  • @mingxiu said:
    Thanks for the info, but WAE For Sounds & FX is checked.
    Must be another reason, if it works by you it must be a user error, I’ll keep looking. (Also tried a reboot)

    Not necessarily – the AUv3 is a complex beast and I've only tested it on quite elderly devices and systems. And there'll be some unsquashed bugs in this first release, so it's worth logging any issues here for @impete's benefit. (For my part I can't for the life of me remember how I stopped the crash-on-plugin-scan every time it got to Kaspar; it's doing it again now in the updated free version and all I know is that I did find a solution…)

  • @Masanga said:

    @mingxiu said:
    Thanks for the info, but WAE For Sounds & FX is checked.
    Must be another reason, if it works by you it must be a user error, I’ll keep looking. (Also tried a reboot)

    Not necessarily – the AUv3 is a complex beast and I've only tested it on quite elderly devices and systems. And there'll be some unsquashed bugs in this first release, so it's worth logging any issues here for @impete's benefit. (For my part I can't for the life of me remember how I stopped the crash-on-plugin-scan every time it got to Kaspar; it's doing it again now in the updated free version and all I know is that I did find a solution…)

    I thought maybe the reason for auv3 not working is because you need to start up the standalone at least once, I know it’s a requirement for some auv3 apps, but in the end I know far too little about these things and will wait for and rely on more knowledgeable people (like you) :)

  • Crashes for me during the scan for AUs, shortly after launch.. stand-alone mode. Waiting for fix… 😞

  • @god said:
    Crashes for me during the scan for AUs, shortly after launch.. stand-alone mode. Waiting for fix… 😞

    Hi! Which AUv3 did it hang-up on?!

    Pete

  • edited January 1

    @impete said:

    @god said:
    Crashes for me during the scan for AUs, shortly after launch.. stand-alone mode. Waiting for fix… 😞

    Hi! Which AUv3 did it hang-up on?!

    Pete

    Same for me on an iPad- the plugin where it initially happened each time is MIDI Route (instrument) - an Audioveek plugin and part of his 'MIDI tools' set - I see other users have had the same issue. I deleted this plugin and loaded Wotja again - this time it got further but then crashed on Atom 2 - another Audioveek app so maybe some clues there?

    I'm also getting similar problems at start up on my Mac - same symptoms - scanning plugins starts, then at some point it crashes - I can't see which plugin causes it, but I've got over 200 AUv2 'component' plugins.

  • @enkaytee said:

    Thanks for that! Hopefully there is a clear pattern I can spot.

    It is amazing to me how many plugins so many of you have!!

    Pete

Sign In or Register to comment.