Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

app anomalies under iOS15

anyone else see this with Moog Model D under iOS15 …

or this with Beathawk (file hamburger causes a hang) …

and - unrelated to iOS15 - anyone been able to get the whistle to download in Thumbjam?

Comments

  • Don’t have Thumbjam installed anymore, Beathawk and Model D work fine here.
    What iPad model are you using? (I’m on iPad Air 2, iPadOS 15 and iPhone 8, iOS15).

  • I had some trouble with IAA apps in AUM and Cubasis. Some were loading normally others didn’t, i.e apeMatrix and Animoog. I already wanted to start a post about it but then I thought that I try first to reproduce the issue on a freshly rebooted iPad and then the problems disappeared after the reboot.

  • All apps look good to me with the exception of Impaktor, where exporting a loop always crashes the app.

    Appearances and general behavior are fine for everything I have looked at though.

  • @krassmann said:
    I had some trouble with IAA apps in AUM and Cubasis. Some were loading normally others didn’t, i.e apeMatrix and Animoog. I already wanted to start a post about it but then I thought that I try first to reproduce the issue on a freshly rebooted iPad and then the problems disappeared after the reboot.

    Both apps load fine (into AUM, Cubasis & BM3 etc.) when I follow my standard IAA procedure (ie. Launch the IAA app first before making any connections with other apps) which I’ve been doing for the last couple of years or so, so it has become more or less automatic behaviour for me.

    I’ve tested most of my remaining (20+) IAA only apps and so far every single on of them has connected properly when launched prior to making the host connection.

    I do have a gazzillion of apps (couldn’t even fit them all even if I had a 2TB iPad) but the app cleaning spree has really helped me focus and I’m down to <300 apps now.

    Cheers!

  • @Samu said:

    @krassmann said:
    I had some trouble with IAA apps in AUM and Cubasis. Some were loading normally others didn’t, i.e apeMatrix and Animoog. I already wanted to start a post about it but then I thought that I try first to reproduce the issue on a freshly rebooted iPad and then the problems disappeared after the reboot.

    Both apps load fine (into AUM, Cubasis & BM3 etc.) when I follow my standard IAA procedure (ie. Launch the IAA app first before making any connections with other apps) which I’ve been doing for the last couple of years or so, so it has become more or less automatic behaviour for me.

    I’ve tested most of my remaining (20+) IAA only apps and so far every single on of them has connected properly when launched prior to making the host connection.

    I do have a gazzillion of apps (couldn’t even fit them all even if I had a 2TB iPad) but the app cleaning spree has really helped me focus and I’m down to <300 apps now.

    Cheers!

    I think the problem was that I did not start the IAA app beforehand. I’m sure that I did not have to do that with Cubasis under 14.x

  • @krassmann said:

    I think the problem was that I did not start the IAA app beforehand. I’m sure that I did not have to do that with Cubasis under 14.x

    With some apps it's been the only way to get them to properly connect over IAA ever since iOS13.x :sunglasses:

    That's why I've resorted to always launching IAA apps first before making any connections...
    ...some apps do launch when launched from the host but sometimes produce no audio until launching the stand-alone and re-connecting it to the host.

    Launching the IAA app first is also a good way to avoid 'IAA Ghosts' (ie. the app keeps on running in the background but can not be seen in the app switcher and can leave ghost midi-ports behind as well).

    With 'Launch IAA First' I've got a >98% success rate connecting and working with IAAs.
    (Ie. a fail 2 times out of a 100 or so connection attempts, and when that happens I wipe the RAM and try again).

    I think it's at least worth a try for now as IAA as a technology is very unlikely to get any further improvements from Apple.

  • @simonnowis said:
    and - unrelated to iOS15 - anyone been able to get the whistle to download in Thumbjam?

    Just tried downloading it, and it downloaded it OK. When I tried to use it, I couldn’t find it to start with, as it’s not listed under Whistle or Penny Whistle, but under D Whistle!

  • @Samu said:
    I think it's at least worth a try for now as IAA as a technology is very unlikely to get any further improvements from Apple.

    With the technology deprecated, I would imagine that the chance of finding issues can only increase going forward.

  • @michael_m said:

    @Samu said:
    I think it's at least worth a try for now as IAA as a technology is very unlikely to get any further improvements from Apple.

    With the technology deprecated, I would imagine that the chance of finding issues can only increase going forward.

    True, I've only tested about 30 IAA apps I still have installed...
    ...all of them work without any issues when I launch the IAA app first before making any connections to any hosts.

    So yeah, iPadOS15 is for me 'safe' regarding IAAs and I've not encountered any major issues on my iPad Air 2.

  • thanks everyone :)

    @Samu … this is a new entry level ipad 9 … i’m guessing the model D issues maybe to do with that , i’ll mail moog :)

    maybe the same goes for beathawk

    @bygjohn :) yes, i spotted the D whistle later (Thumbjam is so generous with the instrument downloads) … i got hung up on it never saying installed … monkey error!

    i’m currently setting up the new ipad, downloading,,, “rearranging the studio”,,, and very briefly testing apps as i go ,,,,

    trying to be “future proof”,, but so many good IAA apps still!

    ———

    « rant »

    i know many Love (or at least tolerate) the rolling techno tide, but everytime after a main number ios update, both the ipad and i have to learn all over again, just to do the same things as before

    and at the same time, there’s all this other stuff going on i might not want

    it’s a first world problem, but the tide of technology takes all with it

  • edited September 26

    Intermittently my lppmk3 will no longer responds when using it in LK.
    Haven’t figured out out how to exactly replicate it yet, but it’s certain sequence of presses when arming tracks for recording and using the capture midi button.

    @sinosoidal sorry, I haven’t had a camera or figured out the best way to document the bug report as I can’t always replicate it. I’m sure it will turn up again tomorrow so Ill try and be ready for it and submit.
    (Ipad mini 6, latest App Store LK, ipadOS15 fully updated)

  • @simonnowis said:
    thanks everyone :)

    @Samu … this is a new entry level ipad 9 … i’m guessing the model D issues maybe to do with that , i’ll mail moog :)

    maybe the same goes for beathawk

    Ok, good to now...
    The Model D (and Model 15) issue looked quite familiar...
    (I guess Moog just needs to render new graphics and add support the specific iPad model and push it out to AppStore).

    I've not been able to reproduce the BeatHawk issue but I do hope @BastienCo and UVI are on the case already :sunglasses:

Sign In or Register to comment.