Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

VS - Visual Synthesizer by Imaginando Lda

1222325272830

Comments

  • @jonmoore said:

    @sinosoidal said:

    @cuberoo_ said:

    @jonmoore said:

    @sinosoidal said:

    @foxal said:
    more materials? maybe sold as IAP’s? It’s a matter of taste, but currently i’m using only one - bit-for-bit - so VS is not real tool for me (eg for live visuals on gigs) . But I love simplicity and power of VS. I’m dreaming about shaders / materials like shadertoys

    We are working on a material editor so you can create your own materials or modify existent

    Will the material editor allow GLSL style control in much the same manner as Shadertoy?

    +1

    What do you mean by style control? Can you please elaborate?

    All I meant by that was live feedback as you write your shader.

    I wouldn’t classify myself as a skilled shader writer but got into shader writing via VEX (which in turn is based on RSL, Pixar’s RenderMan Shading Language) in Houdini (the 3d DCC).

    There’s a wealth of resources online for Shadertoy, as all you need is your web browser to get started. And the Shadertoy archive is full of inspiring code fragments.

    Whilst cut/paste workflows from Shadertoy to Visual Synth may not be possible right now, the Shadertoy API is completely open-source so it would be great to see it added in the future. There are already a few Shadertoy viewer apps on the App Store, the best and most current is this.

    https://apps.apple.com/gb/app/shadertoy-viewer/id1595439881

    Details on the API can be found here.

    https://www.shadertoy.com/howto

    Any app to play those shaders offline?

  • @sinosoidal thank you so much for making this video!

    I watched the entire thing, and I’ve come to three conclusions;

    1. I’ve got a LOT to learn if I want to start making my own materials. I’ll be reading that book next!

    2. While English obviously isn’t your first language, you do a fantastic job of explaining things. You speak clearly and stay on point. You’re a great teacher!

    3. You have amazing hair!

  • @Edward_Alexander said:
    @sinosoidal thank you so much for making this video!

    I watched the entire thing, and I’ve come to three conclusions;

    1. I’ve got a LOT to learn if I want to start making my own materials. I’ll be reading that book next!

    I would love to learn more about coding shaders myself but I don't have the time :blush:

    1. While English obviously isn’t your first language, you do a fantastic job of explaining things. You speak clearly and stay on point. You’re a great teacher!

    Thank you very much for the feedback. I was a bit insecure about releasing this video as I've struggled in many little details. While I read and write a lot of english, having a fluent speech about a topic you are not used to talk about is a big challenge.

    1. You have amazing hair!

    Thank you! :blush:

  • edited March 2022

    @sinosoidal Can you precisely define what is meant by the opacity parameter?

    • time - highp float variable that is linked with the speed parameter of VS
    • opacity - highp float variable that is linked with the brightness of the layer color
    • alpha - highp float variable that is linked with the layer alpha parameter
    • color - highp vec4 variable that is linked with the layer color
    • resolution - highp vec2 variable that has the viewport resolution
    • texCoord - highp vec2 variable that has the texture coordinates normalized between 0 and 1

    I think of alpha as transparency, and opacity as the inverse of transparency.

    Is the opacity parameter more like intensity, aka chroma or saturation?

    Also, what is the unit of time? Is it related to frame rate, tempo, or elapsed time?

  • It is not hyperbole when I say this is probably my iOS app ever. And as someone who uses iOS for sound applications, I'm baffled how I can love an app that makes no sound this much.

    So much fun, love the deep integration, results are easy to enjoy. Excellent work @sinosoidal

  • @sinosoidal said:

    @Paulinko said:
    @sinsoidal The video was very helpful.

    Thank you! I hope you haven't fall asleep while seeing it :blush:

    it was very good.

  • @mojozart said:
    @sinosoidal Can you precisely define what is meant by the opacity parameter?

    • time - highp float variable that is linked with the speed parameter of VS
    • opacity - highp float variable that is linked with the brightness of the layer color
    • alpha - highp float variable that is linked with the layer alpha parameter
    • color - highp vec4 variable that is linked with the layer color
    • resolution - highp vec2 variable that has the viewport resolution
    • texCoord - highp vec2 variable that has the texture coordinates normalized between 0 and 1

    I think of alpha as transparency, and opacity as the inverse of transparency.

    Is the opacity parameter more like intensity, aka chroma or saturation?

    Also, what is the unit of time? Is it related to frame rate, tempo, or elapsed time?

    Opacity = Brightness = Intensity of the material color. We should have called it brightness or intensity in this refactor.

    The time used to be linked with sample rate but now is just an increment factor. The speed in converted from [0, 1] -> [-0.5, 0.5] and this value is multiplied by a small constant (0.1). Therefore, speed doesn't have a unit.

  • @CalCutta said:
    It is not hyperbole when I say this is probably my iOS app ever. And as someone who uses iOS for sound applications, I'm baffled how I can love an app that makes no sound this much.

    So much fun, love the deep integration, results are easy to enjoy. Excellent work @sinosoidal

    Thanks for your kind words! :blush:

  • @espiegel123 said:

    @sinosoidal said:

    @Paulinko said:
    @sinsoidal The video was very helpful.

    Thank you! I hope you haven't fall asleep while seeing it :blush:

    it was very good.

    Thank you! :blush:

  • edited March 2022

    @sinosoidal said:

    @mojozart said:
    @sinosoidal Can you precisely define what is meant by the opacity parameter?

    • time - highp float variable that is linked with the speed parameter of VS

    The time used to be linked with sample rate but now is just an increment factor. The speed in converted from [0, 1] -> [-0.5, 0.5] and this value is multiplied by a small constant (0.1). Therefore, speed doesn't have a unit.

    Thanks!

    Let's say si is the momentary speed at frame i. (Expressed as a sequence because speed can be modulated.)

    Then, I understand you to say that time is a summation i=1..frameCount of (si - 0.5)/10

  • @mojozart said:

    @sinosoidal said:

    @mojozart said:
    @sinosoidal Can you precisely define what is meant by the opacity parameter?

    • time - highp float variable that is linked with the speed parameter of VS

    The time used to be linked with sample rate but now is just an increment factor. The speed in converted from [0, 1] -> [-0.5, 0.5] and this value is multiplied by a small constant (0.1). Therefore, speed doesn't have a unit.

    Thanks!

    Let's say si is the momentary speed at frame i. (Expressed as a sequence because speed can be modulated.)

    Then, I understand you to say that time is a summation i=1..frameCount of (si - 0.5)/10

    I couldn't express myself better :blush:

  • Wow, that Book of Shaders is incredibly helpful. I went from barely comprehending what I was looking at with the code to being able to follow along pretty decently. I still couldn’t make a shader from abstract cos I really need to brush up/learn more math but manipulating code and having expected results is occurring more frequently. It was a little confusing getting it compatible with VS but the tutorials really tied it all together and I have the system down I think for the most part.

  • @sinosoidal
    i have an issue with background layer "forgetting" it's content.
    vs 1.3.1 au hosted in aum.
    saved project in vs and in aum.
    when reloaded the aum project, the background layer is empty.

    can you, or anybody else confirm this?
    thanks

  • Yeah, I've had that too...also in standalone...

  • Yeah I’ve had that happening as well

  • @rototom said:
    @sinosoidal
    i have an issue with background layer "forgetting" it's content.
    vs 1.3.1 au hosted in aum.
    saved project in vs and in aum.
    when reloaded the aum project, the background layer is empty.

    can you, or anybody else confirm this?
    thanks

    @lasselu said:
    Yeah, I've had that too...also in standalone...

    @Fingolfinzz said:
    Yeah I’ve had that happening as well

    We have written down the issue. Thanks for reporting!

  • @rototom said:
    @sinosoidal
    i have an issue with background layer "forgetting" it's content.
    vs 1.3.1 au hosted in aum.
    saved project in vs and in aum.
    when reloaded the aum project, the background layer is empty.

    can you, or anybody else confirm this?
    thanks

    @lasselu said:
    Yeah, I've had that too...also in standalone...

    @Fingolfinzz said:
    Yeah I’ve had that happening as well

    Same problem with the background layer here as well guys.

  • edited April 2022

    @Edward_Alexander said:

    @rototom said:
    @sinosoidal
    i have an issue with background layer "forgetting" it's content.
    vs 1.3.1 au hosted in aum.
    saved project in vs and in aum.
    when reloaded the aum project, the background layer is empty.

    can you, or anybody else confirm this?
    thanks

    @lasselu said:
    Yeah, I've had that too...also in standalone...

    @Fingolfinzz said:
    Yeah I’ve had that happening as well

    Same problem with the background layer here as well guys.

    Hey good people. Sorry for the long wait. This one took a bit longer. The problem should be fixed in the latest 1.3.2 (build 58) beta version.

    Please let me know if this fixes the bug and if there isn't anything new broken.

    Thanks! :blush:

  • @sinosoidal said:

    @Edward_Alexander said:

    @rototom said:
    @sinosoidal
    i have an issue with background layer "forgetting" it's content.
    vs 1.3.1 au hosted in aum.
    saved project in vs and in aum.
    when reloaded the aum project, the background layer is empty.

    can you, or anybody else confirm this?
    thanks

    @lasselu said:
    Yeah, I've had that too...also in standalone...

    @Fingolfinzz said:
    Yeah I’ve had that happening as well

    Same problem with the background layer here as well guys.

    Hey good people. Sorry for the long wait. This one took a bit longer. The problem should be fixed in the latest 1.3.2 (build 58) beta version.

    Please let me know if this fixes the bug and if there isn't anything new broken.

    Thanks! :blush:

    cool, thanks!
    i would like to test, but i'm not on the testflight vs.
    would you mind sending me an invite, if i send you my email?

  • @rototom said:

    @sinosoidal said:

    @Edward_Alexander said:

    @rototom said:
    @sinosoidal
    i have an issue with background layer "forgetting" it's content.
    vs 1.3.1 au hosted in aum.
    saved project in vs and in aum.
    when reloaded the aum project, the background layer is empty.

    can you, or anybody else confirm this?
    thanks

    @lasselu said:
    Yeah, I've had that too...also in standalone...

    @Fingolfinzz said:
    Yeah I’ve had that happening as well

    Same problem with the background layer here as well guys.

    Hey good people. Sorry for the long wait. This one took a bit longer. The problem should be fixed in the latest 1.3.2 (build 58) beta version.

    Please let me know if this fixes the bug and if there isn't anything new broken.

    Thanks! :blush:

    cool, thanks!
    i would like to test, but i'm not on the testflight vs.
    would you mind sending me an invite, if i send you my email?

    Sure! I have just added you! :blush:

  • @sinosoidal said:

    @rototom said:

    @sinosoidal said:

    @Edward_Alexander said:

    @rototom said:
    @sinosoidal
    i have an issue with background layer "forgetting" it's content.
    vs 1.3.1 au hosted in aum.
    saved project in vs and in aum.
    when reloaded the aum project, the background layer is empty.

    can you, or anybody else confirm this?
    thanks

    @lasselu said:
    Yeah, I've had that too...also in standalone...

    @Fingolfinzz said:
    Yeah I’ve had that happening as well

    Same problem with the background layer here as well guys.

    Hey good people. Sorry for the long wait. This one took a bit longer. The problem should be fixed in the latest 1.3.2 (build 58) beta version.

    Please let me know if this fixes the bug and if there isn't anything new broken.

    Thanks! :blush:

    cool, thanks!
    i would like to test, but i'm not on the testflight vs.
    would you mind sending me an invite, if i send you my email?

    Sure! I have just added you! :blush:

    thanks!:)

  • The update is working great for me so far when I had a little time to play with it earlier

  • I have noticed a few more crashes than usual but it could just be what I’m running. Is anyone else getting crashes with the new TestFlight update? It could just be me though cos I’m using some shaders I converted myself so there could be some insufficiency with my code and I have spacefields running so I could just be killing my memory

  • @Fingolfinzz said:
    I have noticed a few more crashes than usual but it could just be what I’m running. Is anyone else getting crashes with the new TestFlight update? It could just be me though cos I’m using some shaders I converted myself so there could be some insufficiency with my code and I have spacefields running so I could just be killing my memory

    I'm not having reports of crashes. Are you sharing app analytics with developers?

  • I really need to start watching these. First time I tried actually editing a music video on the iPad, I started with VJ, had no clue what I was doing, achieved nothing, tried all of the other vj and effect apps I have, which either crashed or achieved nothing and ended on using Luma.

  • @sinosoidal said:

    @Fingolfinzz said:
    I have noticed a few more crashes than usual but it could just be what I’m running. Is anyone else getting crashes with the new TestFlight update? It could just be me though cos I’m using some shaders I converted myself so there could be some insufficiency with my code and I have spacefields running so I could just be killing my memory

    I'm not having reports of crashes. Are you sharing app analytics with developers?

    Ah it looks like I had that off. I have it turned on now and I’ll try to make it crash again so it can send one

  • Something I did with VS Synth using a sequencer and external LFO’s.

    Enjoy.

  • Sounds awesome @Gravitas
    Also looks cool

  • @Lorichs said:
    Sounds awesome @Gravitas
    Also looks cool

    Thank you.

    🙏🏾

  • @Gravitas said:
    Something I did with VS Synth using a sequencer and external LFO’s.

    Enjoy.

    This is amazing! :blush:

Sign In or Register to comment.