Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

VS - Visual Synthesizer by Imaginando Lda

191012141528

Comments

  • This guy is live playing Launchpad with VS

  • Does anyone know any AUv3 that is able to send something to HDMI output?> @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @skiphunt said:

    There's another app in the appstore called VOSC and it's a visual synth. It doesn't make sound, but it uses ocsillators to manipulate particles. Looks to be abandoned, but still looks interesting.

    I had a look at the review section for VOSC and
    a reviewer stated that it doesn't have midi in
    which is a pity as it looks very interesting.

    @sinosoidal

    A couple of things if you don't mind.

    Is it possible for VS to remember it's sync settings when
    closed and reopened in standalone mode?
    It defaults to internal sync.
    If this is deliberate then please ignore this.

    I think it is possible. Let's take a look.

    Can we reset the individual LFO phase using a controller message?
    I'm trying to get the LFO to start on the one when synced.

    If we had a reset button on the LFO UI, that button could be assigned to a midi control.

    What do you mean with "start on the one when synced"?

    When synced to tempo the LFO's freewheel in regards to phase?
    When sent a reset signal or key press they begin cycling again?
    So I wanted to find out if we could assign a key press to start the phase
    of an individual LFO at the beginning of a loop without affecting
    the others and without it being reset every time.

    It feels like a global key press rather than being
    able to assign a specific key press or gate signal.

    I also didn't get this one.

    The LFO's react to all incoming key presses rather
    than a specific key press or gate signal?

    So when they are set to 'phase' they react to every key press?
    which is why I said 'global'.

    In this screenshot you can see where I triggered the LFO
    and it's phase gets reset with every key press.

    We have seen this problem before during our tests. One solution is to have a filter by channel for the LFO. Instead of reacting to all note ons from all channels, it would react only to the ones of certain incoming channel.

    Ahhhh....

    So is it possible for us to assign four separate midi channels, one for each LFO?
    That way we can treat the phase start point of each LFO individually
    and still be able to play VS using a keyboard or midi controller?

    @jose_varela said:
    This guy is live playing Launchpad with VS

    :scream:

  • @Ailerom said:

    @Gravitas said:

    @Ailerom said:

    @Toastedghost said:

    @Toastedghost said:
    Another test, sorry use the same track as before with a slight update.

    @Ailerom said:
    Any chance of being able to load video from the Photos app?

    Long press on B the background layer reveals files, resources and photos file folders. Inside the photo folder find the video you want.

    No videos showing up there. Only in Files. There is no photos folder in the files app if that is what you meant.

    +1

    I found the same thing yesterday.
    I copied the video over to 'Files' so that VS could load it.

    Same here, just hoping to avoid that as I have different places for different types of video.

    I believe we have fixed that bug in 1.0.2. It should be available for beta soon.

    By the way, we have been able to add HDMI output support but it seems to work only in standalone.

    Does anyone knows a AUv3 that is capable to sending output to HDMI? I'm not sure, but maybe it is not possible.

  • That Twitch that @jose_varela posted is insane. Does he explain how he gets VS and his live stream to mix together?

  • @sinosoidal said:
    Does anyone know any AUv3 that is able to send something to HDMI output?> @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @skiphunt said:

    There's another app in the appstore called VOSC and it's a visual synth. It doesn't make sound, but it uses ocsillators to manipulate particles. Looks to be abandoned, but still looks interesting.

    I had a look at the review section for VOSC and
    a reviewer stated that it doesn't have midi in
    which is a pity as it looks very interesting.

    @sinosoidal

    A couple of things if you don't mind.

    Is it possible for VS to remember it's sync settings when
    closed and reopened in standalone mode?
    It defaults to internal sync.
    If this is deliberate then please ignore this.

    I think it is possible. Let's take a look.

    Can we reset the individual LFO phase using a controller message?
    I'm trying to get the LFO to start on the one when synced.

    If we had a reset button on the LFO UI, that button could be assigned to a midi control.

    What do you mean with "start on the one when synced"?

    When synced to tempo the LFO's freewheel in regards to phase?
    When sent a reset signal or key press they begin cycling again?
    So I wanted to find out if we could assign a key press to start the phase
    of an individual LFO at the beginning of a loop without affecting
    the others and without it being reset every time.

    It feels like a global key press rather than being
    able to assign a specific key press or gate signal.

    I also didn't get this one.

    The LFO's react to all incoming key presses rather
    than a specific key press or gate signal?

    So when they are set to 'phase' they react to every key press?
    which is why I said 'global'.

    In this screenshot you can see where I triggered the LFO
    and it's phase gets reset with every key press.

    We have seen this problem before during our tests. One solution is to have a filter by channel for the LFO. Instead of reacting to all note ons from all channels, it would react only to the ones of certain incoming channel.

    Ahhhh....

    So is it possible for us to assign four separate midi channels, one for each LFO?
    That way we can treat the phase start point of each LFO individually
    and still be able to play VS using a keyboard or midi controller?

    @jose_varela said:
    This guy is live playing Launchpad with VS

    :scream:

    Hhhmmm...
    I think I've been misquoted again.
    This is the 2nd time in a couple of days....Lolololol

    I don't do 'Twitch', presumably from your reaction it must be amazing.

    I on the other hand have chosen a simpler approach.

    Here's the thread

    https://forum.audiob.us/discussion/45735/32-step-drm-sequencer#latest

    I triggered it using the drm sequencer I've been quietly designing,
    screen recorded it and dropped it in on the video.

    Very simple at the moment.

  • @sinosoidal said:

    @Ailerom said:

    @Gravitas said:

    @Ailerom said:

    @Toastedghost said:

    @Toastedghost said:
    Another test, sorry use the same track as before with a slight update.

    @Ailerom said:
    Any chance of being able to load video from the Photos app?

    Long press on B the background layer reveals files, resources and photos file folders. Inside the photo folder find the video you want.

    No videos showing up there. Only in Files. There is no photos folder in the files app if that is what you meant.

    +1

    I found the same thing yesterday.
    I copied the video over to 'Files' so that VS could load it.

    Same here, just hoping to avoid that as I have different places for different types of video.

    I believe we have fixed that bug in 1.0.2. It should be available for beta soon.

    Nice.

    By the way, we have been able to add HDMI output support but it seems to work only in standalone.

    Very cool.

  • edited June 2021

    @sinosoidal

    A thought.

    Maybe the one to ask would be @Blue_Mangoo from Mani Consulting Limited.

    He does Tube AU, here's the App Store link

    https://apps.apple.com/gb/app/tube-au/id1471493593

    I'm thinking as he does visuals in auv3 he may be able to point
    you in the direction you need for hdmi output for VS?

    Other than that I don't know of any auv3's that can do hdmi output directly.

  • Can VS do airplay out without mirroring and without showing the interface controls?

  • edited June 2021

    Noob question. Resetting background layer clears material. Resetting other layer does not clear material as per manual, so how do you clear the material from a layer. The only way I found so far is to copy empty layer b to layer a. Is plain color the same as reset?

  • @Ailerom said:
    Any chance of being able to load video from the Photos app?

    Long press on B the background layer reveals files, resources and photos file folders. Inside the photo folder find the video you want.

    No videos showing up there. Only in Files. There is no photos folder in the files app if that is what you meant.

    Inside the photos folder you can see videos. That is if you have made videos and stored them in the photos folder. Hope this helps

  • @Toastedghost said:

    @Ailerom said:
    Any chance of being able to load video from the Photos app?

    Long press on B the background layer reveals files, resources and photos file folders. Inside the photo folder find the video you want.

    No videos showing up there. Only in Files. There is no photos folder in the files app if that is what you meant.

    Inside the photos folder you can see videos. That is if you have made videos and stored them in the photos folder. Hope this helps

    Nope.

    I have over 30 videos in my photos section on
    one iPad over a hundred on the other iPad.

    Yup, long press on 'B' to access Files, resources and photos.

    VS isn't seeing them when going into 'Photos'.

    iOS 13.4 on one iPad, iOS 14.4 on the other.

  • wimwim
    edited June 2021

    No videos here either.
    Maybe it's because @Toastedghost is on the beta?

  • edited June 2021

    @wim said:
    No videos here either.
    Maybe it's because @Toastedghost is on the beta?

    Don’t think so it worked before I be ame engaged with beta.
    Does @sinosoidal have the answer?
    I have ipad Air 2 IOS 14.6

  • @sinosoidal said:

    @xor said:
    @sinosoidal hey, is it possible to start modulation at the beginning of a musical phrase and then fade it out at the end of that phrase? I thought that an EG with a slow attack and slow release would work but each key press and release re-triggers the eg so only a long sustained note hits the maximum. Similarly as a trigger, is there a way to keep the trigger high as long as notes are coming in reasonably (user-defined) quickly.

    If you want more control you should use something that allows you to automate in time.

    For instance, LK has automation abilities. You can set an automation lane for a certain CC and then use that CC to modulate a parameter in VS.

    Let's say you are using EG to modulate brightness. You would take this modulation out and modulate brightness directly with an automation lane.

    Makes sense?

    Also, can you look at hue modulation on the solid color material? Hooked to a lfo it seems that all positive values are red and then all negative values cycle through all the colors, including red.

    [AUM with keyboard routed to VS in an effects slot] Also the solid color brightness EG modulation seems, well, odd. With trigger set to none, set brightness full on. Everything is good. Now set EG modulation of brightness to -1. Press a key and screen fades to black. Almost expected, there’s no trigger so why is it responding to midi? Now change trigger to midi and screen goes immediately black. Why? Brightness is full. Now press a key, with EG modulation -1 or +1nothing happens. Set brightness off, EG to -1 or +1 same. Guessing that trigger is hooked up backwards on solid color?

    Also, lfo modulation of brightness doesn’t appear to change when lfo is positive.

    Can you do a simple video that replicates the issue and share with us?

    I think I understand the source of some of my confusion. I was assuming the EG was tied to the trigger. It appears to respond to any midi regardless of the trigger state. Is that correct?

    I’m still unsure how midi trigger and brightness is supposed to work. On trigger it seems to always be black and needs a positive modulation to show. How can I get a fast attack (full bright) and a slow decay while a key is held down? I expected that triggering the layer would make it visible using the specified control values and then start applying the modulation. If that were the case then setting brightness to full and EG modulation to -1 would work. If I wanted a slow fade in then I’d set brightness to 0 and modulation to +1. As it is, if I want a fast attack I need to set brightness full, EG attack fast, EG modulation +1 but that leaves no way to specify further key-down eg modulation. I can also use a key-synced lfo with -1 modulation but that wastes a lfo to workaround something that I should be able to do with just the EG mod.

    Here’s a video

    I’d also like an inverse midi trigger. That is, hide the layer when triggered and show when not. I can almost do this by setting trigger none and EG negative EG modulation but it only works for non-overlapping input. If you hit two notes then release one of them the EG release triggers. If this is by design then I’d like an option so the release doesn’t trigger until all notes are off. Here’s another video.

    Immediately after making that video I noticed that layer 1 was unresponsive. I found that toggling solo unstuck it.

  • I’m still trying to wrap my head around this. So, if one were to run multiple instances of VS on various audio channels, could the visuals from all (or some) of them be blended together somehow on a single screen?

    Or is it better to do everything within a single instance?

  • wimwim
    edited June 2021

    @Edward_Alexander said:
    I’m still trying to wrap my head around this. So, if one were to run multiple instances of VS on various audio channels, could the visuals from all (or some) of them be blended together somehow on a single screen?

    Or is it better to do everything within a single instance?

    Single instance. There would be no reason I can think of to use multiple instances, and it would kill your CPU. Just route any audio and/or midi to the instance that you need. In AUM, set the input of a channel to a bus, add VS as an FX, then use bus sends on any channels you want to influence the visual, and route midi to VS if you want to influence it that way.

  • @sinosoidal said:
    I believe we have fixed that bug in 1.0.2. It should be available for beta soon.

    Sweet!

  • @soundtemple said:
    Noob question. Resetting background layer clears material. Resetting other layer does not clear material as per manual, so how do you clear the material from a layer. The only way I found so far is to copy empty layer b to layer a. Is plain color the same as reset?

    Reseting a material layer is the same as selecting the "plain color" material. Right now, the reset functionality only resets the current material parameters to its default state. So, to fully reset the layer just change its material to the "plain color" one.

  • edited June 2021

    @xor said:

    @sinosoidal said:

    @xor said:
    @sinosoidal hey, is it possible to start modulation at the beginning of a musical phrase and then fade it out at the end of that phrase? I thought that an EG with a slow attack and slow release would work but each key press and release re-triggers the eg so only a long sustained note hits the maximum. Similarly as a trigger, is there a way to keep the trigger high as long as notes are coming in reasonably (user-defined) quickly.

    If you want more control you should use something that allows you to automate in time.

    For instance, LK has automation abilities. You can set an automation lane for a certain CC and then use that CC to modulate a parameter in VS.

    Let's say you are using EG to modulate brightness. You would take this modulation out and modulate brightness directly with an automation lane.

    Makes sense?

    Also, can you look at hue modulation on the solid color material? Hooked to a lfo it seems that all positive values are red and then all negative values cycle through all the colors, including red.

    [AUM with keyboard routed to VS in an effects slot] Also the solid color brightness EG modulation seems, well, odd. With trigger set to none, set brightness full on. Everything is good. Now set EG modulation of brightness to -1. Press a key and screen fades to black. Almost expected, there’s no trigger so why is it responding to midi? Now change trigger to midi and screen goes immediately black. Why? Brightness is full. Now press a key, with EG modulation -1 or +1nothing happens. Set brightness off, EG to -1 or +1 same. Guessing that trigger is hooked up backwards on solid color?

    Also, lfo modulation of brightness doesn’t appear to change when lfo is positive.

    Can you do a simple video that replicates the issue and share with us?

    I think I understand the source of some of my confusion. I was assuming the EG was tied to the trigger. It appears to respond to any midi regardless of the trigger state. Is that correct?

    I’m still unsure how midi trigger and brightness is supposed to work. On trigger it seems to always be black and needs a positive modulation to show. How can I get a fast attack (full bright) and a slow decay while a key is held down? I expected that triggering the layer would make it visible using the specified control values and then start applying the modulation. If that were the case then setting brightness to full and EG modulation to -1 would work. If I wanted a slow fade in then I’d set brightness to 0 and modulation to +1. As it is, if I want a fast attack I need to set brightness full, EG attack fast, EG modulation +1 but that leaves no way to specify further key-down eg modulation. I can also use a key-synced lfo with -1 modulation but that wastes a lfo to workaround something that I should be able to do with just the EG mod.

    Here’s a video

    I’d also like an inverse midi trigger. That is, hide the layer when triggered and show when not. I can almost do this by setting trigger none and EG negative EG modulation but it only works for non-overlapping input. If you hit two notes then release one of them the EG release triggers. If this is by design then I’d like an option so the release doesn’t trigger until all notes are off. Here’s another video.

    Immediately after making that video I noticed that layer 1 was unresponsive. I found that toggling solo unstuck it.

    Regarding your first problem, the thing is that currently our EG only have attack and release. To achieve what you want EG must also have the decay parameter, so the brightness can go to it maximum, and then slowly go to the value defined in the brightness parameter in the time defined by that decay parameter. For that to be made our EGs must be changed, and I don't know if thats a priority right now. But we will analyse the possibilities =)

    Regarding your second problem, what you want is possible, and is exactly as you tried (plus putting the layer in "MONO" mode, so you don't have that overlapping thing, only one voice will be displayed). But we have in fact an issue. In MONO mode, pressing two keys, and releasing only one, will trigger the Release state, which isn't suppose to happen, since there is still one pressed note. I'll try to see what is going on with that and will let you know when there's a fix for that =)

    Maybe you had some other layer with solo activated? And by soloing that one you deactivate the previous one and everything went normal

  • @wim said:

    @Edward_Alexander said:
    I’m still trying to wrap my head around this. So, if one were to run multiple instances of VS on various audio channels, could the visuals from all (or some) of them be blended together somehow on a single screen?

    Or is it better to do everything within a single instance?

    Single instance. There would be no reason I can think of to use multiple instances, and it would kill your CPU. Just route any audio and/or midi to the instance that you need. In AUM, set the input of a channel to a bus, add VS as an FX, then use bus sends on any channels you want to influence the visual, and route midi to VS if you want to influence it that way.

    Yes, summing audio to a bus is the path here but i think the disconnect for many will be “but i want to isolate the kick drum and sync this flashing thing to it “.

  • wimwim
    edited June 2021

    @lukesleepwalker said:

    @wim said:

    @Edward_Alexander said:
    I’m still trying to wrap my head around this. So, if one were to run multiple instances of VS on various audio channels, could the visuals from all (or some) of them be blended together somehow on a single screen?

    Or is it better to do everything within a single instance?

    Single instance. There would be no reason I can think of to use multiple instances, and it would kill your CPU. Just route any audio and/or midi to the instance that you need. In AUM, set the input of a channel to a bus, add VS as an FX, then use bus sends on any channels you want to influence the visual, and route midi to VS if you want to influence it that way.

    Yes, summing audio to a bus is the path here but i think the disconnect for many will be “but i want to isolate the kick drum and sync this flashing thing to it “.

    That's doable if you understand audio routing and the Audio Modulator envelopes. You have four of them to work with. You just need to route the kick to the app and find a setting on one of the envelopes that fires when the kick hits.

    You can send a shitload of kick to the app and set the threshold so one envelope triggers when the kick comes in. Then connect that to your flashing thing. You can send a strings patch at the same time and use the Frequency setting on another envelope to fade in a layer as the strings swell, ignoring the kick.

    Or, you can do it more simply with midi. Send the same midi to fire the kick and to VS to flash the thing.

    It's possible to make multiple-input AUv3's but hosts have to be able to support it, and VS provides ample ways to not need that.

  • edited June 2021

    @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @skiphunt said:

    There's another app in the appstore called VOSC and it's a visual synth. It doesn't make sound, but it uses ocsillators to manipulate particles. Looks to be abandoned, but still looks interesting.

    I had a look at the review section for VOSC and
    a reviewer stated that it doesn't have midi in
    which is a pity as it looks very interesting.

    @sinosoidal

    A couple of things if you don't mind.

    Is it possible for VS to remember it's sync settings when
    closed and reopened in standalone mode?
    It defaults to internal sync.
    If this is deliberate then please ignore this.

    I think it is possible. Let's take a look.

    Can we reset the individual LFO phase using a controller message?
    I'm trying to get the LFO to start on the one when synced.

    If we had a reset button on the LFO UI, that button could be assigned to a midi control.

    What do you mean with "start on the one when synced"?

    When synced to tempo the LFO's freewheel in regards to phase?
    When sent a reset signal or key press they begin cycling again?
    So I wanted to find out if we could assign a key press to start the phase
    of an individual LFO at the beginning of a loop without affecting
    the others and without it being reset every time.

    It feels like a global key press rather than being
    able to assign a specific key press or gate signal.

    I also didn't get this one.

    The LFO's react to all incoming key presses rather
    than a specific key press or gate signal?

    So when they are set to 'phase' they react to every key press?
    which is why I said 'global'.

    In this screenshot you can see where I triggered the LFO
    and it's phase gets reset with every key press.

    We have seen this problem before during our tests. One solution is to have a filter by channel for the LFO. Instead of reacting to all note ons from all channels, it would react only to the ones of certain incoming channel.

    Ahhhh....

    So is it possible for us to assign four separate midi channels, one for each LFO?
    That way we can treat the phase start point of each LFO individually
    and still be able to play VS using a keyboard or midi controller?

    Right now its not possible, but we'll try to add that in a future update =)

  • @xglax said:

    @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @sinosoidal said:

    @Gravitas said:

    @skiphunt said:

    There's another app in the appstore called VOSC and it's a visual synth. It doesn't make sound, but it uses ocsillators to manipulate particles. Looks to be abandoned, but still looks interesting.

    I had a look at the review section for VOSC and
    a reviewer stated that it doesn't have midi in
    which is a pity as it looks very interesting.

    @sinosoidal

    A couple of things if you don't mind.

    Is it possible for VS to remember it's sync settings when
    closed and reopened in standalone mode?
    It defaults to internal sync.
    If this is deliberate then please ignore this.

    I think it is possible. Let's take a look.

    Can we reset the individual LFO phase using a controller message?
    I'm trying to get the LFO to start on the one when synced.

    If we had a reset button on the LFO UI, that button could be assigned to a midi control.

    What do you mean with "start on the one when synced"?

    When synced to tempo the LFO's freewheel in regards to phase?
    When sent a reset signal or key press they begin cycling again?
    So I wanted to find out if we could assign a key press to start the phase
    of an individual LFO at the beginning of a loop without affecting
    the others and without it being reset every time.

    It feels like a global key press rather than being
    able to assign a specific key press or gate signal.

    I also didn't get this one.

    The LFO's react to all incoming key presses rather
    than a specific key press or gate signal?

    So when they are set to 'phase' they react to every key press?
    which is why I said 'global'.

    In this screenshot you can see where I triggered the LFO
    and it's phase gets reset with every key press.

    We have seen this problem before during our tests. One solution is to have a filter by channel for the LFO. Instead of reacting to all note ons from all channels, it would react only to the ones of certain incoming channel.

    Ahhhh....

    So is it possible for us to assign four separate midi channels, one for each LFO?
    That way we can treat the phase start point of each LFO individually
    and still be able to play VS using a keyboard or midi controller?

    Right now its not possible, but we'll try to add that in a future update =)

    Very cool.

    Perfect. 😁

  • There is a new beta available:

    • Add support for HDMI on iOS (standalone only)
    • Add MIDI activity indicator
    • Fix modulators buttons checked state
    • Fix gif not playing bug
    • Fix demo tempo when changing presets

    Does anyone here have a HDMI adaptor to test this?

  • Hang on, you can connect an iPad (3rd gen) to HDMI monitor?

  • Having alignment issues in bove AU and standalone. Please see images below.

    Then when seen in full screen mode.

  • @Toastedghost said:
    Having alignment issues in bove AU and standalone. Please see images below.

    Then when seen in full screen mode.

    Is the image in fit or crop mode? Try the other fill mode to see if it makes any difference

  • @NimboStratus said:
    Hang on, you can connect an iPad (3rd gen) to HDMI monitor?

    If you have the ligthning to hdmi adaptor then yes

  • The above images were in crop mode. The 2 images below in fit mode same issue.
    and in full screen

  • @sinosoidal said:

    @NimboStratus said:
    Hang on, you can connect an iPad (3rd gen) to HDMI monitor?

    If you have the ligthning to hdmi adaptor then yes

    Does this only work with the Apple hdmi adaptor or
    would it work with generic hdmi adaptors.
    I'm asking because I have a generic hdmi adaptor.
    I'll be testing it tomorrow in any case.

Sign In or Register to comment.