Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Cubasis 3.3 state saving issues not fixed = unreliable DAW? - FIXED IN NEXT 3.3.1 UPDATE

Cubasis 3.3.1 beta fixes the issue

Hi all!!

I’m really upset. Cubasis 3.3 still have HUGE state saving issues.

It’s now not needed anymore to switch to home screen before closing Cubasis to help with state saving…

… but randomly some AUV3 goes back to default preset after closing/opening CB3.3. There is nothing to help with this.

I encountered the issue with Dubstation2, Bleass Delay, Beef, RoughRider3, FAC Maxima and others. I have zero issues with those FXS in GarageBand and AUM.

When you tweak a mix for a good while, it’s so frustrating to lose your song settings and how it sounds because of those random state saving issues.

It has been a while since CB3 has those issues, but it’s now worst with 3.3 from my experience with 7 Plus and Air 3 on latest OS.

Cubasis 3 is one of my best app, I love the workflow and it’s one of the reason for which I bought latest iPad Pro M1.

I can’t even feel confident and use it for making a single song!!!

Please @LFS can your team definitely fix Cubasis 3??? We need it on iOS, so much potential and pleasing to make music with that DAW.

Cubasis 3 state saving reliability
  1. Have you got state saving issues in Cubasis 319 votes
    1. Yes
      63.16%
    2. No
      36.84%

Comments

  • edited May 2021

    No problems here. Maybe the thread title could be edited because it’s crass and also untrue for many users. I only had Dubstation of those mentioned and that’s been replaced with Waves H-Delay because of instability. Noticed too late for a refund. Nowadays I test new plugs thoroughly and refund if there’s issues. With that approach (and track freezing) C3 is very stable on a base ipad with stuff from Bram Bos, Eventide, Moog, Waldorf, Sugarbytes, Korg and more. I actually haven’t experienced crackles even since DrumComputer got an update. So I think there’s more reasons for your troubles than the Cubasis team and their coding. Have you tried track freezing? That’s one of my main tests for plugins because of how useful it is when working on a mobile device.

  • Did you update to iPadOS14.6 already? (That is the latest released version).

    Apart from a few issues related to audio-editing I've got no other major issues with CB3.3 (iPadAir 2 & iPhone 8, both on iOS/iPadOS14.6). As far as I know CB3.3.1 should be here soon too...

  • I have found that freezing a track is a sure fire way of losing MIDI plugin settings. For example:

    1. Start a new project
    2. Add a MIDI plugin, e.g. Atom 2
    3. Add some notes
    4. With the Atom window still visible, freeze the track
    5. Unfreeze the track, all your notes are gone :(

    This works with other plugins too, not Atom specific.

    If you close the plugin window first then that seems to trigger a state snapshot and all is well. @LFS are your devs able to recreate this? It seems Cubasis should be taking a state snapshot before doing the freeze.

  • Now, that sounds like a serious bug :o

  • @tja said:
    Now, that sounds like a serious bug :o

    Fortunately it doesn’t completely reset the settings but does lose everything since the last state snapshot. Hit me at the weekend and I lost a good half hour of work. Hopefully an easy fix though for the folk at Cubasis.

  • @MisplacedDevelopment said:

    @tja said:
    Now, that sounds like a serious bug :o

    Fortunately it doesn’t completely reset the settings but does lose everything since the last state snapshot. Hit me at the weekend and I lost a good half hour of work. Hopefully an easy fix though for the folk at Cubasis.

    It will be best to report this directly, not only in this forum.... @LFS may show up later then hoped for

  • @tja said:

    @MisplacedDevelopment said:

    @tja said:
    Now, that sounds like a serious bug :o

    Fortunately it doesn’t completely reset the settings but does lose everything since the last state snapshot. Hit me at the weekend and I lost a good half hour of work. Hopefully an easy fix though for the folk at Cubasis.

    It will be best to report this directly, not only in this forum.... @LFS may show up later then hoped for

    Good idea, I have reported via their forum.

  • @MisplacedDevelopment said:

    @tja said:

    @MisplacedDevelopment said:

    @tja said:
    Now, that sounds like a serious bug :o

    Fortunately it doesn’t completely reset the settings but does lose everything since the last state snapshot. Hit me at the weekend and I lost a good half hour of work. Hopefully an easy fix though for the folk at Cubasis.

    It will be best to report this directly, not only in this forum.... @LFS may show up later then hoped for

    Good idea, I have reported via their forum:

    https://forums.steinberg.net/t/midi-state-lost-on-track-freeze/720832

  • edited May 2021

    @Samu I’ve updated to 14.6 both devices, and also reinstalled Cubasis 3. It helped as it’s less now frequent to lose settings, but this still happens unfortunately.

    So after two other hours of testing (instead of making music sadly, but with hopes this helps to find a fix), when Blamsoft Overdrive crashes with black screen (this AUV3 lacks stability), very often Dubstation 2, Roughrider 3 and Fac Maxima goes back to default when reloading project or Cubasis. Randomly when loading a project, an AUV3 can goes back to default (even if no AUV3 has crashed). It’s better with 14.6, with previous iOS version it was half of the time.

    Look at this video, it happens with Beef. The graphic glitch happens because of video capture. Beef settings are lost after second CB3 launching @LFS :

    Here was a Cubasis forum post created in December 2020 about the issue:

    https://forums.steinberg.net/t/state-saving-bug/679126

    @ehehehe said:
    No problems here. Maybe the thread title could be edited because it’s crass and also untrue for many users. I only had Dubstation of those mentioned and that’s been replaced with Waves H-Delay because of instability. Noticed too late for a refund. Nowadays I test new plugs thoroughly and refund if there’s issues. With that approach (and track freezing) C3 is very stable on a base ipad with stuff from Bram Bos, Eventide, Moog, Waldorf, Sugarbytes, Korg and more. I actually haven’t experienced crackles even since DrumComputer got an update. So I think there’s more reasons for your troubles than the Cubasis team and their coding. Have you tried track freezing? That’s one of my main tests for plugins because of how useful it is when working on a mobile device.

    Thanks for your advice, but as you can see I’m not alone with the issue. I think it’s needed to have more attention from Cubasis support as issue is there since more than 6 months now. So I will keep the title « crassy » just like that. I spent money on Cubasis 3 app and all their iaps to support them and lose hours of work and don’t even know if older projects will open correctly. I think any forum need freedom of talking. It’s a cool platform where users and devs can talk together. It’s important to keep talking about bad things too, no need for censorship ;)

  • @Janosax said:
    @Samu I’ve updated to 14.6 both devices, and also reinstalled Cubasis 3. It helped as it’s less now frequent to lose settings, but this still happens unfortunately.

    Ok. Let's hope that the coming 14.7 will fix the remaining glitches (on the OS side of things) when it drops...
    Also Cubasis 3.3.1 should be here soon too if the Steinberg forum posts are correct.

    It's the combination of 'things' that are tricky, first the developers 'work around' a bug in the OS and then the bug in the OS gets fixed and the 'work around' messes things up...

    Sometimes I'm really happy I've not rushed into getting a new iPad...
    ...sure my iPad Air 2 is not a speed deamon but at least it's relatively glitch free :D

  • @MisplacedDevelopment said:

    @tja said:
    Now, that sounds like a serious bug :o

    Fortunately it doesn’t completely reset the settings but does lose everything since the last state snapshot. Hit me at the weekend and I lost a good half hour of work. Hopefully an easy fix though for the folk at Cubasis.

    I’ve updated the Steinberg bug report as I now realise this affects instrument plugins (e.g. DigiStix) as well as MIDI effect plugins.

  • @MisplacedDevelopment said:

    @MisplacedDevelopment said:

    @tja said:
    Now, that sounds like a serious bug :o

    Fortunately it doesn’t completely reset the settings but does lose everything since the last state snapshot. Hit me at the weekend and I lost a good half hour of work. Hopefully an easy fix though for the folk at Cubasis.

    I’ve updated the Steinberg bug report as I now realise this affects instrument plugins (e.g. DigiStix) as well as MIDI effect plugins.

    Thanks

    @Samu said:

    @Janosax said:
    @Samu I’ve updated to 14.6 both devices, and also reinstalled Cubasis 3. It helped as it’s less now frequent to lose settings, but this still happens unfortunately.

    Ok. Let's hope that the coming 14.7 will fix the remaining glitches (on the OS side of things) when it drops...
    Also Cubasis 3.3.1 should be here soon too if the Steinberg forum posts are correct.

    It's the combination of 'things' that are tricky, first the developers 'work around' a bug in the OS and then the bug in the OS gets fixed and the 'work around' messes things up...

    Sometimes I'm really happy I've not rushed into getting a new iPad...
    ...sure my iPad Air 2 is not a speed deamon but at least it's relatively glitch free :D

    It’s also my impression that iOS/iPadOS don’t help, 14.5.1 was terrible, my iPhone wasn’t even able to reboot without plugged to a charger. It’s fixed with 14.6. But again no state saving issues with other AUV3 hosts here. 14.6 has been an improvement, let’s hope Cubasis team will find the right fix for next release!!

  • Hi @Janosax, Hi all,

    Thank you for your messages.
    We are already working on Cubasis 3.3.1 which is aimed to resolve the issues and planned to be released shortly.

    Best wishes,
    Lars

  • @MisplacedDevelopment said:
    I have found that freezing a track is a sure fire way of losing MIDI plugin settings. For example:

    1. Start a new project
    2. Add a MIDI plugin, e.g. Atom 2
    3. Add some notes
    4. With the Atom window still visible, freeze the track
    5. Unfreeze the track, all your notes are gone :(

    This works with other plugins too, not Atom specific.

    If you close the plugin window first then that seems to trigger a state snapshot and all is well. @LFS are your devs able to recreate this? It seems Cubasis should be taking a state snapshot before doing the freeze.

    Hi @MisplacedDevelopment,

    Thank you for your report.

    The issue is planned to be resolved with the upcoming Cubasis 3.3.1 update, planned to be released sometime soon.
    Until the update goes live, please check the following WA: Close the AU plugin view before freezing a track.

    Best,
    Lars

  • edited May 2021

    @LFS said:
    Hi @Janosax, Hi all,

    Thank you for your messages.
    We are already working on Cubasis 3.3.1 which is aimed to resolve the issues and planned to be released shortly.

    Best wishes,
    Lars

    Good news, can’t wait thanks.

  • @LFS said:

    @MisplacedDevelopment said:
    I have found that freezing a track is a sure fire way of losing MIDI plugin settings. For example:

    1. Start a new project
    2. Add a MIDI plugin, e.g. Atom 2
    3. Add some notes
    4. With the Atom window still visible, freeze the track
    5. Unfreeze the track, all your notes are gone :(

    This works with other plugins too, not Atom specific.

    If you close the plugin window first then that seems to trigger a state snapshot and all is well. @LFS are your devs able to recreate this? It seems Cubasis should be taking a state snapshot before doing the freeze.

    Hi @MisplacedDevelopment,

    Thank you for your report.

    The issue is planned to be resolved with the upcoming Cubasis 3.3.1 update, planned to be released sometime soon.
    Until the update goes live, please check the following WA: Close the AU plugin view before freezing a track.

    Best,
    Lars

    Thanks @LFS, I appreciate your presence on this forum and the time you spend responding to us.

  • I have a similar issue with Micrologue that I've yet to reliably reproduce (by starting a new empty project)

    I’ll tweak my patch, say cutoff frequency, or amp release and after a restart these changes revert. To further compound the issue, if I save my tweaks as a new preset, the changes are not saved.

    Confusingly, if I then add a new blank midi track, load up micrologue, open the preset, tweak, save it, my changes are saved fine. It’s like the bug only occurs on the instance attached to my original midi track.

    I thought it could be automation, but there has been no automation recorded on the track and the RW buttons are off.

    When I can reproduce this consistently, I’ll post something over at Steinberg.

  • This is why I always keep a clone of my projects and back up the important ones to iCloud.

  • edited May 2021

    Great news: state saving issues seems to be 100% fixed in current beta. I haven’t encountered any « back to default » preset issue while testing this project with various AUV3 and automations lines:

    I closed and opened CB3 perhaps 30 times with that project and not a single problem.

    Great job Steinberg, thanks @LFS

    Can’t wait to test with my iPad M1!!! I really love touchscreen automations with CB3. This workflow suits me even better than Ableton Live :)

  • Hi @Janosax,

    Thanks for the updated message and title, and for your testing support -
    glad to read that our team managed to resolve the problem... :)

    We hope being able to publicly release Cubasis 3.3.1, which will address several user reported issues soon!

    Thanks again,
    Lars

  • Hi @Janosax, Hi all,

    Please note that Cubasis 3.3.1 has been released, which resolves the most frequent user reported issues.

    For more details, please refer to the official announcement: Cubasis 3.3.1 Maintenance Update Available

    Thanks,
    Lars

  • edited June 2021

    @LFS said:
    Hi @Janosax, Hi all,

    Please note that Cubasis 3.3.1 has been released, which resolves the most frequent user reported issues.

    For more details, please refer to the official announcement: Cubasis 3.3.1 Maintenance Update Available

    Thanks,
    Lars

    Thanks for this update, it fixes reliably state saving issue on my side. Multiple midi FXS are also perfectly recorded now. I definitely can use Cubasis 3 with confidence now, my work should not be lost :)

  • @Janosax said:

    @LFS said:
    Hi @Janosax, Hi all,

    Please note that Cubasis 3.3.1 has been released, which resolves the most frequent user reported issues.

    For more details, please refer to the official announcement: Cubasis 3.3.1 Maintenance Update Available

    Thanks,
    Lars

    Thanks for this update, it fixes reliably state saving issue on my side. Multiple midi FXS are also perfectly recorded now. I definitely can use Cubasis 3 with confidence now, my work should not be lost :)

    Hi @Janosax,

    Thank you very much for your updated feedback.
    We are very glad to read, that Cubasis 3.3.1 addressed and resolved your issues!

    Stay well
    & thanks
    Lars

  • Anyone having issues restoring saved states? (AUv3 fxs at least)

    Yesterday, while working on a mastering session, two of the AUv3 plugins got reset to default state, losing all the adjustments I made (particularly DDMF NYCompressor and Mixbox).
    So, I made all the tweaking again and saved the states.. then, when I tried to recall the states, nothing happened. I tested it with different AUv3 (fxs and instruments).

  • @sharifkerbage said:
    Anyone having issues restoring saved states? (AUv3 fxs at least)

    Yesterday, while working on a mastering session, two of the AUv3 plugins got reset to default state, losing all the adjustments I made (particularly DDMF NYCompressor and Mixbox).
    So, I made all the tweaking again and saved the states.. then, when I tried to recall the states, nothing happened. I tested it with different AUv3 (fxs and instruments).

    Works perfectly here with those AUV3 on iPadOS 14.8.1. What’s your version?

  • @Janosax said:

    @sharifkerbage said:
    Anyone having issues restoring saved states? (AUv3 fxs at least)

    Yesterday, while working on a mastering session, two of the AUv3 plugins got reset to default state, losing all the adjustments I made (particularly DDMF NYCompressor and Mixbox).
    So, I made all the tweaking again and saved the states.. then, when I tried to recall the states, nothing happened. I tested it with different AUv3 (fxs and instruments).

    Works perfectly here with those AUV3 on iPadOS 14.8.1. What’s your version?

    iPadOS 15.1

  • I don't know if this helps but I remember having a similar problem about 6 months ago tweaking and saving a micrologue patch.

    I'd adjust filter cut off, release etc.. and after reloading cubasis, the changes were gone. So, I saved the preset, after reloading the preset, my changes would revert.

    What I eventually found out was this only affected the instance of micrologue on that specific track.

    If I made a new track, with a new instance, it would save and reload just fine.

    I could never reliably reproduce it except on the project I was working on, so I never reported it.

  • Try duplicate your project and try also with a new one, perhaps your project is corrupted.

    @sharifkerbage said:

    @Janosax said:

    @sharifkerbage said:
    Anyone having issues restoring saved states? (AUv3 fxs at least)

    Yesterday, while working on a mastering session, two of the AUv3 plugins got reset to default state, losing all the adjustments I made (particularly DDMF NYCompressor and Mixbox).
    So, I made all the tweaking again and saved the states.. then, when I tried to recall the states, nothing happened. I tested it with different AUv3 (fxs and instruments).

    Works perfectly here with those AUV3 on iPadOS 14.8.1. What’s your version?

    iPadOS 15.1

Sign In or Register to comment.