Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Menu mixer

When I open a synthesizer in the mixer menu the first midi volume control button, makes a adjustment and it becomes erratic and I have to restart the application

«13

Comments

  • edited January 7

    @Agapito1 said:
    When I open a synthesizer in the mixer menu the first midi volume control button, makes a adjustment and it becomes erratic and I have to restart the application

    I assume you're referring to AudioBus (this forum actually covers a much wider area).

    • Please identify your AudioBus version and iOS/iPadOS version.
    • Are you using a hardware MIDI controller?
    • Is the synthesizer an Audio Unit (AUv3) or an IAA?
    • Can you describe a simple scenario reproducing this?
    • Post a screenshot of the mixer screen (photo icon above the forum edit window)?

    I myself use AudioBus every day, and often visit apps from the mixer screen, without experiencing MIDI problems. So there may be something in your specific setup that causes a problem, or reveals a bug in AB.

  • Right, I'm using iphone and ipad, and on ipad ios 12.4 it is failing me with the korg module in the mixer window when moving the midi volume is when it does strange things like leaving the sustain pedal activated

  • Ipad 5 ios 12.4, usb keyboard p45, au korg module y fm esentials

  • Where can I comment on my problem and upload the necessary information with a photo and complete details?

  • Also with my iphone I know with ios 13.4 it is doing the same failure

  • I already saw what the problem is, I already tried it with my korg bluetooth keyboard and it does not fail, it is the incompatibility with the yamaha p45, you can fix the bug

  • My problem is, I already tried it with my korg bluetooth keyboard and it does not fail, it is the incompatibility with the yamaha p45, you can fix the bug in the mixer screen, it becomes erratic after moving the midi volume button

  • @Michael Over to you. Sounds like tweaking the volume slider on a MIDI KB upsets the applecart.

  • edited January 9

    Thanks heaps for taking this one this far @uncledave!

    @Agapito1, can you tell me a bit more? What do you mean by erratic/strange things? You said "it does strange things like leaving the sustain pedal activated" - what else happens? Some specific examples would be very helpful, maybe even a video recording. I don't have a P45 to test with, so I'm gonna need a bit extra.

  • With pleasure, I also tried it with my m_audio kesytation 88 controller and it does the same, because for me it is already quite a failure to record that the sustain pedal stays put, and also like it lowers and raises the volume, and I share video of the mistake

  • This is the fault, which also does it with my M-audio keystation 88 ES, and This is the fault, which also does it with my iphone 6 plus,
    An apology because I do not know English and I use the google translator, i from Mexico

  • It is also necessary that the MF splitter be memorized the changes of split and filter of the midi controls

  • I am a composer and this is my city

  • @Agapito1 said:
    I am a composer and this is my city

    Wow, lovely!

    Nice to meet you ☺️

    An apology because I do not know English and I use the google translator, i from Mexico

    Wow, really? Google Translate is getting scary good these days. I, for one, welcome our AI overlords.

    @Agapito1 said:
    This is the fault, which also does it with my M-audio keystation 88 ES, and This is the fault, which also does it with my iphone 6 plus,

    Thanks heaps for the video, that's very clear! Also frustrating, because I can't seem to reproduce it here with the Korg Module audio unit!

    Does it happen for you with Korg Module, as well? Assuming the answer is "yes", I think we need to do a bit more diagnosis. Would you be able to grab the app "MIDI Spy" (it's free): https://apps.apple.com/au/app/midispy/id1444652196

    Then connect it up to your keyboard like this:

    Then, using just a small number of note presses (to avoid filling up the monitor screen), reproduce the issue, just like in your video. Then switch back to MIDI Spy, and take a screenshot and send it to me.

    I hope that might contain some helpful information!

  • @Agapito1 said:
    I am a composer and this is my city

    Such a beautiful piece and a magnificent city.

  • Hi Michael thank you for your email

    I have the same error

    • on both AU units I have loaded (Korg Module, Ravenscroft 275) (Agapito1 is also using this!)
    • happens on both iphone 6 and iphone 11 (both phones running ios 14.2)
    • happens when i adjust the volume via midi (from a yamaha p100)
    • happens if i move the volume slider on the app
    • the error is that the sustain pedal sticks on (and sometimes the volume sticks at very low volume)
    • it only started doing it when i added the midi learn expansion to the audiobus app

    Let me try MIDI spy and come back to you!

    Thank you very much for your response much appreciated

    Moz

  • MIDI Spy not for iphone but will try something similar
    It is strange that I can (anyway) make the same error direct in the app without touching the controller...
    We can work it out !

  • On korg nanokey studio no problem

  • the application midispy is no longer available, but with the Midiwrench
    menu the screenshot

  • @Michael Can this be related to the MIDI Clock messages, every 20 ms?

  • I also got hold of midi wrench for Iphone - will run the error and see what I get - thanks for posting!

  • Thanks guys – actually, MIDI Wrench won’t do what we want because it listens to all incoming messages. I need something like MIDISpy which will only listen to the messages coming from Audiobus. What happens if you search in the App Store for MIDISpy? Maybe that link just doesn’t work in your country?

  • It is the same information, the clock signal that is sent continuously, and the normal midi signal of notes and pedal that I play with the piano.

  • Huh!! No note offs! Could you record another trace after re-launching audiobus without touching the mixer, to see the original signal?

  • @Michael said:
    Huh!! No note offs! Could you record another trace after re-launching audiobus without touching the mixer, to see the original signal?

    There are some Note Ons with velocity zero, which should be OK, but they seem to stop near the bottom of the screen. Glitchy behavior?

  • @Michael said:
    Huh!! No note offs! Could you record another trace after re-launching audiobus without touching the mixer, to see the original signal?

    LOL, Same reflection as me but @j_liljedahl pointed out to me that velocity 0 is the same as note off.

    So a NOTE ON with Velocity 0 == Note off :D

  • @Samu said:

    @Michael said:
    Huh!! No note offs! Could you record another trace after re-launching audiobus without touching the mixer, to see the original signal?

    LOL, Same reflection as me but @j_liljedahl pointed out to me that velocity 0 is the same as note off.

    So a NOTE ON with Velocity 0 == Note off :D

    Exactly, until they stop. Notice 45 32 and 52 39, followed by 45 39 and 52 36, with no velocity zero in between.

  • Let me do it as you ask, because I hope to use the audiobus without problems, in the korg module the split or dual mode does not work and they do not pay attention in any medium

  • @Agapito1 said:
    Let me do it as you ask, because I hope to use the audiobus without problems, in the korg module the split or dual mode does not work and they do not pay attention in any medium

    If I'm not mistaken Korg Module Pro's split & dual modes are only available in the stand-alone app.
    When using the AUv3 the dual / split mode is not available, it's by design.

    To layer & split sounds use two instances of the AUv3.

    Cheers!

Sign In or Register to comment.