Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

AUM and Ableton

I’ve got various channels with AU playing in Aum channels. Everything sounds in sync.

So then I arm them and record into an Audioshare folder.

Then I long press the folder to airdrop. Once to laptop, I line them up in Ableton arrangement or session view scenes. The weird thing is, in Ableton clip view, the clips have wildly different bpm +-40 (not just halved bpm) in each of the clips. Timing is WAY off when properly lined up and played back in Ableton.

The weird thing is, these bpm differences are often recorded from the same AU at the same bpm in Aum. Just recording in passes different AU channels in AU that aren’t multi-out - Drambo (before multi-out), Groovebox, Blocs etc.

iPad Pro 10.5 iOS 13, powerful enough for a few AUM channels. This has to have something to do with a setting in AUM? This is doing my head in, can anyone see something in these settings that could be causing it?


Comments

  • On your iPad, if you open the files in AudioShare or another audio editor that easily lets you see the length in beats at a particular tempo, do the clips seem right? Before driving yourself nuts trying to figure out the Ableton part, first check the recorded tracks/loops to see if they seem right.

  • edited September 1

    I would check Live audio settings. If it's 48kHz than that could be the problem. Make sure you record your audio (AUM) in the same format your DAW (Live) expects it for playback.
    Also match the bit depth in both.
    Edit: as far as I remember Live is set to 48k / 24 bit by default.

  • Are you sure this isn't an Ableton configuration problem?
    Ableton by default will attempt to stretch the clips to match the project BPM unless you change this behaviour,
    So you're sure your Ableton project is the same BPM as the recordings....

  • Thanks, that was the logical next step and you’re right. Everything lines up fine in reaper and audacity. Something is really off about how Ableton is importing these clips. You can see the wild bpm differences it set each clip on import. The live set bpm is at 120, same as Aum recording.

    Individual clip bpm goes all over the place on import. Have Ableton at 44/24, played around setting it down to 16, didn’t help. Changed buffer/latency setting and it didn’t help. Turned individual warp off then on and it set them them both to 120, but as you can see the snare is still misaligned.

    So this isn’t exactly an iOS issue, but if someone can see anything in these setting that could be causing it, I’d appreciate that!






  • edited September 1

    If you have it set to loop mode, and the clip isn’t cropped exactly to the correct length, then it’ll play out of time. I tend to have loop mode off in these situations, and use the Arranger view to ensure clips are cropped and then copied and pasted across a track manually.

  • Thanks @MonzoPro I turned off auto warp completely (assume that’s what you mean/same as loop). The files didn't need trimming. They are lined up fine, playing right same as they were in audacity, reaper etc. Seems it’s something to do with auto warp and Ableton. Weird thing is, I can drag loops into Ableton I’ve made on desktop/packaged loops in fine and the autowarping in Ableton isn’t so strangely off. The files I record from Aum to audioshare then import are. 🤔

  • edited September 1

    Well, changed settings to import as warped one-shot and turned auto-warp long samples off. The Aum files line up fine now. I’ve had to do adjustments to warp markers many times in all the years I’ve used Ableton, never has the bpm been so erratic as when I import from Aum channel recordings with auto-warp on. Gadget, Groovebox etc Ableton set export is always spot on. Hmmm, just don’t get why.

Sign In or Register to comment.