PSA: Don't update to iOS 12.4 if you use apps in AB output slot or IAA apps that use the mic.
https://forum.audiob.us/discussion/34030/urgent-psa-hold-off-updating-to-ios-12-4-if-you-use-apps-in-output-slot-in-audiobus

Rooms!: Wait for 3.41 if you are on iOS 7

Rooms! 3.4 was released yesterday. I was informed by a user that IAA does not work in 3.4 (you get an error message at app startup). The cause is that the IAA entitlement is missing in the app bundle, for unknown reasons. I compiled the project again (identical code, identical project settings) and submitted version 3.41. This time the entitlement is there. So if you are on iOS 7 and use IAA or don't want to get this annoying error message at every cold start of the app, better skip 3.4 and wait for 3.41.

Comments

  • A hint for other developers: After submitting an app, look into the binary details at iTunes Connect and make sure that all needed entitlements are there.

  • Ahh...that explains it....but, too late for me.

  • I am sorry about this. Let me explain what happened. I developed and built with Xcode 5.1 and as always tested with Xcode installation and iTunes installation. When I wanted to submit to the App Store, the ipa was not accepted because it allegedly used some non-public API. It turned out there is a bug in Xcode 5.1 which prevents from submitting apps that support iOS 5. So I installed Xcode 5.0.2 again, built the app with it, tested with Xcode installation and successfully submitted it. But this time I did not test with iTunes installation and hence did not notice the missing IAA entitlement. Why was the entitlement missing? I don't know. Something fishy must have happened when I switched the Xcode versions.

    The strange thing is that 3.4 still passed the Apple review.

  • No worries @polaron_de. I can wait for the next update.

  • Very nice that you keep us informed... :)

Sign In or Register to comment.