Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

BM3 export...disappointing

Hi guys,
I exported a song and audio has ‘buzzing’ in background.
I added a few volume audio automations, some pad quantisation and a panning LFO effect.
There are only five tracks and no audio units on...
I have had success with most export mix down in the past.
I tried both wav and aac...both failed to produce the same clear Audio as in original.

What the **** is going on I wonder?
Thanks....

«1

Comments

  • Of course I could sample the song into Cubasis 2 and mix down, but why?

  • edited August 1
    1. It's going to be hard to help diagnose this issue without some more info about what was contained in your project (which plugins, effects, IAA?, audio recordings)
    2. A video of the bug (or shared copy of your project) can really help
    3. You should probably post these technical support questions on the official BM3 forum
    4. You shouldn't use the word 'disappointing' until you know for sure that it is not user error.
  • For the record... I've been using BM3 for 3+ years and never had any buzzing in my exports.

    Though I stopped using IAA in my projects in 2018.

  • Ok thanks....
    Yes...you’re right about disappointing I suppose.
    I thought I’d try BM3 to Cubasis 2 through AUM anyway....
    But cannot get sound through the following set up..
    Any ideas thanks again?

  • Signal yes...but cannot hear BM3....

  • It’s showing signal in Cubasis through IAA Port 1....

  • @IOSSOS said:
    Ok thanks....
    Yes...you’re right about disappointing I suppose.
    I thought I’d try BM3 to Cubasis 2 through AUM anyway....
    But cannot get sound through the following set up..
    Any ideas thanks again?

    To send audio from BM3 to C2 you'll need Audiobus.

  • IAA port is a midi port... not audio.
    I'm little confused what's the your goal?

  • Record audio from BM3 to Cubasis...
    Due to export problems in BM3....
    Thanks....

  • Signal....but cannot hear it......

  • Since we're dealing with IAA here is background audio enabled in all the apps? (AUM, BM3 and Cubasis).

    And if no other apps than Cubasis and BM3 needed there is no use what so ever to mix in AUM into the equation.

    If you need to connect BM3 to Cubasis using IAA launch BM3 first and make sure background audio is enabled before connecting it to Cubasis.

    I wish IAA was just a bad nightmare and was never invented at all...
    (And instead of IAA we would have something like the classic SoundFlower on iOS).

  • What do you need AUM for between BM3 and C2?
    You can load BM3 in C2 and record its output.

  • Background audio is enabled in all apps....
    But in AUM cannot find background audio to check..
    Settings can’t see it there?

  • The other option is to record all BM3 tracks to separate new audio tracks in BM3......then export...?

  • Despite many tries can’t get BM3 recording directly in Cubasis 2....

  • I tried what was on the screen.....

  • Are any additional Plug-Ins / IAA apps used in BM3 and what sample-rate is the session running at?
    Some Plug-Ins work fine for realtime playback but fail off-line rendering, especially if the sample-rate is changed or the render is done faster than realtime.

    What iPad and iOS version are we dealing with here?
    A little background info on the session (used plug-ins, external apps etc.) is always helpful when troubleshooting issues like this.

    Sometimes I feel that the lack of background info on the issues is more 'disappointing' than the issue itself...
    ...it's impossible to properly assist when too much information is missing...

  • Managed to record straight into Cubasis...
    Thanks again Samu...your points very useful and valid...
    Could be sample rate....
    I have 2017 I pad pro 12.9....Cheers....
    I needed to give more info sure....

  • @IOSSOS Did you hard reboot your iPad?

  • If you could share a copy of the session (even trimmed down but still exhibits the problem if possible) then a whole bunch of us with different devices and OSes could all give it a try and help narrow it down.

  • AUM question please...
    Is there a ‘background audio’ setting?
    On/off..?
    Thanks.....

  • @IOSSOS said:
    AUM question please...
    Is there a ‘background audio’ setting?
    On/off..?
    Thanks.....

    As far as I've understood it it's on by default in AUM otherwise it would not work at all.
    (AUM has 8 output IAA generator output busses and if background audio was not enabled no apps could connect to it).

    The reason some apps have an option to enable/disable background audio is to avoid draining the battery when the app backgrounded but it usually causes more head-aches than it solves especially when connected apps are used...

    So if battery life is a 'non issue' keep background audio on at all times to lessen connectivity issues with audio apps.

    My very humble opinion is that background audio should be enabled at all times...
    Part of the problem is that IAA is 'flawed by design'. If a host (ie. AUM in this case) launches an IAA app and the launch for one or another reason fails the IAA app can get 'ghosted' and since iOS has no proper task-manager the only option to get rid of the 'ghosts' is to do a soft-reset and if that doesn't help a hard reboot...

    This is why I always recommend launching IAA apps before making any connections to them.
    When launching the app first you have at least a remote chance to kill it if things don't work.

    Even though iOS/iPadOS is touted as 'touch and play' it's not always the case.
    I will not cry rivers when IAA gets removed even if it could mean losing a few apps...

  • edited August 2

    maybe like this?

  • Very helpful thanks groundlift....

    Will try this too...yes thought of Audiobus...

    By the way......
    What do you use to highlight the pointer in red please?

  • @IOSSOS said:

    By the way......
    What do you use to highlight the pointer in red please?

    It's part of the pointer settings in iPadOS13.6 when using an external mouse.

  • it’s mouse cursor

    @IOSSOS said:
    Very helpful thanks groundlift....

    Will try this too...yes thought of Audiobus...

    By the way......
    What do you use to highlight the pointer in red please?

  • Ah...ok I’m a bit ignorant...you’re just using a mouse with USB or Bluetooth right...and it just shows up as in the video....?
    Great for tutorials...
    Thanks.....

  • @Samu said:

    Hosting/Recording BM3 in Cubasis with Cubasis triggering playback of BM3 is so sweet. For this I would cry.

  • @IOSSOS : how about changing the thread title to something that sounds like a general statement about BM3 export, maybe: "BM3 Export...Help Needed"

    I don't find BM3 export to be generally problematic. There is probably something specific about your project that BM3 is having a problem with.

Sign In or Register to comment.