Drumjam thumbjam no shows

Got the latest updates, (double checked version numbers on their start up screens -all ok) but neither show up at all in audiobus
Re-started iPad..still no show! ...ouch

Comments

  • Can you try to delete all apps in question, reboot the iPad and install again from the App Store? Then -- ideally -- report back if you can?

    I can't reproduce this over here, yet.

  • Ouch.. That's nearly 400mb of re-downloading! ..ok
    Btw-Thumbjam shows up and loads on my iPhone ok, but so does an old version of drumjam! (it actually shows up- but no control panel as it is obviously the pre- audiobus version)

  • Was your iPad connected to the internet when you launched the Audiobus app?

    Also: was Audiobus running in the background while you were launching Drumjam? If both apps run at the same time, Audiobus picks up DrumJam and will add it to its input list, even if it can't sync with the app database.

  • Just the same here, iPod touch 3rd gen. The apps don't show in the list when I'm starting by Audiobus. I have to startup thumbjam (before or after Audiobus) for it to show up in the list when I'm pressing the input slot...

    Other things are not working but I don't want to pollute the thread...I'll start a specific one...

    Cheers

  • Ho, btw, exact same thing with Drumjam (except the icon is not showing up (just a blank square) when the app is displayed in the list)

  • Btw thanks for staying this calm guys. We're really grateful for people cutting us some slack and letting us get to the bottom of this. Seriously.

  • Calm but excited (the good way) by Audiobus...
    I just tested again (or is it the first time...? I focused on NLog and Thumbjam since yesterday really) with Dumjam and the app does not show in the input slot: just the "busy" animation for the last 2 minutes (I started Drumjam first and it shows 'normally' in Abus list allowing me to choose between input/filter/output)...

    Airplane mode on all other apps shut down (taskbar forced shut down that is)...

    I can try to delete Drumjam and clean reinstall is it helps, won't do it with Thumbjam, to many things to save...

  • Mat, the icon not showing is ... kind of normal because that is loaded from the web. We can't put all of that stuff in the app since new apps are added all the time. So just wait a bit and it'll show up. It's probably either our or Apple's servers being overwhelmed.

  • To be exactly clear: A white square with rounded edges with "DrumJam" next to it == normal and will clear up later.

    No white square with rounded edges, no icon in it, nothing, even though the compatible app is installed and has been started while audiobus was running in the background == something's wrong.

    Can you tell me what it is?

  • The first case: white square with rounded edges (so the normal behavior)

    Bad news: it didn't stop "loading" the app until I turned the Wifi back on (maybe was the program endlessly waiting for the icon to load but couldn't find it as the iPod was offline... confirmed by the fact it finally shown the "ZZZ/tap to launch" icon when I turned the Wifi back on again but took ages to open Drumjam and opened it without any Audiobus control panel in). When I loaded everything as explained in my previous posts: Drumjam , Audiobus then pushed the input slot in the connections screen, everything worked fine, Audiobuspanel present in Drumjam...

  • We're gonna have to have a look at this over here. So do I understand this correctly that you've had WiFi turned off the whole time and couldn't get the connection graph to fully load? After you enabled an internet connection it worked?

  • edited December 2012

    Also, not sure if you did this, but delete and reinstall the Audiobus app, and make sure you have a network when you first start it up. That should be the first thing tried by anyone, before proceeding into further troubleshooting.

    Do NOT delete TJ or DJ, it will not be any help at all, and I don't want people thinking they have to lose any saved work for this.

  • I too am having problems with DrumJam. I deleted Audiobus from my iPad and rebooted it. I then re-installed Audiobus.

    Steps to recreate:
    1. Launch Audiobus
    2. Tap the + icon for input
    3. Drumjam launches
    4. No connection panel present in Drumjam
    5. Double click home button and switch back to Audiobus
    6. A loading (in-progress) icon appears over the Drumjam icon (see screenshot).

    Hope this helps resolve the issue:

    screenshot

  • ETA: ThumbJam works fine for me, btw

  • edited December 2012

    Just to be completely sure, do you see v1.1 when you launch DrumJam?

    I actually just experienced this myself on an iPhone5, the first time what you described happened. Then I killed both AB and DJ, and did the same thing again and it worked fine. I will definitely look into it, sounds like a race condition.

  • Yup, v1.1 in the lower right corner of the splash screen.

  • Launching DrumJam first and THEN launching Audiobus works

  • We're about to submit an update that should put an end to this problem. It's a caching thing - currently Audiobus only checks the App database every 24 hours, which is not enough. A slight oversight of us.

    Sorry!

  • Awesome, thanks guys. Really appreciate the responsiveness of Sebastian and Michael, as well as Sonosaurus et al.

  • In the meantime turning off background audio in Drumjam's settings works

  • I am able to reproduce this issue on an iPad2 with iOS5, and an iPad3 running iOS6. In that case starting DrumJam before starting Audiobus does the trick. On iOS6 on iPhone5 and I see it once after a reboot, but subsequent times (after killing both) it was acting normally (AB can be started first and it launches and connects DJ fine). But I've also seen it work normally on the iPad3 as well.

    Again, I will be investigation a true fix.

  • All seems well after re downloading.. Thanks

  • Just posted this over on discchord, but thought it really belongs on your support forum...

    Another DrumJam comment -- iPhone 4S, iOS v6.0.1:

    If I start Audiobus and add DrumJam to the input slot, then tap the Zzzz icon to launch DrumJam, the app launches, but no AudioBus tab shows up. I can start/stop and play the pads in DrumJam. When I double-tap home and return to AudioBus, the DrumJam icon shows the spinner overlay and tapping it will not return to DrumJam. (I do not have my iPad 2 in front of me, but I believe I'm encountering the same behavior there as on my iPhone.) This is an apparent bug.

    On the other hand, if I close all the running apps, then launch DrumJam first, wait for it to load, then hit home and launch AudioBus, I can add DrumJam to the input slot -- I just tapped on the app name, not the (>) button -- and the icon shows up without the spinner overlay. Tapping into DrumJam, I now see the AudioBus tab. This is the behavior I expected to see.

  • Hey @caspianx67 – does this work better if you turn on Airplane mode? We discovered recently that some poorly-configured networks can interfere with Audiobus.

  • @Michael - Tested both launch orders with Airplane mode on and off, no difference. Tested both launch orders with Airplane mode off, Wi-Fi on and off, no difference. If Audiobus is launched first, DrumJam will not function in the input slot. If DrumJam is launched first, Audiobus will pick it up and it'll work.

  • Okay, that makes sense now - since my last message, I've worked with Jesse on this problem and he's working on an update that will fix the problem.

    It looks like the problem is a bug in one of Apple's communication libraries that was being triggered by DrumJam's initialisation. It'll be fixed in the update, but until then, here's how to avoid the problem:

    1. Either quit Audiobus (via the multitasking bar, or make sure that DrumJam isn't in the connection screen.
    2. Start DrumJam manually, from the Home screen.
    3. Switch back to Audiobus, and add DrumJam - it should work now.

    The problem is triggered when you launch DrumJam from Audiobus.

Sign In or Register to comment.