Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

(MIDI) Routing/Recording, AB Remote Questions

Hi!
Want to do the following:

Load multiple instances of synths. Lets say, 2 x Moog Model D, 2 x Sunrizer, NanoStudio‘s Obsidian etc...

Control them with Fugue Machine (have it) or StepPolyArp.

Switch fast with AB Remote App on my second iOS device between the synths and the controller app to tweak them live.

I would love to record the MIDI of what Fugue Machine plays, i only have Cubasis 2 and Nanostudio 2.

What (else) do i need to jam/record like this, how would you setup AB for this?

Comments

  • edited June 29

    I think you can do this with what you have already.

    Setup the AB Midi like you would normally, with each FM and SPA midi channel on its own lane in the Midi input slot, and whatever apps that are receiving Midi in the Midi output slots.

    In order to record the Midi, you can add an additional Midi output to each AB lane you want to record. Use the system tab when loading the recording connection, and select either Virtual Midi or Cubasis, and select a unique Channel to send/receive on.

    In Cubasis, create a Midi track for each Midi stream coming from Audiobus. You may want to set it to No Instrument so it doesn’t make any sound. In the Routing panel, select the Midi input. If you are sending to Virtual Midi Bridge in AB, select AB3 as the Midi input source in Cubasis. If you are sending to Cubasis in AB, select Virtual Midi as the source in Cubasis. Remember to also select the correct Midi Channel for each track.

    Arm all the tracks in Cubasis and they will all record at the same time.

    This will enable you to capture the Midi while AB is playing back. If you want to record loops and switch from a sequencer app driving midi to a Cubasis loop driving midi, after capturing a loop, that is technically more challenging, and this setup will not do that. This just records the Midi in Cubasis so you can save it or manually manipulate it for further use.

    I would advise recording the Midi in Cubasis, rather than in NS2, since you also mentioned using NS2 as a sound source. Using NS2 for both simultaneously can add confusion and complicate things. Also, I know Cubasis can record to all the separate Midi tracks at the same time. I am not positive NS2 can do this, as I never tried it in that app.

    Here is a SS of a single Midi lane in AB with 2 midi outputs connected, just to help clarify.

  • @CracklePot said:

    >

    Here is a SS of a single Midi lane in AB with 2 midi outputs connected, just to help clarify.

    Thank you!! The screenshot says it all - shame on me... 🥴

  • @Pummelfee
    🤙🏻
    Glad to help, always.

  • Oh, i tried but it failed. As soon as i add an additional MIDI Output to either VM or Cubasis, Fugue Machine will not play. I tried also to setup the Sync in AB to send MIDI Clock from FM or AB to Cubasis. Any idea...?

  • edited June 30

    ...if i try to use NS instead of CB to record MIDI, this works. But as soon CB is involved (even if i have not set any outputs to VM or CB, it‘s enough to have CB shown up in topmenu of AB, FM does not move it‘s playheads. When i remove CB from AB, it plays again.

    EDIT: I re-installed Cubasis and now it works. I can record MIDI AND Audio... 😀

  • Not sure about why FM doesn’t play. Make sure that the main play button is engaged, as well as some Playheads. It seems obvious, but AB won’t auto-start FM unless the main play button is engaged.

    For syncing AB and Cubasis, try this:
    In AB, turn on receive Midi clock, and select Virtual Midi as the clock source.
    I also have Link enabled, with link start/stop enabled, but I don’t think that is required.

    In Cubasis, turn on Send Midi clock (midi settings) and also set the Precount to 1bar (metronome settings). Turn on Count In (Recording Mode options at the bottom of the Tempo panel. Tap the BPM display).

    When you hit Record in Cubasis, it pre-counts 1 measure, and then AB starts playback as Cubasis starts recording. If you don’t use the pre-count AB plays back all garbled for the first measure, I think while it syncs all the clocks. This may be because I have Link start/stop enabled.

    This is working reliably for me. If you cannot track down why FM isn’t playing while using Cubasis, then you can always use NS2. I just don’t have the chops to help much in that app, so I try explaining how to do it with Cubasis.

Sign In or Register to comment.