Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

IDAM between iPad and Bitwig(macbook)

Hi,

Due to my ex-partner diagnosed with Meniere, i am helping her for at least a couple of weeks to get up her feet again, and to take care of the kids. I have my macbook and iPad here and in the spare time fiddling a bit with music.
Here comes the problem:
I am using Bitwig on my macbook and i want to try to stream MIDI from mu iPad (AUM) to an instrument track in Bitwig.
AUM sees IDAM MIDI-host in the connection matrix.

In Audio/Midi configuration on macbook i have this:

In Bitwig under setup i have this:

And i can't see any midi-input from the iPad in the instrument track.

So, i can't transfer midi from iPad to macbook or vice versa.

I have tried IDAM MIDI in Ableton and Reason, and they both see midi from iPad.
In Reason i can send midi to a synth in AUM and at the same time record the synth in Reason.

Anybody got a clue what i'm doing wrong, or it might be that Bitwig can't handle IDAM Midi?

Comments

  • edited May 2020

    I typed an answer then saw I was incorrect. In order to record the audio from my iPad in the past though I’ve had to make an aggregate device that included iPad as an input, maybe that’s the issue? Currently in audio midi setup only your built in mic and built in output are being used.

    I have never used bitwig so I can’t help you on that side of it.

  • I noticed on your first photo of the AUM Midi connection matrix, nothing is routed. Do you have your routings set there?

  • @mrufino1 said:
    I typed an answer then saw I was incorrect. In order to record the audio from my iPad in the past though I’ve had to make an aggregate device that included iPad as an input, maybe that’s the issue? Currently in audio midi setup only your built in mic and built in output are being used.

    I have never used bitwig so I can’t help you on that side of it.

    I have not tried that yet, maybe i can figure that out. An aggregate device is something that includes all in- and out’s if i’m right?

    @Eschatone said:
    I noticed on your first photo of the AUM Midi connection matrix, nothing is routed. Do you have your routings set there?

    That is correct. I have no instrument included in the matrix. I only wanted to show that there is IDAM available.

  • @Identor said:

    @mrufino1 said:
    I typed an answer then saw I was incorrect. In order to record the audio from my iPad in the past though I’ve had to make an aggregate device that included iPad as an input, maybe that’s the issue? Currently in audio midi setup only your built in mic and built in output are being used.

    I have never used bitwig so I can’t help you on that side of it.

    I have not tried that yet, maybe i can figure that out. An aggregate device is something that includes all in- and out’s if i’m right?

    @Eschatone said:
    I noticed on your first photo of the AUM Midi connection matrix, nothing is routed. Do you have your routings set there?

    That is correct. I have no instrument included in the matrix. I only wanted to show that there is IDAM available.

    Correct, just hit the plus sign below the interfaces to create a new aggregate device and include anything you want to include.

  • i have tried the aggregate device setup, but still no midi in or out. It seems like Bitwig does only midi sync from- and to the ipad, but no midi-notes. It doesn't show up in the available midi sources when selecting an instrument channel in Bitwig.
    (I have Bitwig 3.03)

  • I think all that is missing (based on the photos presented) is the “controller input” in Bitwig. Under “Controllers”, click the “+ Add Conroller” button and add a new Generic MIDI Keyboard and then select the iPad for its input.

  • Ahh, that would maybe the solution. I will try it tonight. (CET)

  • I have the iPad selected as Generic MIDI keyboard. Now i can send midi-notes from iPad to Bitwig. Still not vice versa.
    Now comes a second problem:
    Rozetta XOX:

    Bitwig:

    As you can see, The recording of midi starts 1/8 note too early.

    I have tried everything, but no result.

    I think i gonna give up to use IDAM with bitwig. It has cost me 2 evenings to figure out...

  • On a second note: Bitwig doesn't Support IDAM As it seems. I got a confirmation from Bitwig support.

    Hi Adriaan​,

    we have not added anything particular to support IDAM, but as it seems to register as standard midi driver in macOS, we would expect it to work. How exactly did you set it up in the Apple Audio MIDI Setup app and in the Bitwig Studio preferences?

    Best regards,
    Bitwig Technical Support Team

  • Very strange, because the ipad is just seen as a stereo audio Input and 16 in out midi, shouldnt have anything to do with the daw.

    Did you say you were using aum? I’ve never used that either, I’ve just used my ipad directly with one app at a time, for instance replacing logic’s mellotron with streetlytron, so maybe it has something to do with the routing in aum?

  • @Identor said:
    On a second note: Bitwig doesn't Support IDAM As it seems. I got a confirmation from Bitwig support.

    Hi Adriaan​,

    we have not added anything particular to support IDAM, but as it seems to register as standard midi driver in macOS, we would expect it to work. How exactly did you set it up in the Apple Audio MIDI Setup app and in the Bitwig Studio preferences?

    Best regards,
    Bitwig Technical Support Team

    Hello again :)

    I believe IDAM is just the name/acronym for the connection happening between the ipad and the mac. Bitwig hasn’t incorporated anything specifically IDAM related, but they are also saying here that the iPad should be viewed as a standard midi device. If you wish to verify this, go into “Audio MIDI Setup” on the Mac. If you inspect the iPad panel (in the MIDI window, not the Audio window) it should reflect that it can send and receive, and also allow you to select which channels it will do so on. There is not a need to view or change the settings here currently, I only mention it to help direct you to where some useful connection information can be found.

    For getting MIDI out of Bitwig, and some other DAW’s, you will need to create an instrument out (Instrument > Bitwig Device > Hardware > Bitwig > “HW Instrument”). With this HW Instrument in place, you can select where the MIDI is sent to and you can also select the audio input from the iPad (or your aggregate device) and have the audio returned to the same channel (my source name is “stereo out” but the iPad is selected as the audio source in Bitwig’s settings).

    Hopefully that can help clear things up some more? I’ll be around a while longer anyhow :) Hopefully you’re about.

  • On a side note, I’m not sure how to address the timing issue... I’ll look at it further, but no promises :neutral:

  • @tehskwrl said:

    @Identor said:
    On a second note: Bitwig doesn't Support IDAM As it seems. I got a confirmation from Bitwig support.

    Hi Adriaan​,

    we have not added anything particular to support IDAM, but as it seems to register as standard midi driver in macOS, we would expect it to work. How exactly did you set it up in the Apple Audio MIDI Setup app and in the Bitwig Studio preferences?

    Best regards,
    Bitwig Technical Support Team

    Hello again :)

    I believe IDAM is just the name/acronym for the connection happening between the ipad and the mac. Bitwig hasn’t incorporated anything specifically IDAM related, but they are also saying here that the iPad should be viewed as a standard midi device. If you wish to verify this, go into “Audio MIDI Setup” on the Mac. If you inspect the iPad panel (in the MIDI window, not the Audio window) it should reflect that it can send and receive, and also allow you to select which channels it will do so on. There is not a need to view or change the settings here currently, I only mention it to help direct you to where some useful connection information can be found.

    For getting MIDI out of Bitwig, and some other DAW’s, you will need to create an instrument out (Instrument > Bitwig Device > Hardware > Bitwig > “HW Instrument”). With this HW Instrument in place, you can select where the MIDI is sent to and you can also select the audio input from the iPad (or your aggregate device) and have the audio returned to the same channel (my source name is “stereo out” but the iPad is selected as the audio source in Bitwig’s settings).

    Hopefully that can help clear things up some more? I’ll be around a while longer anyhow :) Hopefully you’re about.

    Thank you, i shall figure it out tonight (CET).

  • what kind of input/track should you have in the DAW to recognize IDAM ?

  • @BitterGums said:
    what kind of input/track should you have in the DAW to recognize IDAM ?

    The DAW doesn’t recognize IDAM specifically, but will see the device connected by IDAM as a midi input/output and audio source. Once connected to the Mac, the ios device must first be enabled in Audio/MIDI Settings before any DAW will be able to recognize it. Set your-choice-of-DAW’S settings (audio input source should be set to ipad and a new generic midi controller added with the ipad as its input) and add a hardware instrument on a MIDI track to output MIDI back to the ipad.

  • edited May 2020

    @tehskwrl said:
    On a side note, I’m not sure how to address the timing issue... I’ll look at it further, but no promises :neutral:

    I think You might need to set the MIDI sync from bitwig to your iOS device. Looking at your screenshot it looks like Rosetta doesn’t know where the start of the bar/song and isn’t syncing to the beat. It’s just playing back midi at the same tempo but off grid.

    Check your MIDI settings in bitwig; I don’t have bitwig but I’m guessing it must have options to send MIDI clock including start/stop etc. You might have to tinker with the settings to get things lined up.

    The easiest way to use IDAM is to send MIDI from Bitwig to you iOS device and record the audio back. Your iOS device is then effectively an external midi instrument. Just sequence it from bitwig.

    I do this with Logic frequently (sequence my iOS synths from Logic and record audio back into Logic) and it works perfectly.

  • A small update: I am using Audiobus 3 now, and now Bitwig can communicate with it. I used a HW-Instrument in Bitwig to send notes to AB on CH1. In AB midi setup i set IDAM MIDI host as receiver to control Fractal Bits.
    In Bitwig i set up an Audio Channel to receive the Audio of Fractal Bits. When i record the audio, its almost spot-on with timing.
    Next thing i tried: Setup Atom Piano roll on channel 2 to IDAM MIDI host. In Bitwig i setup an instrument track with an AU-synth.
    The synth receives the MIDI from AB (CH2) by choosing the iPad as the receiver on CH2.

    Im still confused why AUM can't do what AB3 can do... I like the AUM approach more than AB3.

  • I know this doesn't help resolve the issue, but I have no problems with exactly the same setup between my iPad and Ableton Live on my MacBook. My guess from this is that it's possible that it's a Bitwig issue?

  • edited January 17

    @tehskwrl said:

    @Identor said:
    On a second note: Bitwig doesn't Support IDAM As it seems. I got a confirmation from Bitwig support.

    Hi Adriaan​,

    we have not added anything particular to support IDAM, but as it seems to register as standard midi driver in macOS, we would expect it to work. How exactly did you set it up in the Apple Audio MIDI Setup app and in the Bitwig Studio preferences?

    Best regards,
    Bitwig Technical Support Team

    Hello again :)

    I believe IDAM is just the name/acronym for the connection happening between the ipad and the mac. Bitwig hasn’t incorporated anything specifically IDAM related, but they are also saying here that the iPad should be viewed as a standard midi device. If you wish to verify this, go into “Audio MIDI Setup” on the Mac. If you inspect the iPad panel (in the MIDI window, not the Audio window) it should reflect that it can send and receive, and also allow you to select which channels it will do so on. There is not a need to view or change the settings here currently, I only mention it to help direct you to where some useful connection information can be found.

    For getting MIDI out of Bitwig, and some other DAW’s, you will need to create an instrument out (Instrument > Bitwig Device > Hardware > Bitwig > “HW Instrument”). With this HW Instrument in place, you can select where the MIDI is sent to and you can also select the audio input from the iPad (or your aggregate device) and have the audio returned to the same channel (my source name is “stereo out” but the iPad is selected as the audio source in Bitwig’s settings).

    Hopefully that can help clear things up some more? I’ll be around a while longer anyhow :) Hopefully you’re about.

    I was trying to figure this out today, one of the ways it was a little easier to set up things in Ableton.. Thanks! It would have taken me a while to figure out using the HW Instrument was needed.

    I'm hosting instruments in AUM receiving on the IDAM midi channel, outputting to USB. How I have Bitwig set up is with the iPad set as the main input in the audio settings, and a generic midi controller set to iPad.

    The Instrument track is set to output MIDI to the iPad, then the Audio track has a HW instrument receiving the iPad's audio.

    It's not as straightforward as Ableton was, but it's working better on my iPad 6 than Studiomux was. running through Studiomux was giving me crackling just frequently enough to be irritating.

    Hope this helps the next poor soul that tries to get IDAM and Bitwig talking to each other.

Sign In or Register to comment.