Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Riffer sync issues

Just a heads up to the DEV, I love the concept of Riffer and would use it frequently ---- but after about 8 loops the midi sync drifts badly. It seems like it is getting start / stop messages, because it sounds lined up and great for the first few bars then drifts into wonky town. Is there some setting I need to get midi clock to lockon... ?? I like the layout of the app, hope this gets fixed. This has been a problem since I first got the app. Using a 2018 10.5 iPad Pro w/ Aum as clock source.

Comments

  • +1 on this. I was experiencing the same sync drift last night. Also iPad 10.5 pro with Riffer in AUM (on a midi channel as AU midi processor). Midi notes to SynthMaster, my drums from EG Pulse.

  • edited February 10

    From day 1, I’ve had major sync issues with Playbeat from the same dev @Audiomodern , although my sync problems with Riffer seem to be sorted in the recent v2 update.
    Hopefully the dev is addressing it.
    Air2 iPadOS 13.3.1

  • Yep, drift issues with both apps here.

  • @lukesleepwalker said:
    Yep, drift issues with both apps here.

    Yes - sync drifts after a 8-16 bars. I sent email to developer about it happening in previous version - but got a reply back saying they couldn't replicate the issue...

  • @Halftone said:

    @lukesleepwalker said:
    Yep, drift issues with both apps here.

    Yes - sync drifts after a 8-16 bars. I sent email to developer about it happening in previous version - but got a reply back saying they couldn't replicate the issue...

    Maybe I will write them again - suggest others do the same and maybe they will look at it more

  • Good idea. Will do the same. They have been quite responsive in the past.

  • @lukesleepwalker said:
    Good idea. Will do the same. They have been quite responsive in the past.

    Just sent them email ...

  • @Audiomodern waiting for midi pattern chaining and sync drift issues fix ;-)

  • They responded immediately to my email, which they always do. Great service. They reported that they cannot replicate so perhaps we can help. Is this only an issue in AUM?

  • @lukesleepwalker said:
    They responded immediately to my email, which they always do. Great service. They reported that they cannot replicate so perhaps we can help. Is this only an issue in AUM?

    AUM is the main app I need it for, haven't checked other apps yet.

    Thanks for helping with [email protected]!

  • I’m surprised they cannot replicate this in AUM. Load Riffer AU, point it at a another AU, turn on the AUM metronome, and it drifts out of time within 5 mins.

  • @gusgranite said:
    I’m surprised they cannot replicate this in AUM. Load Riffer AU, point it at a another AU, turn on the AUM metronome, and it drifts out of time within 5 mins.

    Maybe they don't have AUM?

  • Might be an idea to send a video with it drifting. I must admit, seems to be better for me now although it was drifting before.

  • I just did an experiment in AB3 and had no drift at all.

  • @lukesleepwalker said:

    @gusgranite said:
    I’m surprised they cannot replicate this in AUM. Load Riffer AU, point it at a another AU, turn on the AUM metronome, and it drifts out of time within 5 mins.

    Maybe they don't have AUM?

    I have no words 😶

  • Are you guys running at 44.1khz? Riffer seems to have problems with 44.1k on newer devices, which are some sort of hardwired to 48k (afaik...)
    It runs fine at 48k on my setup (ipad 6th gen, AUM, latest ipadOS).
    cheers

  • edited February 11

    @electronicsfordogs said:
    Are you guys running at 44.1khz? Riffer seems to have problems with 44.1k on newer devices, which are some sort of hardwired to 48k (afaik...)
    It runs fine at 48k on my setup (ipad 6th gen, AUM, latest ipadOS).
    cheers

    no - I'm having issues on my ipad 2018 6th Generation here - running ios 12.2.1 .

    I sent video to developer this morning... I tried syncing a couple apps in AUM, andalso tried running riffer standalone in background sending notes to Gadget. And also with Future Drummer instead of Gadget... each time it's the same: you can hear slight flamming effect (I tested using kick drums) after about 1 min... after 2 mins the flamming is more pronounced - and after 3:30-4minutes Riffer is very much out of sync with an offset kick.

    video link if interested:

  • I’m on Air2 at 44.1 in AUM, a friend has the same sync problems on an Air3 at 48k

  • mmmh.
    Did you try different buffer sizes?
    I'm running at 1024, allthough I don't know
    if that makes a difference...
    cheers

  • @electronicsfordogs said:
    mmmh.
    Did you try different buffer sizes?
    I'm running at 1024, allthough I don't know
    if that makes a difference...
    cheers

    i dunno if 1024 would make a difference - i tried both 256 & 512... have you tried letting Riffer play out for 3-4 mins? And it's still in perfect sync?

  • just did the exact same test (rozetta vs riffer, 2x sm1). stays perfectly in sync for more than 5mins. running at 48/256. At 48/1024 timing is somewhat back and forth, but doesn't drift apart. At 44.1k the result is exactly like yours.
    cheers

  • @electronicsfordogs said:
    just did the exact same test (rozetta vs riffer, 2x sm1). stays perfectly in sync for more than 5mins. running at 48/256. At 48/1024 timing is somewhat back and forth, but doesn't drift apart. At 44.1k the result is exactly like yours.
    cheers

    Confirmed! I set AUM to 48khz and it syncs good / no drift. I let developer know... fingers crossed it'll be fixed now that the cause is known.

  • @Halftone said:

    @electronicsfordogs said:
    just did the exact same test (rozetta vs riffer, 2x sm1). stays perfectly in sync for more than 5mins. running at 48/256. At 48/1024 timing is somewhat back and forth, but doesn't drift apart. At 44.1k the result is exactly like yours.
    cheers

    Confirmed! I set AUM to 48khz and it syncs good / no drift. I let developer know... fingers crossed it'll be fixed now that the cause is known.

    Thank you !
    My doctor said I was making it up, since day 1-
    Refusing to give me any more pills,
    I knew I was right,

  • @gsm909 said:

    @Halftone said:

    @electronicsfordogs said:
    just did the exact same test (rozetta vs riffer, 2x sm1). stays perfectly in sync for more than 5mins. running at 48/256. At 48/1024 timing is somewhat back and forth, but doesn't drift apart. At 44.1k the result is exactly like yours.
    cheers

    Confirmed! I set AUM to 48khz and it syncs good / no drift. I let developer know... fingers crossed it'll be fixed now that the cause is known.

    Thank you !
    My doctor said I was making it up, since day 1-
    Refusing to give me any more pills,
    I knew I was right,

    developer sent email this morning - said fixing the sync issue is top priority and they hope to release a fix as soon as they can.

Sign In or Register to comment.