Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

AU instruments: remembering patches

I’m using 3 different ISEM patches for a track. All loaded as AU instruments. I don’t have any issues doing this initially but when I come back to the track the next time after app has been closed and reopened all ISEM tracks are using the same patch which is whatever seems to be the last patch I used in ISEM. This happens in both NS2 and BM3. Am I doing something wrong or is this just a limitation on iOS at the moment?

Comments

  • No that’s a bug if you’re using the AU and saving/loading the host session...should save the patch

  • @Carnbot said:
    No that’s a bug if you’re using the AU and saving/loading the host session...should save the patch

    I thought that was how it’s meant to work but wasn’t sure. It will save whatever patch I used last but not multiple patches from the same app. Will test it more later with other apps to see if it’s just isem

  • edited January 19

    It's a very basic bug that occurs in many AUv3 apps. What their developers don't realize is that all instances of their plug-in share the same process and thus the same global variables, etc...

    Some very basic testing (i.e., errr, load two instances of the plug-in) should normally catch this during development if it isn't clear from the start...

  • Cheers for the info, any idea on workarounds except to record the tracks as audio? This is what I’ll do but when I decide to add an extra note (which I know we all always do 😂) then I’ll need to start the process again

  • edited January 19

    ok just tested iSEM in AUM....for me it is working But the patch name has reverted to say the same for all instances, the patches are the correct ones saved though. So still a bug (and another common one) but at least the sound is saved with the session :)

  • First off, do you have the most recent version (1.5)? Up until the last update iSEM had a bug where even a single instance didn't save its preset correctly.

    However, as @Carnbot notes, iSEM seems to behave correctly in AUM. I tried this with 3 instances both with 3 different patches loaded and with 3 modified patches (i.e. they weren't saved as patches in iSEM, they only had their settings in the AUM session). In both cases everything worked as expected, except, as noted, the patch name is incorrect (this has always been the case with iSEM and you see it in a few other synths as well).

    I just tried this out with BM3 as well, it seems to be behaving normally there too, both with recalling saved presets and recalling settings that weren't saved directly in the synth, only saved by the host session.

Sign In or Register to comment.