Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Cubasis 3 - BUGS (on topic)

I thought (hope) it would be a good and helpful (hopefully) idea to make a thread that focus ONLY on bugs,NO CHATTER please.Make it as easy as possible for @LFS to track down bugs.Keep it simple,keep it short.

Please provide the following infos as well:

Are any 3rd party apps involved?
Did the issue appear when using CB 3 on its own?
What iPad model/iOS system?
Free iPad memory
Can you reproduce the bug?


bugs:

1.Reopen C3 does not reload Rozeta Xox (driving Ruismaker),i have to unload and select/open it again.I can reproduce it every time.Just close Cubasis and open it again.

2.Freezing a track in real time (tried it with the same combination of Rozeta XoX and Ruismaker)
results in a glitchfest wavefile.Also reproducible every time.

3.The hickup at the beginning of a loop....we all know this,no need to explain further :wink:

No other apps running,ipad pro 10,5,a LOT of free memory,ios 13.3

«1345678

Comments

  • Apple Pencil not working on iPad Pro 2018 12.9 - Bug or not supported?

  • edited December 2019

    I get the intention with this thread but think the best thing to do would be to follow @LFS directions from the previous thread...

    “Thank you for your message.

    Are you able to file bug reports at our Cubasis 3 forum, making sure we're not loosing anything?
    If so, this is the link: steinberg.net/cubasisforum.

    Below please find the bug reporting form.

    Once we're able to reproduce the issue, there is a good chance for a fix!

    Thanks again,
    Lars

    Reporting Form

    Summary/Title
    (Provide a short but descriptive sentence that summaries the issue or feature request)
    Description
    (Provide a detailed description and list the step by step process to reproduce the issue to help the team to understand and reproduce the problem)
    Expected Results
    (Describe what you expected to see)
    Actual Results
    (Describe what you actually saw)
    Environment
    (Count the hardware and software including version numbers being used)”

  • https://helpcenter.steinberg.de/hc/en-us/articles/206220404-Cubasis-for-iOS-Known-Issues

    Check here as well ^

    My main gripe:

    CBT-1273 Cubasis 3 is not sending MIDI Clock start/stop from the transport buttons.

  • Yeah the official Steinberg Cubase 3 forum seems the place for bug reporting, so maybe this thread could be just to blow off steam from our frustration :wink: I really like Cubasis a lot and have pretty successfully stopped using Reaper and my desktop computers and am now just using 3 iPad Pro’s for everything, so I really really really want Cubasis 3 to be successful!

  • Hi Crabman, Hi all,

    This is a very great idea!

    If possible, it is of great help for us, if you could use our bug form below.

    Thank you for your support!

    Best wishes,
    Lars

    Reporting Form

    Summary/Title
    (Provide a short but descriptive sentence that summaries the issue or feature request)
    Description
    (Provide a detailed description and list the step by step process to reproduce the issue to help the team to understand and reproduce the problem)
    Expected Results
    (Describe what you expected to see)
    Actual Results
    (Describe what you actually saw)
    Environment
    (Count the hardware and software including version numbers being used)”

  • @d4d0ug said:
    https://helpcenter.steinberg.de/hc/en-us/articles/206220404-Cubasis-for-iOS-Known-Issues

    Check here as well ^

    My main gripe:

    CBT-1273 Cubasis 3 is not sending MIDI Clock start/stop from the transport buttons.

    Hi @d4d0ug,

    We have this on the list and will do our best to address it in the next Cubasis 3 update!
    Please give us a moment, since season hoidays will begin shortly.

    Hope for your understanding.

    Best,
    Lars

  • @brattcave said:
    Apple Pencil not working on iPad Pro 2018 12.9 - Bug or not supported?

    Already entered this into our bugbase.
    Thanks, @brattcave!

  • @Crabman said:
    I thought (hope) it would be a good and helpful (hopefully) idea to make a thread that focus ONLY on bugs,NO CHATTER please.Make it as easy as possible for @LFS to track down bugs.Keep it simple,keep it short.

    Please provide the following infos as well:

    Are any 3rd party apps involved?
    Did the issue appear when using CB 3 on its own?
    What iPad model/iOS system?
    Free iPad memory
    Can you reproduce the bug?


    bugs:

    1.Reopen C3 does not reload Rozeta Xox (driving Ruismaker),i have to unload and select/open it again.I can reproduce it every time.Just close Cubasis and open it again.

    2.Freezing a track in real time (tried it with the same combination of Rozeta XoX and Ruismaker)
    results in a glitchfest wavefile.Also reproducible every time.

    3.The hickup at the beginning of a loop....we all know this,no need to explain further :wink:

    No other apps running,ipad pro 10,5,a LOT of free memory,ios 13.3

    Hi Crabman,

    Entered your issues into our bug base.
    We'll discuss these issues after the holiday seasons ended.

    CBT-1291
    Reopen C3 does not reload Rozeta Xox (driving Ruismaker)

    CBT-1292
    Freezing a track in real time results in a glitchfest wavefile

    Are you able to provide more details regarding #3?

    3.The hickup at the beginning of a loop....we all know this,no need to explain further :wink:

    Thanks,
    Lars

  • Hi @LFS ,about #3

    When C3 is set to loop play (with couple of AUs but it's enough to use just one i.e, pure acid with a kickdrum on the first beat it's best noticeable).When the loop starts again it creates a"doublekick" on the very first beat and the timing goes slightly off for the first 1-3 beats of the first bar,after that it runs fine again.I try to provide an audio example later.

    sorry,i can describe it better in german (i know you understand this Lars ;) ) :Cubasis"stolpert" am Anfang eines neuen Loopdurchgangs ein bischen.

    About the Steinberg Forum: i know it exists but for most iOS musicians (and me) this forum is still the number one source and Lars is very active here as well.I really think it doesn't hurt to run a thread like this as long as it srays free from all off topic stuff!!!

  • some midi auv3s are not recording any midi to the timeline and/or not sending midi to instruments
    I tested 10 so far with these results:

    — midi auv3 that don‘t work in Cubasis 3
    Aphelian
    Ochtachron
    KB1
    Velocity Keyboard

    — midi auv3 that work in Cubasis 3
    StepPolyArp
    Fugue Machine
    Xequence
    Atom
    GeoShred
    Rozeta

  • edited December 2019

    I apologize if this would be seen as off topic, but a key development item for me is getting the Cubase importer done for the new Cubasis 3. Ideally, I’m hoping that Cubasis 3 will allow smoother passing of projects both ways back and forth with Cubase 10 in general. (And +1 on the Apple Pencil).

    THANK YOU to you @LFS and your team. You have the patience of a saint haha 😂. Long time Cubase/Cubasis ecosystem customer here and very excited with the release of Cubasis 3!!

  • @LFS, thank you for your hard work! Here’s a little bug:

    Summary/Title
    Wrong note being highlighted while changing note’s velocity/position using the buttons on the left

    Description
    Select a note, then add another note to selection and remove it so there is only the first note in the selection. Press velocity button and swipe over the selected note.
    Expected Results

    Actual Results

    Environment
    iPhone X, Cubasis 3.0.0.42

    Also it would be nice to be able to hide bottom velocity row to expand piano roll a bit on small screens.

  • Hello everyone,

    When I copy a midi segment of a track, and paste it on the same track, that segment does not sound ... the instrument is microsonic ...

    Anyone?

  • @chandi said:
    Hello everyone,

    When I copy a midi segment of a track, and paste it on the same track, that segment does not sound ... the instrument is microsonic ...

    Anyone?

    Had same issue with copied audio events on the same track. Resolved after deleting not sounding events and pasting them again

  • 4 more ...

    • The piano roll is extremely small every time you open it.
    • Midi over Bluetooth it keeps the connection but stops sounds on some occasions.
    • Every time I freeze a tack, the first 2 or 4 bars don't are recorded.
    • There are no layers either in midi, or in audio, and the grid is not visible below the tracks, this makes it almost impossible to align them when you are cutting and pasting pieces, and hidden events may remain under a piece of track, if you do not glue the All track.

    Thanks

  • @chandi said:
    Hello everyone,

    When I copy a midi segment of a track, and paste it on the same track, that segment does not sound ... the instrument is microsonic ...

    Anyone?

    Hi @chandi,

    Thank you for your report, the issue is already included in our known issues article:
    https://helpcenter.steinberg.de/hc/en-us/articles/206220404-Cubasis-for-iOS-Known-Issues

    CBT-1275 In some cases, pasted events are not played back.
    Please restart Cubasis or move the particular events once. Issue planned to be addressed in a future maintenance update.

    CBT-1246 In some cases, pasted events remain silent.
    Please check if the master channel is set to mute. Issue planned to be addressed in a future maintenance update.

    Best,
    Lars

  • @marmakin said:
    I apologize if this would be seen as off topic, but a key development item for me is getting the Cubase importer done for the new Cubasis 3. Ideally, I’m hoping that Cubasis 3 will allow smoother passing of projects both ways back and forth with Cubase 10 in general. (And +1 on the Apple Pencil).

    THANK YOU to you @LFS and your team. You have the patience of a saint haha 😂. Long time Cubase/Cubasis ecosystem customer here and very excited with the release of Cubasis 3!!

    Hi @marmakin,

    Thank you for your message.

    The Cubasis 3 Importer is already in the making, and we hope being able to release it sometime soon.
    The Cubasis Project 3 will allow to import Cubasis 3 projects into Cubase.

    THANK YOU to you @LFS and your team. You have the patience of a saint haha 😂. Long time Cubase/Cubasis ecosystem customer here and very excited with the release of Cubasis 3!!

    Thanks for the nice comment!

    Best,
    Lars

  • @chandi said:
    4 more ...

    • The piano roll is extremely small every time you open it.
    • Midi over Bluetooth it keeps the connection but stops sounds on some occasions.
    • Every time I freeze a tack, the first 2 or 4 bars don't are recorded.
    • There are no layers either in midi, or in audio, and the grid is not visible below the tracks, this makes it almost impossible to align them when you are cutting and pasting pieces, and hidden events may remain under a piece of track, if you do not glue the All track.

    Thanks

    Hi @chandi,

    If posible, please break your reports down in single posts, and add the steps to reproduce the issue.
    Thank you very much for your support.

    Best,
    Lars

  • @clowm said:
    @LFS, thank you for your hard work! Here’s a little bug:

    Summary/Title
    Wrong note being highlighted while changing note’s velocity/position using the buttons on the left

    Description
    Select a note, then add another note to selection and remove it so there is only the first note in the selection. Press velocity button and swipe over the selected note.
    Expected Results

    Actual Results

    Environment
    iPhone X, Cubasis 3.0.0.42

    Also it would be nice to be able to hide bottom velocity row to expand piano roll a bit on small screens.

    Hi @clowm,

    Thank you, your issue has been entered to our bugbase.

    CBT-1296
    Wrong note being highlighted while changing note’s velocity/position

    Best,
    Lars

  • @Crabman said:
    Hi @LFS ,about #3

    When C3 is set to loop play (with couple of AUs but it's enough to use just one i.e, pure acid with a kickdrum on the first beat it's best noticeable).When the loop starts again it creates a"doublekick" on the very first beat and the timing goes slightly off for the first 1-3 beats of the first bar,after that it runs fine again.I try to provide an audio example later.

    sorry,i can describe it better in german (i know you understand this Lars ;) ) :Cubasis"stolpert" am Anfang eines neuen Loopdurchgangs ein bischen.

    About the Steinberg Forum: i know it exists but for most iOS musicians (and me) this forum is still the number one source and Lars is very active here as well.I really think it doesn't hurt to run a thread like this as long as it srays free from all off topic stuff!!!

    Hi Crabman,

    Thanks for the additional information, issue has been entered to our bug base.

    CBT-1297
    Cycle playback creates double kick when reaching first bar again

    Best,
    Lars

  • @nick said:
    some midi auv3s are not recording any midi to the timeline and/or not sending midi to instruments
    I tested 10 so far with these results:

    — midi auv3 that don‘t work in Cubasis 3
    Aphelian
    Ochtachron
    KB1
    Velocity Keyboard

    — midi auv3 that work in Cubasis 3
    StepPolyArp
    Fugue Machine
    Xequence
    Atom
    GeoShred
    Rozeta

    Hi Nick,

    Thank you!

    Did see your report in anther AB forum topic, correct?
    Information has already been added to an existing bug report reported on the AB forum:

    CBT-1288
    Cubasis not accepting Midi Out from Audio unit instruments

    Thanks again,
    Lars

  • edited December 2019

    I think it would be a good idea to put this

    Reporting Form

    Summary/Title
    (Provide a short but descriptive sentence that summaries the issue or feature request)
    Description
    (Provide a detailed description and list the step by step process to reproduce the issue to help the team to understand and reproduce the problem)
    Expected Results
    (Describe what you expected to see)
    Actual Results
    (Describe what you actually saw)
    Environment
    (Count the hardware and software including version numbers being used)

    In the original post it, would help @LFS out a lot with organising stuff if we all report bugs in the same format, then it doesn’t matter as much which channel it comes from.. :)

  • edited December 2019

    Cubasis are having their break, is this an opportunity to get bugs in the au’s filtered out, no doubt some bugs will be with inconsistencies in the AU implementations..

    Not so sure on effort for IAA, it’s going, what’s the point, better to press those IAA only Apps to go AU, IF the studio environment is what you’re after.

    I’m sure @LFS will provide any support needed to devs

    There are plenty of people here who are beta testers for other apps and au’s, any who can help with reproducing issues and giving fruitful feedback I’m sure would be appreciated by our usually respectful community.
    .

  • edited December 2019

    @LFS

    Hi Lars,things are a little more complicated than i first thought.i recorded some audio examples as well,link is at the end,i want to explain first ;)

    1.The"doublekick"in the beginning of a loop happened so far only with pure acid (audio file attached).But i tried pure acid with Auria and AUM without a problem..

    2.The drunken shaolin is back :(

    Whe i opened my test project this morning the timing from digistyx and Rozeta+Ruismaker was all over the place like back in the old days.Then i figured out it has to do with latency setting!
    I changed the latency to highest (11,,6ms) and the timing went south.Switched back to the lowest and its good.But thats not a solution for long..2,6 ms latecy is nice but i`m sure it will kill the battery quite fast

    ONE expection: pure acid was running without timing issues bo matter what latency setting,lol.Okay,one issue...the double kick.

    So,this time i decided to think positive instead of going mad about the bad timing.Deep down in this app IS a stable clock so i hope it`s easier fixable this time ;))

    Here are the audio examples:

    https://www.dropbox.com/s/hvuhrtvdnegcznl/C3 Tests.zip?dl=0

    One more thing:The bug with Rozeta XoX not loading::it happened twice now that it DID load after i started cubasis but most of the time it does not.

    cheers

  • Just checking with other users before I make a formal report - Anyone else unable to import wav files from AudioShare? I keep getting an error message no matter how short or long the sample.

  • edited December 2019

    I’m getting an insane amount of instability in general, I have a ton of video of it Lars if you’d like to view it. I used it for a few mins, seemed normal until I actually tried to do anything, prematurely left good review. I have absolutely none of these issues in Cubasis 2.
    Very frequent hangs/crashes
    Audio inputs don’t work half the time
    Group channels in mixer cause tracks in group to not show sound levels in mixer
    Apple Pencil doesn’t work
    External inputs from audiofuse interface don’t seem to work at all. Outputs all work through audiofuse fine.
    Also, I don’t request refunds like ever, but when I have to there was no prob, but I can’t get a refund at all, my reason of “this app is totally unusable" is apparently not justification for a refund. This app is way too much money to not work, let alone not be able to get a refund.
    I understand that app launches can be problematic. I also understand iOS has been plagued since iOS 12 w audio problems, some of which still exist in 13 to some extent. This is what I’ve dealt with since I bought this 3rd gen pro. And I’m not just placing all the blame on app devs, I know apple has done their part in not caring about a lot of these issues, while many devs are unable to really do anything about apples os issues, and they are the ones that lose money when people get mad and stop buying audio apps/plugins.
    But it’s kind of different when the app like doesn’t work enough to do anything at all... I spent quite a few hours trying workarounds and such but still couldn’t even begin to record anything. Everything seems fine until you try to input signals, with or without an external interface.
    Back to just using good ol reliable AUM routed to Ableton live. If possible I really would like a refund, I’d be happy to pay again in the future when this is usable and has midi learn for the mixer and transport and such.
    Edit: I’ll say that the time stretch algorithms seem to work great, on a positive note lol.

  • edited December 2019

    Summary/Title

    Undo history remains unpopulated after using the app for a few minutes

    Description

    I encountered this error after opening up a very simple test project that I’ve been using to learn Cubasis 3. The project consists of one MIDI track hosting the AUv3 of MV08 and one instance of Rozeta XOX sequencing MV08 on the same track. I edited some track automation of one of MV08’s pitch parameters, recorded Rozeta to the MIDI track, edited the track automation further (nice that it will overlay on top of the MIDI clip!) and decided to check the Undo history, but it was blank.

    Expected Results

    I expected to see at least some of my recent actions Undo history.

    Actual Results

    The Undo history list is blank/empty.

    Environment

    iPad Pro 12.9 (3rd gen); iOS 13.3

    Update: I closed then reopened the project and the Undo history list was populated

  • Summary/Title

    Deleting track caused DSP spike, glitched sound, then loss of audio/silence

    Description

    I encountered this error after deleting a track I had duplicated. The project had two tracks: (1) MV08 hosted on a MIDI track with a switched off Roseta XOX; a MIDI clip; and (2) a MIDI track hosting Tardigrain with a MIDI clip. I duplicated the MV08 track to try running it through another instance of Tardigrain as an effect, didn’t like the sound, and deleted the duplicated track. Upon deleting the track playback stopped, I heard a distorted/glitched sound, and the audio cut out. I started playback and got no sound. I attempted to play tardigrain with the Cubasis 3 keys and heard no sound. I noticed that the DSP readout under System Info in the Inspector flashed the message “silent” a few times and bounced between 0 and 100.

    Expected Results

    I expected to see the track deleted while playback continued.

    Actual Results

    Playback stopped and the app no longer produced audio. Even after several minutes the audio was still unresponsive.

    Restarting brought the audio back in the affected project.

    Environment

    iPad Pro 12.9 (3rd gen); iOS 13.3

  • @papertiger said:
    Summary/Title

    Undo history remains unpopulated after using the app for a few minutes

    Description

    I encountered this error after opening up a very simple test project that I’ve been using to learn Cubasis 3. The project consists of one MIDI track hosting the AUv3 of MV08 and one instance of Rozeta XOX sequencing MV08 on the same track. I edited some track automation of one of MV08’s pitch parameters, recorded Rozeta to the MIDI track, edited the track automation further (nice that it will overlay on top of the MIDI clip!) and decided to check the Undo history, but it was blank.

    Expected Results

    I expected to see at least some of my recent actions Undo history.

    Actual Results

    The Undo history list is blank/empty.

    Environment

    iPad Pro 12.9 (3rd gen); iOS 13.3

    Update: I closed then reopened the project and the Undo history list was populated

    Hi @papertiger,

    Thank you for your bug report, which has been added to the list:

    CBT-1298
    Empty or incomplete undo History List

    Best,
    Lars

  • @papertiger said:
    Summary/Title

    Deleting track caused DSP spike, glitched sound, then loss of audio/silence

    Description

    I encountered this error after deleting a track I had duplicated. The project had two tracks: (1) MV08 hosted on a MIDI track with a switched off Roseta XOX; a MIDI clip; and (2) a MIDI track hosting Tardigrain with a MIDI clip. I duplicated the MV08 track to try running it through another instance of Tardigrain as an effect, didn’t like the sound, and deleted the duplicated track. Upon deleting the track playback stopped, I heard a distorted/glitched sound, and the audio cut out. I started playback and got no sound. I attempted to play tardigrain with the Cubasis 3 keys and heard no sound. I noticed that the DSP readout under System Info in the Inspector flashed the message “silent” a few times and bounced between 0 and 100.

    Expected Results

    I expected to see the track deleted while playback continued.

    Actual Results

    Playback stopped and the app no longer produced audio. Even after several minutes the audio was still unresponsive.

    Restarting brought the audio back in the affected project.

    Environment

    iPad Pro 12.9 (3rd gen); iOS 13.3

    Hi @papertiger,

    Thank you for your report, which has been entered into our bugbase:

    CBT-1299
    Deleting track caused DSP spike, glitched sound, then loss of audio/silence

    Thanks
    Lars

Sign In or Register to comment.