Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Ios garageband export to files broken?

Hi everyone, can please someone check if exporting a wav from a garageband project to files is broken? The resulting file in the files app is greyed out. Nothing can play it back. Interestingly if I email it to myself and then import it into Files app then it works! This is under iOS 13.2. Thank you.

«1

Comments

  • Actually under ios 13.2.2

  • Updating now, will let you know! Was still on 13.1.3 I think


  • Thank you. This is what i get.

  • Seems ok - I’m updated to 13.2.2 - I exported two .wav files and one .aiff, all three play. How did you get files to show extensions?

  • I don’t know! LOL. I think i am doing something wrong because it worked a few weeks ago. Before updating. I just go to GarageBand and while looking at my garage band projects press share and do the usual process and this is what I get. what could be wrong? Tried restarting iPad tried force restarting etc.

  • Again the weird thing is if I email it to myself instead of saving it on the iPad then it works! Later from the email I can save it to the Files app.

  • Could it be a bug on the 2018 ipad only?

  • Are you inside GarageBand and looking at the file? Cause I think that’s grayed out

  • Yeah in Files it’s cool. The files browser in GB will not play audio files

  • No. I am definitely looking at the files app. I just tried again. Actually quit garageband. Opened only files app. That is where the screenshot is from. Appreciate you trying to help.


  • Look at this. I just exported to my email address. From there I imported into the Files app. Look at the two different files.

  • Very weird! Yeah I dunno... I’m on 2018 iPad I guess it might just be a certain hardware model?? Wouldn’t be the first time

  • Thank you for your time. IF i reinstall garageband, will i lose my projects? Just copy them to icloud to be safe and then re install garageband?

  • Yeah as long as they are in iCloud you good to go, I’ve deleted and reinstalled GB... so... many times lol..

  • Deleted and re installed garageband. Same thing😕

  • wimwim
    edited November 10

    Maybe try removing and reinstalling the files app? I’ve done this a few times and haven’t lost files, but accept no responsibility if it does cause file loss. :#

    And, you’ve shut down and restarted your device already, I assume? ‘Cause that’s always the first thing to try...

  • Yes restarted many times many ways. Didn’t know i can delete the files app. I will backup the ipad and all my files to my mac tomorrow and try to re install the files app. Thank you.

  • Can confirm also deleting and reinstalling files app is ok, you won’t lose anything. A lot of times when it caches too much stuff locally I’ll do this (because Apples way of deciding what I need cached locally and not is baffling, at best)

  • I’ve been having terrible problems with Files app in iOS 13.2. And it’s just as bad in the 13.3 beta.

  • Deleted Files app. Downloaded again. Same problem😕

  • Files app is the most buggiest app on Ipados now. Can’t drag a pdf in split view from files to mail, filling out pdfs natively in files app with apple pencil brings up the markup tool automatically and does not let me scroll with one finger, need two fingers but leaving marks sometime. Terrible palm rejection. Emailing pdfs with markups, people only see an empty page with only markups! Now exporting from garageband results in unplayable files for me. Problems going on and on....very sad.

  • @mistercharlie said:
    I’ve been having terrible problems with Files app in iOS 13.2. And it’s just as bad in the 13.3 beta.

    What sort of problems?

    Have you reported them to Apple?

  • @Jimmy said:
    Deleted Files app. Downloaded again. Same problem😕

    Can you share any screenshots of the settings you use when exporting those files?

  • I also tried one last thing in the settings app: reset all settings. Didn’t help.

  • wimwim
    edited November 10

    I don’t see anything wrong there. Have you by chance recently installed any media player apps? Or any apps that might have messed with the audio file associations?

    Have you tried exporting a wav file from any other app to see if they have the same issue?

  • Well the only thing that is wrong, is that the resulting file is unplayable. It shows the file extension and I guess it shouldn’t. I installed some AUV3 effects. Could that be the problem?


  • These are the only music related apps I have on the iPad.

  • I don’t see anything there that would explain this. Maybe Music Memos? Try uninstalling that temporarily?

  • I can try. That is a native app from Apple installed on all iPads.

Sign In or Register to comment.