Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

iPadOS: Share Sheet does not work anymore!

I already noticed that something was strange with the "Share Sheet" and now i tried to have look into this:

There are those Apps that are in that vertical list, some of them system features, some shortcuts links and some regular Apps.
And there is the horizontal stripe of App.

I already dont understand the difference between those two groups of Apps.

But also, i dont understand what determines where an App appears.
Any insights from a developer, maybe?

Anyway, the main point here is, that this Share Sheet simply does not work anymore!

It simply does not show all of my App!

And i cannot find a way to fix that.

For example, i tried to share a WAV file from AudioShare to Hokusai.
Not possible!

I can find Twisted Wave, but not Hokusai!

I even tried to open Hokusai first, but it still does not appear on the Share Sheet.

This make iPadOS (and most probably iOS 13 too) nearly useless for me.

Anybody else has this?
Any fix?
Did someone already mention this to Apple?

Again, Apple frustrates me to no end.
I am short of giving up.

Comments

  • edited October 6

    I have the same issue, of not being able to find Hokusai to, um, share to, directly from AudioShare as used to be the case. (Had it with a few other apps too which also seem to have vanished from the horizontal Share To strip). The workaround I have found for the moment is to open a new Hokusai project from the desktop (tablet top?) then select import inside Hokusai. You can then path to the AudioShare folder ‘On My IPad’ from the Hokusai end, and import your wavs that way. A bit of a PITA which I hope gets fixed, but not terminal, at least. Doing this on a 2018 IPad Air running the most recent IPad OS update.

  • Piggybacking on this. @j_liljedahl is it going to be possible to see Audioshare in the share sheet in ipadOS?

    Also, the ability to copy from one app’s folder to Audioshare’s folder in the Files app? I’m trying to copy different .Wav files from different app’s folders to Audioshare’s folder in the Files app and I get a circle with a cross through it showing it’s prohibited.

  • It feels like AudioShare's file provider could use some love and care?!

    When I try to copy a video from the camera roll (ie. Share -> Files) and select AudioShare as the destination in Files.app only a fraction of the file gets copied to AudioShare while copying to other destinations (DropBox, GoogleDrive, Documents 5, BM3 etc.) works without a hitch and the whole files is copied...

    The Idea here is to extract the audio from ScreenRecordings using AudioShare but for now I have to use other apps for that.

  • That’s a weird one Samu. I think I’ve tried that with a screen recording before and it was working on 12... Using a clunky shortcut in the shortcut app for that now. Definitely, needs some tweaks to that file provider. Hope it’s something not too difficult to fix because as many steps forward as iPados is, this part is a big step back for my workflow anyway.

  • edited October 9

    This has definitely been an issue for me this week.

    A common workflow of mine is using share / airdrop to Audioshare.

    Updated the phone to iOS 13, and now not having Audioshare listed in that share sheet makes everything so much more time consuming.

    Any quick workarounds people have found?

    Has Jonatan commented on this at all yet?

    Looks like AirDropping between devices is also playing up because phone is on 13/ iPad on 12. So a solution of using Files app isn't working for me.

  • edited October 10

    SAVE TO FILES, then choose AudioShare.

  • That would be my solution as well. Thing is, Files shows up on mine, but just disappears on select and nothing is sent to it . It’s the only app that doesn’t get info passed to it.

Sign In or Register to comment.