Audiobus: Your virtual music studio.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Audiobus tap tempo via midi. How?

I'm trying to control tempo in audiobus using a korg nanokontrol but I'm failing.

I've managed to assign nudgge up and down but not tap. This has always eluded me with gear.

Has anyone managed this?

Comments

  • I think the issue might be note-off handling.

    I have a QuNexus that sends out a note on (0x8n) with velocity 0 as the note off event. If I try to use this, I get a "Hold C2 Not compatible with this action"

    With a nanoPad that sends an actual note off message (0x9n), Audiobus tap tempo works.

    If you're using a button that sends CC, it needs to be a momentary button, not toggle.

  • @aplourde said:
    I think the issue might be note-off handling.

    I have a QuNexus that sends out a note on (0x8n) with velocity 0 as the note off event. If I try to use this, I get a "Hold C2 Not compatible with this action"

    With a nanoPad that sends an actual note off message (0x9n), Audiobus tap tempo works.

    If you're using a button that sends CC, it needs to be a momentary button, not toggle.

    Thanks. I've tried cc momentary but while I'm hearing some tempo jitters it doesn't work as expected. Especially, the value in audiobus transport doesn't change. I'm going to do some tests later tonight.

  • Just out of curiosity, do you have Link on?

  • @lukesleepwalker said:
    Just out of curiosity, do you have Link on?

    Nope

  • @supadom said:

    @aplourde said:
    I think the issue might be note-off handling.

    I have a QuNexus that sends out a note on (0x8n) with velocity 0 as the note off event. If I try to use this, I get a "Hold C2 Not compatible with this action"

    With a nanoPad that sends an actual note off message (0x9n), Audiobus tap tempo works.

    If you're using a button that sends CC, it needs to be a momentary button, not toggle.

    Thanks. I've tried cc momentary but while I'm hearing some tempo jitters it doesn't work as expected. Especially, the value in audiobus transport doesn't change. I'm going to do some tests later tonight.

    Hmmmm, well you know, it seems to work great when the transport isn't running, but when the transport is running, it's very un-responsive. Sometimes it will change after a couple of taps, sometimes I'll keep tapping the control for 20 seconds and nothing happens.....

    Of course, if you're not seeing any change, even when the transport is stopped, there would seem to be something else going on.

  • @aplourde said:

    @supadom said:

    @aplourde said:
    I think the issue might be note-off handling.

    I have a QuNexus that sends out a note on (0x8n) with velocity 0 as the note off event. If I try to use this, I get a "Hold C2 Not compatible with this action"

    With a nanoPad that sends an actual note off message (0x9n), Audiobus tap tempo works.

    If you're using a button that sends CC, it needs to be a momentary button, not toggle.

    Thanks. I've tried cc momentary but while I'm hearing some tempo jitters it doesn't work as expected. Especially, the value in audiobus transport doesn't change. I'm going to do some tests later tonight.

    Hmmmm, well you know, it seems to work great when the transport isn't running, but when the transport is running, it's very un-responsive. Sometimes it will change after a couple of taps, sometimes I'll keep tapping the control for 20 seconds and nothing happens.....

    Of course, if you're not seeing any change, even when the transport is stopped, there would seem to be something else going on.

    I haven't tried it while it was stopped but I just did and yes, you're right. I guess that's already something since I'd usually use tap tempo before I press the start button. Cheers

  • edited August 24

    Oh, yep, you've found a bug @supadom/@aplourde! I'll fix it now.

Sign In or Register to comment.