Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Nanostudio 2 Problems -- Anybody else?

I have had nothing but problems with NS2.

Every time I try and use it I run in to major problems with it locking up.

Apparently Audio Damage Grind is a known problem AU, and some of my projects that caused lock ups and crashes had Grind instances.

Anyway, I deleted NS2 after not being able to get to the bottom of an issue that resulted in projects unable to archive, save, export, mix down, etc

I thought I'd give it another go as I was using AUM and had a little vibe going and I thought I'd try and recreate it in NS2 so that I could expand on the arrangement in a linear format.

So, I have a fresh new install of NS2. I did not restore any of my old projects which I have backed up in an iCloud Drive folder.

So I started a new project.

I added one instance of Lorentz and another of Kronecker (loving the ice works synths!) For Audio FX I had one instance of Dubstation on the Lorentz track and one instance of QuatroMod on the Kronecker track. I had an aux track with one instance of EOS.

I added another track with Kronecker and added a Rozeta Collider to trigger it.

I have an 8 bar loop of the two tracks. Nothing more.

I created a mix down and it went incredibly slowly (0.1x!). It eventually finished and I went to check the exported stems within NS2 via settings->manage files. NS2 locked up loading the file viewer thingy whilst creating peaks (or whatever the exact text was).

So I had to restart my iPad as NS2 crashed.

I tried to export the stems again, and NS2 has completely and utterly locked up during mix down, getting to 0.0x speed and then crashing. FFS.

I restarted the iPad after NS2 crashed and tried to record the screen. NS2 locked up again, then crashed again and got a warning that the screen recording failed to save.

EVERY SINGLE PROJECT I make causes these issues. iPad Air 2, iOS 12.2. I don't have weird issues in any other audio apps. I use AUM, Auria Pro, Blocs, GarageBand and a ton of other apps.

I've reported issues at length and apparently it's just me that has these issues that make NS2 unusable.

Anybody else have lockups and crashes when saving, archiving, mixing down, etc.?

Unfortunately I can only surmise that my specific system is allergic to NS2. But only NS2.

Please don't reply to tell me NS2 works for you. I'm sure it does. I'm only trying to ascertain whether anybody else is having similar issues. If not, I will just assume it's only me, delete NS2 and move on. If anybody else is having issues then perhaps we can help get the bugs fixed.

«13

Comments

  • tjatja
    edited July 28

    Maybe post your project, so we can download the setup and try?

    Also, what version of iOS are you on?

  • And maybe try first with only the Synths, but not the effects?

    One of them may produce the problems

  • And lastly, did you post the same in the NS2 bug forum?

  • I’ve been down the route of trying to diagnose specific projects before and got nowhere (other than having the Grind issue confirmed).

    I thought I’d try NS2 once more with a fresh install and no old projects. And even avoiding Grind I ran into the same issues straight away.

    I just wanted to know if it’s just me having these problems.

    If the issue is with audio damage plug ins then somebody else would surely also have issues. If it’s just me I’ll shut up and move on.

  • edited July 28

    @tja said:
    And lastly, did you post the same in the NS2 bug forum?

    Actually you started thread about those problems at NS forums :)))

    https://www.blipinteractive.co.uk/community/index.php?p=/discussion/736/unclean-handling-of-au-with-resulting-project-problems

    I spend significant amount of time trying to reproduce those issues - unsuccessfully :( It would be cool to found more users with similar catastrophic issues, maybe it would help to found some pattern within it.

    So far, i got some crash logs from @klownshed , i sent them to Matt, but for no no pattern emerged from them.

    Only thing which i was able to reproduce were problems with some Audio Damage plugins in NS2, especially with GRIND (and sometimes with Replicant and Dubstation2 - but this is very rare). Definitely GRIND looks that hates NS2 most :))

    I created a mix down and it went incredibly slowly (0.1x!).

    This exact issue had also @drez, also in his case it was related to Grind, after he saved preset, removed Grind from project, reloaded it back again and loaded same preset - problem was fixed.

    I'm almost sure it's related to plugins (if it can be fixed on NS side, on plugin side, or both ? No idea ..) , problem is that even after @klownshed send me his problematic project, there were no problems on my iPad Mini 5 or iPad Air1 - everything was working fine.

    So definitely more users with same experience can bring some light to those weird events ...

  • Have you considered upgrading to iOS 13? There's really no reason I can think of to still be running iOS 12.2, iOS 13 will actually make your Air 2 run more smoothly, and also fixes a lot of bugs. You never know, it might even fix this issue.

  • @dendy said:

    I'm almost sure it's related to plugins, problem is that even after @klownshed end me his problematic project, there were no problems on my iPad Mini 5 or iPad Air1 - everything was working fine.

    So definitely more users with same experience can bring some light to those weird events ...

    Exactly why I started this thread. If it’s a problem with plug ins somebody else would surely experience similar issues.

    I had some problem projects from before but this time started completely fresh with a new Ns2 install and started a new project without Grind and still managed to run into project ending issues.

    The project I created was fine for a while but eventually crashed when I tried to mixdown.

    I had been using other audio apps for while before opening the NS2 project so that could be a factor?

    So maybe try this.

    Make a project in NS2 with at least three audio damage plug in instances. Maybe create another track with an audio damage plug in and mute it. Save the project.

    Work in it for a while and confirm saving, saving as, mixdown etc work.

    Then quit ns2 and Work in say AUM for a while. Maybe leave it for a few days.

    Quit AUM and go back to the NS2 project without restarting the iPad.

    Try and mixdown. See what happens.

    One thing is for sure. Once ive had one file related issue with a project then it will continue being a pain in the arse from then on.

  • edited July 28

    iOS 13 isn’t officially out yet is it? Not sure I would recommend beta software to fix an issue. You could update to 12.4.

  • @richardyot said:
    Have you considered upgrading to iOS 13? There's really no reason I can think of to still be running iOS 12.2, iOS 13 will actually make your Air 2 run more smoothly, and also fixes a lot of bugs. You never know, it might even fix this issue.

    I use my iPad for work too and there are many reasons not to install a beta os. Especially ios13 which has lots of iCloud issues reported by developers that can result in data loss.

  • I've had zero issues with iOS12.4 and from what I've heard AudioDamage is also in a process of updating all their plug-ins with latest versions various frameworks.(Juce, AudioBus, etc. etc.)

  • Oh yes - sorry, I got confused between iOS 12 and 13 😳

    For what it's worth I use AD Replicant in most of my NS2 projects without issue.

  • Indeed, update to iOS12.4 but not 13 beta. Some devs don’t support beta, can’t blame them.

  • edited July 28

    @klownshed said:
    I have had nothing but problems with NS2.

    Every time I try and use it I run in to major problems with it locking up.

    Apparently Audio Damage Grind is a known problem AU, and some of my projects that caused lock ups and crashes had Grind instances.

    Anyway, I deleted NS2 after not being able to get to the bottom of an issue that resulted in projects unable to archive, save, export, mix down, etc

    I thought I'd give it another go as I was using AUM and had a little vibe going and I thought I'd try and recreate it in NS2 so that I could expand on the arrangement in a linear format.

    So, I have a fresh new install of NS2. I did not restore any of my old projects which I have backed up in an iCloud Drive folder.

    So I started a new project.

    I added one instance of Lorentz and another of Kronecker (loving the ice works synths!) For Audio FX I had one instance of Dubstation on the Lorentz track and one instance of QuatroMod on the Kronecker track. I had an aux track with one instance of EOS.

    I added another track with Kronecker and added a Rozeta Collider to trigger it.

    I have an 8 bar loop of the two tracks. Nothing more.

    I created a mix down and it went incredibly slowly (0.1x!). It eventually finished and I went to check the exported stems within NS2 via settings->manage files. NS2 locked up loading the file viewer thingy whilst creating peaks (or whatever the exact text was).

    So I had to restart my iPad as NS2 crashed.

    I tried to export the stems again, and NS2 has completely and utterly locked up during mix down, getting to 0.0x speed and then crashing. FFS.

    I restarted the iPad after NS2 crashed and tried to record the screen. NS2 locked up again, then crashed again and got a warning that the screen recording failed to save.

    EVERY SINGLE PROJECT I make causes these issues. iPad Air 2, iOS 12.2. I don't have weird issues in any other audio apps. I use AUM, Auria Pro, Blocs, GarageBand and a ton of other apps.

    I've reported issues at length and apparently it's just me that has these issues that make NS2 unusable.

    Anybody else have lockups and crashes when saving, archiving, mixing down, etc.?

    Unfortunately I can only surmise that my specific system is allergic to NS2. But only NS2.

    Please don't reply to tell me NS2 works for you. I'm sure it does. I'm only trying to ascertain whether anybody else is having similar issues. If not, I will just assume it's only me, delete NS2 and move on. If anybody else is having issues then perhaps we can help get the bugs fixed.

    >

    I did have problems with mixdowns on my 2017 ipad. Many projects would slow down to 0.0x just like you describe. 90% of these issues were resolved by setting my buffer size to ‘very low’ before mixdown...

  • edited July 28

    I have been really limiting external instruments and effects because ALL the iOS DAWs I own start crashing/glitching at some point when IAAs and AUv3s enter the mix. It’s not straight-forward, either, because an AU that works great in Auria Pro blows up in BM3, or an effect that is SO groovy in AB3 looses all audio in AUM after ten seconds, or an IAA that works beautifully in Cubasis locks Garageband up if I even think about loading it. (Okay, that part isn’t true... I do have to actually load the offending instrument or effect to have an issue)

  • It does sound like plugin compatibility. It is slow going but I would try no plugins, test, add one, test, add second, etc. You may find the culprit. Especially as you are using Audio Damage plugins and they had issues reported in BM3.

  • I’ve had a few crashes occasionally but I was pushing my Air 1 to the limits any time it happened and I’m sure anything I used would have crashed at that point

  • My issue is that once the project crashes the iPad (shortly after it hit 0.0x rendering speed as per the screenshot above, the iPad hard crashed and rebooted itself) I’m stuck with a project that is effectively corrupt.

    I can’t save it, save as, archive or mixdown without Ns2 locking up even if I remove all the plugins.

  • @dendy said:

    @tja said:
    And lastly, did you post the same in the NS2 bug forum?

    Actually you started thread about those problems at NS forums :)))

    https://www.blipinteractive.co.uk/community/index.php?p=/discussion/736/unclean-handling-of-au-with-resulting-project-problems

    No.

    That was a similar problem, and mostly around saving and reloading projects and them getting damaged and not reloadable.

    This one is a new posting and while having similar problems, they are described very different and resolve around mixing down audio. Also there are lots of more information and a list of concrete AU plugins.

    So, this may be related but seems something different to me.

    Anyway, we still did not get such a project from @klownshed

  • @richardyot said:
    Have you considered upgrading to iOS 13? There's really no reason I can think of to still be running iOS 12.2, iOS 13 will actually make your Air 2 run more smoothly, and also fixes a lot of bugs. You never know, it might even fix this issue.

    I would not recommend to anyone update to iOS 13. Many iOS releases (and MacOS releases) have audio issues that come and go and don't get addressed till the end.

    I'd be cautious about being an early adopter.

  • edited July 28

    @klownshed said:
    My issue is that once the project crashes the iPad (shortly after it hit 0.0x rendering speed as per the screenshot above, the iPad hard crashed and rebooted itself) I’m stuck with a project that is effectively corrupt.

    I can’t save it, save as, archive or mixdown without Ns2 locking up even if I remove all the plugins.

    Yah I had a lot of corrupt projects when using Aparillo for a bit but then an update seemed to resolve it.

  • edited July 28

    @AudioGus said:

    @klownshed said:
    My issue is that once the project crashes the iPad (shortly after it hit 0.0x rendering speed as per the screenshot above, the iPad hard crashed and rebooted itself) I’m stuck with a project that is effectively corrupt.

    I can’t save it, save as, archive or mixdown without Ns2 locking up even if I remove all the plugins.

    Yah I had a lot of corrupt projects when using Aparillo for a bit but then an update seemed to resolve it.

    Interesting. When you were having issues when using aparillo in your projects were you having trouble opening/saving/exporting the projects?

  • edited July 28

    @Samu said:
    I've had zero issues with iOS12.4 and from what I've heard AudioDamage is also in a process of updating all their plug-ins with latest versions various frameworks.(Juce, AudioBus, etc. etc.)

    That isn't was he told me four days ago, he is currently having serious issues with the latest MacOS and trying to diagnose that.

    Audio damage plugins have been nothing but pain here in any DAW I use them in, I just use them for sound design and resample out now, great sounding, unstable as anything.

  • @espiegel123 said:

    @richardyot said:
    Have you considered upgrading to iOS 13? There's really no reason I can think of to still be running iOS 12.2, iOS 13 will actually make your Air 2 run more smoothly, and also fixes a lot of bugs. You never know, it might even fix this issue.

    I would not recommend to anyone update to iOS 13. Many iOS releases (and MacOS releases) have audio issues that come and go and don't get addressed till the end.

    I'd be cautious about being an early adopter.

    IPadOS has definitely made Beatmaker a bit more stable with AUs for one, but a couple of old apps just wont run, so it is six of one and half dozen of the other right now.

  • I tried to see if I could reproduce the problem on my IPad Air 2 , using the same au’s you’ve listed, Lorentz, 2 instances of Kronecker with Rozeta Collider driving one, and the 3 audio Damage plugins you listed, and didn’t have any issues, the only thing different is that I’m running 12.3.1 I don’t know if my settings are different from your as I haven’t changed any of them. Also my audio interface is an Apogee Duet. Since we’re both on Air 2’s maybe it’s the IOS you’re on? Idk.

  • @Strizbiz said:
    I tried to see if I could reproduce the problem on my IPad Air 2 , using the same au’s you’ve listed, Lorentz, 2 instances of Kronecker with Rozeta Collider driving one, and the 3 audio Damage plugins you listed, and didn’t have any issues, the only thing different is that I’m running 12.3.1 I don’t know if my settings are different from your as I haven’t changed any of them. Also my audio interface is an Apogee Duet. Since we’re both on Air 2’s maybe it’s the IOS you’re on? Idk.

    ![](https://forum.audiob.us/uploads/editor/7b/

    I don’t think it’s anything to do with iOS version as I’ve had these issues for months across a few iOS updates.

    I had no issues with this new project for a few days. It suddenly caused issues when I tried to do a mixdown.

    IIRC I had been using AUM for a while prior to the mixdown crash and hadn’t restarted the iPad.

    The project was auto loaded when I stated NS2

    Now I can’t even audition the mixdowns from within NS2 as it locks up while loading the file editor.

    If it is a problem due to Audio Damage plugins, which is possible, it’s the manner in which they cause NS2 to fail which is my main issue. A simple crash is easy to deal with. I am ending up with an app that can’t open, save or export its own projects.

  • @klownshed said:

    @AudioGus said:

    @klownshed said:
    My issue is that once the project crashes the iPad (shortly after it hit 0.0x rendering speed as per the screenshot above, the iPad hard crashed and rebooted itself) I’m stuck with a project that is effectively corrupt.

    I can’t save it, save as, archive or mixdown without Ns2 locking up even if I remove all the plugins.

    Yah I had a lot of corrupt projects when using Aparillo for a bit but then an update seemed to resolve it.

    Interesting. When you were having issues when using aparillo in your projects were you having trouble opening/saving/exporting the projects?

    Yes, very much so. Then Aparillo got an update and poof, problems vanished.

  • @klownshed said:

    @Strizbiz said:
    I tried to see if I could reproduce the problem on my IPad Air 2 , using the same au’s you’ve listed, Lorentz, 2 instances of Kronecker with Rozeta Collider driving one, and the 3 audio Damage plugins you listed, and didn’t have any issues, the only thing different is that I’m running 12.3.1 I don’t know if my settings are different from your as I haven’t changed any of them. Also my audio interface is an Apogee Duet. Since we’re both on Air 2’s maybe it’s the IOS you’re on? Idk.

    ![](https://forum.audiob.us/uploads/editor/7b/

    I don’t think it’s anything to do with iOS version as I’ve had these issues for months across a few iOS updates.

    I had no issues with this new project for a few days. It suddenly caused issues when I tried to do a mixdown.

    IIRC I had been using AUM for a while prior to the mixdown crash and hadn’t restarted the iPad.

    The project was auto loaded when I stated NS2

    Now I can’t even audition the mixdowns from within NS2 as it locks up while loading the file editor.

    If it is a problem due to Audio Damage plugins, which is possible, it’s the manner in which they cause NS2 to fail which is my main issue. A simple crash is easy to deal with. I am ending up with an app that can’t open, save or export its own projects.

    But you are very resistant to upload the project somewhere, so people could just try.

    I don't have all those Audio Damage Apps and effects anyway, only a small bunch of them.

  • @AudioGus said:

    @klownshed said:

    @AudioGus said:

    @klownshed said:
    My issue is that once the project crashes the iPad (shortly after it hit 0.0x rendering speed as per the screenshot above, the iPad hard crashed and rebooted itself) I’m stuck with a project that is effectively corrupt.

    I can’t save it, save as, archive or mixdown without Ns2 locking up even if I remove all the plugins.

    Yah I had a lot of corrupt projects when using Aparillo for a bit but then an update seemed to resolve it.

    Interesting. When you were having issues when using aparillo in your projects were you having trouble opening/saving/exporting the projects?

    Yes, very much so. Then Aparillo got an update and poof, problems vanished.

    When you say the problems vanished, does this include the 'corrupt' projects? Did they start working again?

    The next thing on my list when I have some time was to delete the audio damage plug-ins and try the projects without them installed, then if they worked fine without the plug-ins, re-install them and test again.

    Hopefully we can find a plug-in that makes these particular issues happen regularly and consistently so that it can be tested by the devs so that they can make sure NS2 doesn't fall over so badly when the plug-in misbehaves.

  • @klownshed said:

    @AudioGus said:

    @klownshed said:

    @AudioGus said:

    @klownshed said:
    My issue is that once the project crashes the iPad (shortly after it hit 0.0x rendering speed as per the screenshot above, the iPad hard crashed and rebooted itself) I’m stuck with a project that is effectively corrupt.

    I can’t save it, save as, archive or mixdown without Ns2 locking up even if I remove all the plugins.

    Yah I had a lot of corrupt projects when using Aparillo for a bit but then an update seemed to resolve it.

    Interesting. When you were having issues when using aparillo in your projects were you having trouble opening/saving/exporting the projects?

    Yes, very much so. Then Aparillo got an update and poof, problems vanished.

    When you say the problems vanished, does this include the 'corrupt' projects? Did they start working >again?

    I don’t recall exactly how things resolved but there were cases where I was surprised loading old projects and in they were fine again. Never any guarantees of course.

    The next thing on my list when I have some time was to delete the audio damage plug-ins and try the projects without them installed, then if they worked fine without the plug-ins, re-install them and test again.

    Hopefully we can find a plug-in that makes these particular issues happen regularly and consistently so that it can be tested by the devs so that they can make sure NS2 doesn't fall over so badly when the plug-in misbehaves.

    The problem with these problems is that they are rare and hard to corner. In the case of Aparillo it was the Aparillo update that fixed my issue.

  • edited August 1

    @dendy said

    I spend significant amount of time trying to reproduce those issues - unsuccessfully :(

    I can reproduce them even when I’m trying hard not to :(

    So one more try to get to the bottom of the issue; I deleted all my Audio Damage plug-ins and reloaded NanoStudio 2.

    Everything worked fine. Saving was snappy, auditioning audio files in the mixdown folder worked as it should.

    I then quit NanoStudio and reinstalled the AD plugins.

    Relaunched NanoStudio 2 and the project played back fine, everything sounded good, no crackles etc, low cpu usage. Did a ‘save as’ and NS2 locked up again.

    There is definitely an issue with AD plug ins or a specific combination of plug ins in NanoStudio 2.

    But the big problem with the AD + NS2 combination is that the incompatibility manifests itself in NS2 being unable to do any file related functions such as saving, exporting or mixing down. There are no problems actually playing the project as you are creating it.

    If I open the project with the AD plugins installed and loaded in the project itself, even doing things unrelated to the project itself cause lockups that result in hard iPad crashes. For example, if I go into settings-> Manage audio files and double tap an audio file in the mixdown folder, NS2 hangs with the ‘preparing audio file editor’ message, or during the building peaks message. Under normal usage those messages shouldn't even appear as the waveform should instantly open.

    TLDR

    With AD plug-ins in the project; NS2 can't do any file related functions.
    DELETE AD Plug-ins and it all works fine.

    Conclusion; Whether or not AD plug-ins are actually to blame, NS2 falls over badly when things go wrong in a way that no other host does.

Sign In or Register to comment.