Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

whoa! out NOW! Sugar Bytes Factory - Modular Synthesizer for iOS

189101214

Comments

  • edited June 28

    @Daveypoo said:

    @kinkujin said:
    OK, did the big download. Played through about 15 presets and pressed 'BUY' button. Holy crap what an inspiring instrument. I was holding off because I didn't want to buy anything back when it came out, in fact, didn't want to buy today but ... when an instrument gets you that hyped up that quick, it becomes a must-have. Sugar Bytes, my my ...

    Yep - Factory is incredible, and much more universally useful in a variety of genres than the other SB synths. It's a beautiful thing, really.

    Definitely! Factory is their masterpiece, imho. A sonic toy that is fun and great sounding as well as being constantly surprising. This thing could not only be used to score a Scifi movie, but could do all the SFX too (with a little help from a sampler and granular synth). But each of the others is brilliant too. And if SB wants to come out with another masterpiece, I’m alllll ears!👂 (And glad you are digging it, @kinkujin ).

  • Factory crashes intermittently for me in Aum.
    One instance , nothing else running..ipad 2018.
    Particularly when setting up and operating a Program change list for changing patches via midi (bluetooth).
    Unfortunately this makes it unusable in a live situation.
    There is also a problem with some patches loading with huge volume swells upon becoming selected. Also highly problematic in a live sense.

    Anyone else having issues with Patch behaviour ?

  • @Jes said:
    Factory crashes intermittently for me in Aum.
    One instance , nothing else running..ipad 2018.
    Particularly when setting up and operating a Program change list for changing patches via midi (bluetooth).
    Unfortunately this makes it unusable in a live situation.
    There is also a problem with some patches loading with huge volume swells upon becoming selected. Also highly problematic in a live sense.

    Anyone else having issues with Patch behaviour ?

    Yes I find the patch system to be the worst part of factory. It's laggy and unpredictable.

    There is quite a few AU that seem to crash in AUM due to some graphics issue

    Factory
    Turnado
    Enso
    PPG Infinite
    FAC Envolver

    Being the main offenders I know of.

  • Pants of Death has a look at Factory:

  • Anyone else have this bug in iPadOS13 (not iOS 12)? I've messaged Sugar Bytes, but they aren't able to reproduce it.

    1. Load Sugar Bytes Factory in any AU host. Load one of the following presets: After Destruction, Akoustik Plucked, Analog Strings...(any preset which uses the Transformer, Wavetable, or Waveguide oscillator algorithm).
    2. Save the session in your AU host.
    3. Close AU host.
    4. Open AU host & load the saved session. Play Factory. For me, the sound is either very quiet or sounds nothing like what the recalled preset should sound like.

    The problem seems to be specifically the Transformer, Wavetables, & Waveguide oscillator algorithms. In Transformer, the sample isn't loaded. In Wavetables & Waveguide, the wavetable seems to reset to a different one, even though the text-label shows that the correct one is selected.

    The other oscillator algorithms don't seem to be affected.

    Again, this one occurs in iPadOS, not iOS 12.

    2018 iPad 6, iPadOS 13.1.3. iPad internal audio/headphones, 44.1kHz. No external peripherals.
    Factory deleted & reinstalled already. Latest version V1.0.4. Thank you.

  • @StudioES said:
    Anyone else have this bug in iPadOS13 (not iOS 12)? I've messaged Sugar Bytes, but they aren't able to reproduce it.

    1. Load Sugar Bytes Factory in any AU host. Load one of the following presets: After Destruction, Akoustik Plucked, Analog Strings...(any preset which uses the Transformer, Wavetable, or Waveguide oscillator algorithm).
    2. Save the session in your AU host.
    3. Close AU host.
    4. Open AU host & load the saved session. Play Factory. For me, the sound is either very quiet or sounds nothing like what the recalled preset should sound like.

    The problem seems to be specifically the Transformer, Wavetables, & Waveguide oscillator algorithms. In Transformer, the sample isn't loaded. In Wavetables & Waveguide, the wavetable seems to reset to a different one, even though the text-label shows that the correct one is selected.

    The other oscillator algorithms don't seem to be affected.

    Again, this one occurs in iPadOS, not iOS 12.

    2018 iPad 6, iPadOS 13.1.3. iPad internal audio/headphones, 44.1kHz. No external peripherals.
    Factory deleted & reinstalled already. Latest version V1.0.4. Thank you.

    This might be related to a bug I’ve experienced and seen reported elsewhere, that sometimes Factory does not output audio unless you switch to a different preset. I tried your steps but got no sound instead of a strange sound.

  • Tested - also no sound instead of strange sound.
    Sound re-appears after switching the preset and then switching back.

  • Tested - different sounds after re-loading the save AUM sesseion. But when saving as AUM preset, these recall correctly.

    As a conclusion, the problem depends on the 'timing': In case of AUMs session load, the Factory AU might not be fully initialized when loading the preset data. When loading an AUM preset, the Factory AU is already loaded.

    • I also tested both variants in apeMatrix: The presets were recalled correctly on session reload and on preset load.

    • Repeating the test in Auria Pro resulted in no-sound on project reload and 'working' when loading Auria Pro presets.

    • In Cubasis, reloading a project containing one of three Factory presets result in 'no sound' from Factory AU. I didn't find out how to save AU presets in Cubasis

    • In Garageband, reloading such a project results in 'no sound'

    .

    @StudioES If you are already in contact with SugarBytes, can you add this new information to your bug-report, or should i open up another one with the same topic ?

  • edited October 30

    Thank you @craftycurate @MrBlaschke @_ki - I appreciate your help.

    @_ki I sent Sugar Bytes this thread, and they replied stating that they tested once again, this time under iPadOS, and they confirmed that the samples aren't loading properly under iPadOS, and that it affects their other apps too. They are working on a fix.

    Here are several AB3, AUM, aM, & BM3 sessions with specific Factory presets that don't work for me until I change the Factory preset, osc algo, or sample, wavetable, etc. (Note all use the problematic osc algos which use either samples, wavetables, or a waveguide.) Dropbox link

    Once again - thanks for the team effort.

  • I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

  • @Jes said:
    I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

    I'm still on iOS 11 something and running in AUM3. Program changes switching AU presets works fine, though I had three presets in the program change list which overrode the AU presets, so I just saved the AU presets to the PC list. But I can't see how to disable Factory's PC list. Anyone?

  • @ElectroHead said:

    @Jes said:
    I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

    I'm still on iOS 11 something and running in AUM3. Program changes switching AU presets works fine, though I had three presets in the program change list which overrode the AU presets, so I just saved the AU presets to the PC list. But I can't see how to disable Factory's PC list. Anyone?

    Not sure I’ve understood what you’re asking but if you're referring to the Program List panel, it can be toggled by clicking here ...

  • @craftycurate thanks! But from what I experienced this just hides the list, not disable it from receiving PCs, which override AU AUM3 presets

  • @ElectroHead said:
    @craftycurate thanks! But from what I experienced this just hides the list, not disable it from receiving PCs, which override AU AUM3 presets

    I did wonder if you were referring to remote control tbh!

  • @StudioES said:
    Thank you @craftycurate @MrBlaschke @_ki - I appreciate your help.

    @_ki I sent Sugar Bytes this thread, and they replied stating that they tested once again, this time under iPadOS, and they confirmed that the samples aren't loading properly under iPadOS, and that it affects their other apps too. They are working on a fix.

    Meanwhile, there is a workaround: Just load your project (while the current loaded Factory session is still open!) again.
    Then it should load the correct sample files/presets.

  • Glad to hear Sugar bytes is on the case.
    Can’t sing Factory praises enough!
    If you enjoy shaping sound, it will take you to places others can’t.
    The wavetable, formants, morphing and routing possibilities are just outstanding.
    A mild learning curve but well worth the results👌🏼
    Super thankful its on IOS!

  • Is it possible to share presets from Factory? If so, what's the process?

  • @richardyot said:
    Is it possible to share presets from Factory? If so, what's the process?

    Dont know for sure but since they are saved and stored in the files app... you probably can just send the files !?!

  • @Petah said:

    @StudioES said:
    Thank you @craftycurate @MrBlaschke @_ki - I appreciate your help.

    @_ki I sent Sugar Bytes this thread, and they replied stating that they tested once again, this time under iPadOS, and they confirmed that the samples aren't loading properly under iPadOS, and that it affects their other apps too. They are working on a fix.

    Meanwhile, there is a workaround: Just load your project (while the current loaded Factory session is still open!) again.
    Then it should load the correct sample files/presets.

    Thanks, but that doesn't work, even after today's 1.0.5 update. I sent your team another concise video. Cheers!

  • @Jes said:
    I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

    Well the update has kinda dealt with the crashing issue when sending program change messages...
    However it only works when All presets are used to populate the list using the double folder icon. This kinda defeats the purpose altogether.
    Custom program lists just dont work at all and the program crashes on the first selection.
    This is very frustrating...

  • Maybe they should just revamp and simplify that whole file system
    (Personally I find it a cluster fuck)

  • @Jes said:

    @Jes said:
    I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

    Well the update has kinda dealt with the crashing issue when sending program change messages...
    However it only works when All presets are used to populate the list using the double folder icon. This kinda defeats the purpose altogether.
    Custom program lists just dont work at all and the program crashes on the first selection.
    This is very frustrating...

    If you haven't, report the issue to Sugarbytes.

  • @espiegel123 said:

    @Jes said:

    @Jes said:
    I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

    Well the update has kinda dealt with the crashing issue when sending program change messages...
    However it only works when All presets are used to populate the list using the double folder icon. This kinda defeats the purpose altogether.
    Custom program lists just dont work at all and the program crashes on the first selection.
    This is very frustrating...

    If you haven't, report the issue to Sugarbytes.

  • @Jes said:

    @espiegel123 said:

    @Jes said:

    @Jes said:
    I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

    Well the update has kinda dealt with the crashing issue when sending program change messages...
    However it only works when All presets are used to populate the list using the double folder icon. This kinda defeats the purpose altogether.
    Custom program lists just dont work at all and the program crashes on the first selection.
    This is very frustrating...

    If you haven't, report the issue to Sugarbytes.

    Yep Ive reported it to them.
    This update addresses the issue I raised, however it has not solved it.
    It is now not possible to setup a custom list of presets and then send program change messages via midi without instant crashing.
    Has anyone else tried this?
    Its a pretty basic requirement from a synth.
    So, yes, I could report it again..but I tend to agree with @hibjshop that the whole file system needs revamping and is, indeed, a ‘ clusterfuck’.

  • @Jes said:

    @Jes said:

    @espiegel123 said:

    @Jes said:

    @Jes said:
    I have found that Factory crashes completely for me when choosing presets from the Program List on the right hand side ( the one that midi program change works with).
    The first 17 change properly and then..bang..it crashes.
    Ive had Sugar Bytes confirm that it is a bug but am still awaiting an update that fixes it.
    Its been a long time since I reported it and Factory is unusable in its current state ; which is a pity as its one of my favourite sounding synths.

    Well the update has kinda dealt with the crashing issue when sending program change messages...
    However it only works when All presets are used to populate the list using the double folder icon. This kinda defeats the purpose altogether.
    Custom program lists just dont work at all and the program crashes on the first selection.
    This is very frustrating...

    If you haven't, report the issue to Sugarbytes.

    Yep Ive reported it to them.
    This update addresses the issue I raised, however it has not solved it.
    It is now not possible to setup a custom list of presets and then send program change messages via midi without instant crashing.
    Has anyone else tried this?
    Its a pretty basic requirement from a synth.
    So, yes, I could report it again..but I tend to agree with @hibjshop that the whole file system needs revamping and is, indeed, a ‘ clusterfuck’.

    You should most certainly report the part that still isn't working with a precise recipe for reproducing it -- otherwise they won't know about it.

  • The preset 'A Story Forgotten' (and any derivatives of it) do not seem to load up when I load a BM3 session. When I go into Factory it does then seem to wake up.

  • Yup, any preset which uses a sample (Transformer), wavetable, or waveguide doesn’t load properly when reloading a saved session in any AU host. Sugar Bytes responded stating that they weren’t able to reproduce the bug any longer on 13.2. I’m on 13.2 & 1.0.5 & it happens every time. Oh well, after almost a dozen emails with concise steps to reproduce the issue plus 2 videos, I’ve given up on them. 🥱

  • not sure if a known bug...when accessing settings - midi - bluetooth , app crashes

  • @Sergiu said:
    not sure if a known bug...when accessing settings - midi - bluetooth , app crashes

    Same here, crash.

    Ipad pro 12.9'' 2017, iPadOS 13.2

  • Gotta love this forum.
    Never really paid attention when Factory came out and didn’t follow this thread. Last night I caught up, reading the last 8 pages and becoming increasingly convinced I NEED THIS APP.
    Until the final two pages, which are all about how it’s now a broken crashfest!

Sign In or Register to comment.