Bootstrap plugin

Looks like we have the bootstrap plugin installed but our theme doesn't support it so it doesn't work. We should either remove the plugin (or just the toolbar button) or find a theme that supports bootstrap.

Best I can tell from the user side is it's this plugin https://www.dokuwiki.org/plugin:bootswrapper. Same fella makes a bootstrap compatible template. https://www.dokuwiki.org/template:bootstrap3

I'm on the fence about including it. Could certainly help with some formatting but maybe it's just adding another layer of complexity?

Comments

  • @syrupcore said:
    Looks like we have the bootstrap plugin installed but our theme doesn't support it so it doesn't work. We should either remove the plugin (or just the toolbar button) or find a theme that supports bootstrap.

    Best I can tell from the user side is it's this plugin https://www.dokuwiki.org/plugin:bootswrapper. Same fella makes a bootstrap compatible template. https://www.dokuwiki.org/template:bootstrap3

    I'm on the fence about including it. Could certainly help with some formatting but maybe it's just adding another layer of complexity?

    What is the bootstrap plugin, btw?

  • @espiegel123 it's triggered with this button on the edit toolbar:

    Best I can tell from messing with and reading the plugin page, it inserts special wiki markup to create the components from v3 of the Bootstrap library. https://getbootstrap.com/docs/3.3/components/

    Currently, it will insert that markup but it doesn't work (and it seems some of the 'special' markup gets munged anyway).

    The bootstrap3 template would do two things: 1) make the site's base typographic styles (etc) look like that link and 2) enable the components from the bootstrap plugin.

Sign In or Register to comment.