SpaceCraft controlled via GEOSHRED

Hi guys,

Here's a video of SpaceCraft being controlled via GEOSHRED...

If you want to try this make sure you have the latest SC update v1.1.1 :)

Comments

  • edited March 29

    Is that out yet? I’ve only got 178 presets in my GeoShred - can not select the #184.

  • @MrBlaschke said:
    Is that out yet? I’ve only got 178 presets in my GeoShred - can not select the #184.

    Geoshred was updated a several days ago. I tried it as an AU first and didn't see - but after opening the standalone app, then they appeared in the AU. Maybe that's the issue??

  • edited March 29

    @MrBlaschke said:
    Is that out yet? I’ve only got 178 presets in my GeoShred - can not select the #184.

    I had the same thing loading straight into AUM - but if you launch Geoshred in standalone mode first, it does some updating and the new presets then appear when you launch it in AUM.

  • @Halftone said:

    @MrBlaschke said:
    Is that out yet? I’ve only got 178 presets in my GeoShred - can not select the #184.

    Geoshred was updated a several days ago. I tried it as an AU first and didn't see - but after opening the standalone app, then they appeared in the AU. Maybe that's the issue??

    Ah there you go - beat me to it!

  • @MrBlaschke said:
    Is that out yet? I’ve only got 178 presets in my GeoShred - can not select the #184.

    You will need to:

    1. launch the standalone version of GeoShred
    2. Close GeoShred stand-alone
    3. Launch AUM
    4. Load GeoShred and SpaceCraft
    5. Use preset 184 in GeoShred
    6. Use preset GeoShred preset in SpaceCraft
    7. Load or record the samples you want to use in SpaceCraft
    8. Save as a new preset if you want.
    9. Play SpaceCraft from GeoShred
  • Funny, I'm not getting the additional controls at the top that he's using in the vid - just the standard Geoshred controls....missing something somewhere...

  • Bingo. Thanks all. Starting it as Standalone was the problem.

  • Great stuff! 👍
    I had a lot of fun playing SC with GeoShred the last 30 Minutes... 😊

  • Mine still shows 178 presets, even after the update.

  • @Zjenji said:
    Mine still shows 178 presets, even after the update.

    I've got the presets, but not the controls at the top.

  • @MonzoPro said:

    @Zjenji said:
    Mine still shows 178 presets, even after the update.

    I've got the presets, but not the controls at the top.

    Have you rebooted (power cycled) your iPad? I've seen problems like this after an update with Digital D1 where new presets only showed up after I power-cycled.

  • Yeah, rebooted and still showing 178. Weird.

  • edited March 29

    @MonzoPro said:

    @Zjenji said:
    Mine still shows 178 presets, even after the update.

    I've got the presets, but not the controls at the top.

    Try clicking the “arrow” thing on the right side - i think you have the minimized UI selected (all sliders). @MonzoPro

  • edited March 29

    Tried some singing sample - mangled it through SpaceCraft using GeoShred.
    Just experimental and educational - Audio is from screen capture...

  • @MrBlaschke said:

    @MonzoPro said:

    @Zjenji said:
    Mine still shows 178 presets, even after the update.

    I've got the presets, but not the controls at the top.

    Try clicking the “arrow” thing on the right side - i think you have the minimized UI selected (all sliders).

    Deleted and reinstalled the app and that did the trick.

  • I’ll have to try a reinstall - rebooted, reloaded etc. and I still don’t get the extra MIDI controls.

    Frustrating.

  • edited March 30

    This is doing my flipping head in. I’ve rebooted, reinstalled, reloaded, and watched that video 50 times but I can not control Spacecraft with Geoshred, apart from playing the notes.

  • edited March 30

    Right, finally working. Spacecraft was the culprit, even though I had the latest version I had to reinstall to get it to work with GS.

  • @MonzoPro sorry you had issues with this, I thought you were having an issue with GS rather than SC. I wonder if you had the legacy cc mapping selected in advanced settings. GS compatibility requires the new 'default' mapping. Sorry, I should've made that clear.

  • I assume when loading the geoshred au you use the midi processor not the instrument, I haven't tried it yet but maybe that is proper ?

  • @deltaVaudio said:
    @MonzoPro sorry you had issues with this, I thought you were having an issue with GS rather than SC. I wonder if you had the legacy cc mapping selected in advanced settings. GS compatibility requires the new 'default' mapping. Sorry, I should've made that clear.

    Yeah no worries, got there in the end. I thought it was the GS update, and reinstalled that but even though the preset appeared in SC the controls didn’t seem to pick it up. Reinstalling SC fixed it.

  • Excellent association, much fun!

  • Yeah now I've got this working it's amazing, even better with 2x instances and some drums.

  • @MonzoPro, are you able to see all 184 presets from the update? We are not sure why this happened. We'd love to talk with you directly ([email protected]) so that we can figure out this issue and address it in our next incremental release. Thanks, -Pat Scandalis CEO/CTO moForte inc.

  • Geoshred rocks!!!

  • @moForte said:
    @MonzoPro, are you able to see all 184 presets from the update? We are not sure why this happened. We'd love to talk with you directly ([email protected]) so that we can figure out this issue and address it in our next incremental release. Thanks, -Pat Scandalis CEO/CTO moForte inc.

    Yeah I could, it seems the issue was with Spacecraft - even though it was up to date, I had to delete and reinstall it before it picked all the MIDI controls up.

    All fixed now, thanks for asking though, Geoshred is a great app.

  • Sorry if this was addressed in a previous thread (searched the forum, no luck)...

    CC assignments in Spacecraft: i’ve Assigned the GS CC-107 in AUM to the LFO. Works as expected for the LFO, but 107 is also controlling SC reverb. No errant cc assignment in AUM. No apparent cc assignment in SC to disable.

    I’d appreciate any assistance on this—if you can parse all the acronyms...LOL.

    [the SC preset is loaded in GS 🙂]

    Thanks.

  • Hi @zilld2017
    CC 107 in SC is one of the reserved CCs used by seaboard. See this table for info on the reserved mappings
    https://www.deltavaudio.com/about. try using an unreserved CC :)

Sign In or Register to comment.