48 & 96k not working with Auria using AUM & Audiobus

Hi, new here...

Saw some threads that kinda went into this but it didn't feel like any answers were difinitive.

Running Audiobus 3 with AUM and Auria Pro on a new 2018 iPad Pro. Having issues with anything that isn't 44k as long as Audiobus is in the mix.

I can't get Audiobus 3 to connect to Auria at anything other than 44k without issues. I'm trying to link AUM to route from my interface (SPL Crimson 3) to Auria for recording (1, 2, 3 & 4), then control the outputs of the Crimson for sending out two custom audio streams (2 & 3 in to 1 & 2 out, and 1, 2, 3 & 4 out to 3 & 4).

Everything works in 44k just fine. But when i switch AUM and Auria to anything else (same in both obviously), it doesn't work. If i try to launch Audiobus first, then Auria—Auria won't load anything but a 44k project (and throws up a warning). If i load both AUM and Auria first (both set to 96k), then it works independently, but as soon as i link them, i get what sounds like a bunch of jitter/distortion of the signal into Auria (still sounds fine going into and out of AUM).

So something in the bridge (Audiobus) is not letting the signal properly stay at 48 or 96.

It's not a huge deal for the recording into Auria, as i can just run AUM for routing and mute the playback in Auria when recording, at any sample rate. But if i did want to record IIA into Auria via Audiobus, it would appear i can only do that at 44k?

I've read a bunch of threads and the information is all over the place, so i'm starting a new one to ask specifically and hopefully get a totally straight and clear answer (lol). I've even hear people say to launch the apps in the order you want to first set the sample rate, then do Audiobus to link, or one of the Admins here say always start with Audiobus... So no clear answers yet other than that it won't work regardless of the order as long as Audiobus is in the center.

I think i even saw someone say to run Audiobus 2, but i don't get how that would help if it doesn't support the higher sample rates anyway.

Any help would be great. Just knowing what the options and limitations actually are would at least make it clear what i can't do.

Thanks!

Glen Allan

Comments

  • tjatja
    edited February 23

    Not sure how your setup looks like.

    Could you post your AudioBus preset with everything loaded?

  • Good call @tja

    The assumption is that it’s related to AudioBus, but it’s also possible that it’s an app that is causing the issue. There are a number of apps that have a problem with reporting their sample rate properly to hosts. Of course it could be AudioBus related, but best to check that there aren’t other complicating factors.

    Also, does this still happen if the audio interface isn’t connected at all?

  • > @wim

    > There are a number of apps that have a problem with reporting their sample rate properly to hosts.

    To be exact, many AU plugins ignore sample rate set by host and are locked to device hw sample rate.. other do not like switching sample rate "on the run".. there is wjole range of problems with sample rate (and buffer size) handling in AU plugins... From what i know almost all VirSyn plugins, Sunrizer, ApeSoft iVSC3, AudioDamage Dubstation (maybe also other AD plugs ??) and many more...


    Not sure if what @GlenAllan described is the case, but there is chance that it is.


    more here:

    and here more technical explanation:


  • I believe this is better with IAA Apps πŸ˜€

  • I don't have enough information to say for sure what is causing the problem, but i do know that both AUM and Auria work fine at any sample rate while running at the same time (with the same sample rate, a warning does come up if the sample rates are different). It's only when Audiobus is used to link them that the problem comes up. And as described, Auria won't stick to a higher sample rate when launched from Audiobus. I think i pretty thoroughly described all of the scenarios i tried in the main post.

    I still have to get the gear all put back together after the show i did on Saturday (which is also why i haven't responded, the shows take a lot out of me), but there are no special Audiobus presets. I don't seem to be able to find anything within Audiobus for setting sample rates (am i missing something?) and thought from other reading it was sample rate agnostic and just followed what the other apps were set to. All i'm doing is connecting AUM through IIA to two (stereo) channels linked through Audiobus to Auria. I didn't even realize there was a problem as it all worked till i realized it was all at 44k and wanted to change it.

    So, both AUM and Auria work perfectly as long as the sample rates are the same. For the kind of show i was doing i can just run it this way without the link. When i add Audiobus i get the problems described above. This leads me to believe there is no problem with either AUM or Auria (together or separately running), but the link between them, that being Audiobus. This will be an issue when i want to run audio from the interface through other apps then into Auria for recording.

    I know there are other ways of getting the audio into Auria, so it's not like i'm totally stuck. Just would be nice to know either what is screwing up in the apps, or what i'm not doing right. Again, i don't know, so i'm only using simple deduction to say it "seems" like it is because of Audiobus. But it is pretty clear it's a sample rate issue (in particular).

    None of things i mentioned are on that list, except that it is a 2018 iPad. I had actually run across another article describing potential problems with it. So maybe it is the problem. However, that the other two apps can run at whatever sample rate (with both set to the same) without being linked through Audiobus is confusing then.

    I don't really know. When i get my Crimson hooked back up after i sort out my equipment from the show i can see what it's looking like in the apps and do screen shots or whatever. Video if needed.

    Thanks!

  • edited February 25

    Not sure what matters in the details, but it does seem that only Auria is causing the noise to happen (well, i don't know about "cause", but it's where i hear it). Audio sounds good in AUM regardless of what it's set at. It's only when i play back through Auria (with AUM channels muted or not) that i get the pops and cracks (with Audiobus in the middle). That's if i set the rates first in both (which does work), then open up Audiobus to make the connections. If i open up Audiobus first (which i saw was the recommendation. Then Auria refuses to go into a higher sample rate.

    Not sure if that helps to know, but i figure every bit can help to understand.

  • @GlenAllan What about the AudioBus preset?

  • Yeah, i'll give a screen shot when it's set up again. There's not really much to describe though. Inputs 1 & 2 going to one IIA Audiobus channel from AUM, 3 & 4 going to the other, 2 stereo feeds in for recording in Auria. Takes like 4 seconds to set up. I don't see any extra prefs in audio bus to do more. I'll try to get it hooked up here in a few.

  • Okay, so AUM to AB Port 1, and to AB Port 2 — Interestingly, when i hook the AB channel in, AUM goes down to 44 and won't let me change it.

    Oh... Interesting. Tried going through AB settings again and deselected Inter-App Audio Sync (IIA) and it allows the higher sample rates without bitching. Seems IIA syncing is only at 44k, and it changes AUM's setting by default, and Auria doesn't like that. Apparently if i don't "sync" it all works as long as the rates are set properly in the other apps.

    I'm guessing this is a user error issue on my part since that was so simple. But what am i losing by having that option off? Sorry, been out of the iOS audio world for a couple of years as my old iPad that i bought used became obsolete rather quickly. Getting back into it now and trying to build all of my A/V & Graphics production on my new iPad Pro.

    Anyway, if someone can explain to me what this option is for and why it doesn't allow for higher sample rates i could lower my ignorance and not make big posts about something everybody already knows about :P

  • @GlenAllan It seems, we misunderstand.

    AudioBus allows to share a preset in form of an URL.

    Just save your preset with everything loaded in AudioBus.

    Then, you can hit the "Share" button and just copy the link and paste it here.

  • edited February 26

    Hope i'm not wrong, but i think Audiobus uses always default sample rate of device (which is 44 khz on older models, 48 khz if you are on build-in device speaker since iPhone 6S, and generally 48khz since iPad Pro 2018 model).


    This is probably question to @Michael - If you connect to AB other app which uses different sample rate than default device one (Auria in 96khz mode in this case), what happens ? Is there some resampling (down/up) on AB's input or output ?

  • edited February 26

    Yep, AB 1 used to be fixed, but for years now it uses the hardware sample rate. It'll be converted to/from whatever the source/destination app is using.

  • At this point it just seems that "Inter-App Audio Sync" is what locks the rate in. With it off everything works at whatever rate. I'm not entirely clear what this option is for. Can someone clarify that, or why it doesn't seem to like the higher rates and causes the conflict?

  • I try once more πŸ˜‰

    Could you please post your AudioBus preset?

    It's super simple and if it makes problems for you, I can provide screenshots.

  • Not sure how this helps, but here it is. Naming is generic, just made the connections and shared.

  • @GlenAllan Interesting setup.

    What is the App that AUM goes into?

    The App Store did not open as advertised, @Michael


    Glen, please try this:


    1) Load the AB session with everything else

    2) Go to the App Switcher and kill AudioBus

    3) Restart AudioBus

    4) Manually add your two AUM ports and the second App, do not load the session

    5) Open AUM and try to change the Sample Rate


    This worked for me, but would be something that @Michael may possible adress.

  • In this setup AUM is linking to Auria, as mentioned.

    I've done all of that. Actually, it requires i set the sample rate in AUM first or AUM goes down to 44 to match whatever AB is doing. But now that i have "Inter-App Audio Sync" turned off it all will work at any matched sample rate change. Then Auria doesn't bitch about the sample rate being wrong and open up a new project at 44.

    That's why i am asking what "Inter-App Audio Sync" does that locks it to 44k, and why both AUM and Auria can work fine without being linked by AB.

    I can do more testing later with gear hooked up, but deep in website dev at the moment. I'll check back when i'm back in audio mode.

  • I cannot tell what Inter-App Audio Sync does or changes, maybe @Michael can help.

    But what you wrote, with disabling it, did not help - I needed to kill AudioBus.

    But maybe this time also Auria Pro prevented the change, as I now loaded it as well.

  • I'm gonna investigate this myself over the next couple days, maybe I can figure something out. Stay tuned.

  • Well i wish i could say i repeated the steps exactly the same way every time. What i do know is that you have to be sure AUM is in 48 or 96k mode first, working with AB, then Auria will link. Actually, Auria seems to link fine at 44k no matter what else is happening, it just won't work in 44 or 96 unless AUM is also in them. Sounds like you are having problems as well though, so it's not just my machine.

    Cool. I'll check back 😁

  • @GlenAllan Curious - you are able to set in AUM other sample rate than you'r device's default one (which is in most cases 44 or 48 ? Because if i choose any other sample rate i get message.

    "Could not set sample rate - Either the hardware does not support the selected sample rate, or another application is currently controlling it"

  • I believe that he is using an audio interface. iOS devices aren't limited to 44K or 48K if their audio interface supports other sample rates. Are you getting those errors, Dendy when using an audio interface that supports the sample rate you are selecting?

  • edited February 27

    > I believe that he is using an audio interface. iOS devices aren't limited to 44K or 48K if their audio interface supports other sample rates. Are you getting those errors, Dendy when using an audio interface that supports the sample rate you are selecting?

    yeah, i understastand all this stuff about sample rates, i was just curious if he is able to set 96khz in AUM, i forget about possibility the he have 96khz interface, was thinking just about standalone ipad :)

  • @GlenAllan this sounds like an issue that has been addressed specifically by Apple, AUM and AudioBus ...and seems to be an iPad Pro glitch:


    "The problem occurs when the user runs more than a couple of music apps together. The way iPad music usually works is to have one main app that hosts other apps, in the form of plug-in Audio Units. Or, you pipe the audio and data from those apps into your main recording app, like GarageBand or AUM.

    This works great, and even really old iPads can handle the load. But the new iPad chokes. To see the extent of the problem, open up AUM, which is an amazing audio-routing and recording app for iOS. It has a CPU meter in one corner, letting you know how close you are to the limit. This is important on iOS because when you max out the CPU, the sound starts to glitch and crackle (and not in a good way).

    Load up a couple of synthesizer apps inside AUM, and maybe add a few effects, then take a look at the CPU meter. It’ll be up way higher than it would be on an older iPad. But you won’t need to look at that meter, because the audio is probably crackling and stuttering already.

    Why can’t the new 2018 iPad Pro handle a few music apps?

    It’s almost certainly a software problem. The developer of AUM contacted Apple about this problem, and — according to this report from AudioBus forum member Genshi — he received a reply from Apple:

    "I contacted Apple this morning shortly after replying to your email, they have confirmed an issue with this model of iPad and have told me to file an official bug report in order that I may be kept in the loop with what’s going on. It seems there is an issue in the audio system in iOS affecting this model."


    ...More in the article.


    A bit at the end of this article as well..


  • edited February 27

    @BitterGums

    As i know this problem was already solved in latest iOS version .. BUT there is other reason why 2018 iPad PRO models are totally not worth to use for music apps, as soon as you use any host and mostly AU plugins - because no matter what you do you use just single core. Not sure how it is with IAA apps, maybe at least those are able to use other cores ? No idea... For sure in scenario HOST app + AU plugins you always run just in one core.

    And single core performance between 2018 spring normal iPad model and 2018 Pro models isn't not that big (3500 vs. 4900 on geekbench) than price difference (and other disadvantages like no lightning connector, no jack connector)

  • Yeah, the interface I have goes up to 192k, but is limited to a max of 96k by iOS and core audio.

    I did read about issues with the new iPads, but as it seems the different software can work at the higher rates without the sync function mentioned I’m pretty sure at least in this case the problem is something else. I should do a record test at 96 to be sure it’s actually that high.

    I can jack my Moog in and record a bit and see. I don’t know what the best tool to double check it is though without paying a decent amount, so if anyone here knows I’d appreciate it. I know there are telltale signs when audio is downsampled, but I haven’t ever tested it.

    Still would be good to know why the apps seem to play well with each other with the sync option in AB turned off. But again, maybe it just “seems” that way. I need to test it.

  • @BitterGums : That article is out of date. The issue it focuses on was fixed in a recent OS update.

  • Well that's good. So it still leaves the question of "Inter-App Audio Sync" not allowing higher sample rates. I guess it should be tested on other setups to verify i'm not just doing something wrong. I have yet to do any audio syncing in this way, so at least for my recording purposes for shows, it doesn't really matter. But when i do want multiple apps running together at higher sample rates (supplying playback sound) i'd think this could be an issue.

  • @dendy i am able to set the rate to any supported by my interface in AUM.

Sign In or Register to comment.