iPad audio to Mac options

edited February 5 in Off-topic

I've got a huge collection of iOS apps that are largely unused, and I've started looking into incorporating them into my desktop workflow and I'm trying to figure out the best way to connect my iPads. So far I still haven't found a great solution.

First, I'm not looking to replace my audio interface, so the iConnectivity stuff isn't an option.

I started with the IDAM path, since it's the native option now, and it works reasonably well, with the minor inconvenience of having to change the DAW to use the iPad as the audio device, which prevents simultaneous multitracking without making an aggregate device. It's stereo only as well, which again limits multitracking.
Also for some reason I get slight MIDI latency from my desktop to the iPad, even though the audio is fine. It's relatively usable, but I wouldn't want to really play keys through it.

Studiomux seemed like a great option since it doesn't require changing the desktop audio interface and supports multiple inputs. However, it's completely unreliable, and I've only gotten it to work at all intermittently. When it does work, it's only supporting one app anyway. As soon as I add a second app the audio is full of crackles, regardless of the buffer size, using my 2018 iPad Pro on 12.1.3. But in my testing with it and trying to restart things, getting both audio and MIDI to connect seems to require arcane rituals and proper moon phases. It seems like maybe this app is dead with the introduction of IDAM.

At this point I"m getting close to giving up on trying this path, and just using an audio interface for the iPad and traditional MIDI connectivity to treat the iPad as a standalone module.

Also, as part of this, I noticed that I somehow have my iPad registered as a static 18/2 audio interface and I have not memory of this place. You can see it in this screencap. "The 13" is name of my 2018 12.9" iPad. I wasn't able to actually get this to do anything though.

Comments

  • Hey there, I was in the same boat as you awhile ago. Except I could not get IDAM to work consistently for me as you seem to have. Studimux was inconsistent as well so I looked elsewhere and I ended up settling on the iConnectMIDI2+

    https://www.iconnectivity.com/products/midi/iconnectmidi2plus/

    It lets you send MIDI and Audio between your iPad (or iPhone) and your computer. Similar to IDAM it is considered an audio device so you would need to make an aggregate device, however, in my experience that hasn't been an issue. I just had to set it up the one time and it's been working fine ever since. I haven't noticed any latency with the MIDI or audio and it just seems to work. I have a template in Logic saved with all of the routing configured so I can get audio and MIDI to and from my iPad with ease. It's a little pricey if you buy it new but I was able to snag a used one for $20 on ebay that has been working great. Anyway, hope this helps!

  • I don’t have any midi latency through IDAM....even with aggregate device.

    Maybe you could check your interface config

  • edited February 8

    @OnfraySin said:
    I don’t have any midi latency through IDAM....even with aggregate device.

    Maybe you could check your interface config

    There's no interface associated with the MIDI though, it's just the iPad via USB for the IDAM connection. Audio is near instant through my interface, sub 4ms RTL.

    @illaddin said:
    Hey there, I was in the same boat as you awhile ago. Except I could not get IDAM to work consistently for me as you seem to have. Studimux was inconsistent as well so I looked elsewhere and I ended up settling on the iConnectMIDI2+

    Thanks! I appreciate the input but that's exactly the route I don't want to take. :) I have an Apogee Ensemble Thunderbolt already.

    I just tested with my first gen 12.9" iPad Pro though and Studiomux (which is the ideal solution on paper) works as advertised. I'm thinking this guy might become my dedicated software synth external module for this use case, at least until Studiomux updates to work better on the new models (I confirmed that my 11" 2018 iPad Pro has the same exact issue: Studiomux works okay with one channel, but as soon as you add a second app the audio goes to hell.)

  • Chain replying, but I'm excited now. :smiley: This is working GREAT. I've got six apps on the "old" iPad, and even playing all of them in unison (Ableton sending the same MIDI keyboard to all Studiomux generators), I've got perfect audio and no perceivable latency. I did have to bump Studiomix's buffersize from 128 to 256 when I added Zeon as the sixth app.

    My quick, non-scientific test is with:
    1. Kaspar
    2. Kauldron
    3. Model D
    4. Phosphor 2
    5. Poison
    6. Zeon

    That's already more than I'll probably ever use this for. I just tried adding Quanta as a seventh app and I started getting audio crackling, which cleared up by increasing Studimux's buffersize to 512 and it still feels absolutely fine to play that way -- if I wanted a crazy multitimbral synth.

    Gonna be a fun weekend!

  • that mystery interface is the legacy interface provided by studiomux, they do not recommend it anymore

  • edited February 8

    I use both IDAM and Studiomux, but currently prefer the latter.

    What I’ve found is that results can vary depending on conditions. IDAM seems to develop latency when you switch apps, and from other causes. Some apps seem to work better than others, but I’ve been able to get almost all apps I’ve tried working pretty well. IAA is much better than AUv3. In fact, AUv3 basically would not work last time I tried.

    I never use more than one synth at a time, and try to keep sessions short and render to audio ASAP.

    I have also run into increased latency over time (worse with IDAM than Studiomux). I’m currently not sure if the cause is simply the passage of time or certain things that happen over the course of long sessions (sleep mode kicking in, switching apps, etc.). Takes a couple of hours for it to get really bad. Rebooting on the iPad fixes it.

    In used to use MusicIO, but that developed audio glitch issues back in 2016 and the developers (who had previously been super helpful), stopped replying to emails. It hasn’t been updated since, and I assume it’s basically abandonware at this point.

    In general, I’ve always been able to get tracks recorded when I needed, but it could be smoother. Still overall better than trying to work in the slab with an iOS DAW.

    BTW, I do not need to create an Aggregate Device with my setup (MOTU interface + DP). In DP I just go to the Configure Hardware Driver menu and Command-click to select multiple devices, including the iPad).

    The thing I don’t like about IDAM is I cannot disconnect the iPad unless I quit the DAW first (otherwise you get a missing hardware error). Don’t have this issue with Studiomux.

Sign In or Register to comment.