Midiflow Splitter - I’ve created two separated zones but I still hearing both synths together

Hi!

I’m using Juno Di keyboard as MIDI input. Then I’m using two synth Apps and splitting keyboard in two zones with MF Splitter. The problem is I still hearing both synths in both zones, there is not splitting nothing.

I attach screenshot of the setting. Please, tell me if I doing something wrong.

Thank you very much!

Axel

Comments

  • Are both synths on the same channel?

  • edited January 27

    Well, you’re doing everything right @Axeltaglia, but @ikmultimedia apps are MIDI promiscuous and both apps are not updated to the last Audiobus SDK (as you can find when you tap on the exclamation sign on the icon of both apps in Audiobus).
    As an example, iLectric hasn’t been updated in 3 years!

    The problem is that iLectric and Sampletank are listening to both Core MIDI and Audiobus MiDI, so although the split is working, both apps are also listening to your Juno keyboard directly.

    There’s a workaround you can use with the help of Midiflow Channels and setting up in iLectric a MIDI channel different from the one that your Juno keyboard is using, and setting up the live mode in Sampletank.
    So, as an example, if your Juno is transmitting in MIDI channel 1, you should set iLectric to listen to channel 5 (or any other channel different from channel 1) and Sampletank in live mode only listening to channel 5 too.
    This way, your keyboard will be invisible to both apps and the split will work as expected.
    As this may sound confusing, I’m attaching some screen captures so you can better visualize what I’m trying to explain.

    Please advice if you need more details.
    Hope this helps.

  • @Rodolfo
    Excellent job explaining this weirdness!
    B)

  • @CracklePot said:
    @Rodolfo
    Excellent job explaining this weirdness!
    B)

    Thank you @CracklePot.
    I started to answer thinking it was going to be a short answer, and halfway through I realized that I had gotten myself into a swamp ... 🤣

  • Thank you @Rodolfo!

    It works perfectly!

  • @Axeltaglia said:
    Thank you @Rodolfo!

    It works perfectly!

    Happy to help 😎

Sign In or Register to comment.