Galileo2 /Drawbars Are Wack!

Can someone explain to me why the Drawbars jump all over the place when playing a preset? Also, how do I set my own drawbar configuration. And what is that strange C-V control with the drawbar diagrams next to it? Or just tell me where the manual is! Thanks

(Seems like a pretty remarkable app)

Comments

  • edited January 16
  • With regard the drawbars...are they perhaps receiving MIDI CC's ?

  • edited January 16

    I don't have that issue - the drawbars work smoothly for me. I've also mapped them to my KORG nanoStudio2 and that works well also.

    As @AndyPlankton said, the C-V knob is the chorus & vibrato control. This was created by Laurens Hammond (the inventor of the Hammond organ) as a way to combat the development of the spinning speaker by Don Leslie. Hammond didn't like having a competing company making products for his organ, so he tried to create something to replace it.

    I did a video all about the history of the Hammond organ and some tips and tricks for playing it here (check out around 8:17 - that's where I talk about the chorus and vibrato):

    This was before Galileo 2 was released, but there are enough similarities between Galileo 1 & 2 that I think this'll be helpful if you haven't already watched it.

    Hope it helps!

  • edited January 16

    @LinearLineman said:
    Can someone explain to me why the Drawbars jump all over the place when playing a preset? Also, how do I set my own drawbar configuration. And what is that strange C-V control with the drawbar diagrams next to it? Or just tell me where the manual is! Thanks

    (Seems like a pretty remarkable app)

    You might be interested to see the MIDI events your Kawaii is sending. My Casio send CC's like crazy that make no sense to me when I change settings on it and even when I just play notes.

    Those CC's will tell Galileo to do things and it will OBEY.

    StreamByter AU could be placed in from of the Galileo as a MIDI FX and remove all CC's in the MIDI stream as a potential fix.

    You might find a way to turn off the CC's from the Kawaii but that assumes a lot of knowledge about MIDI and most of us don't know what to look for.

    You can see MIDI events with @ka010's excellent MIDISpy App which is "Gratis" which is an ancient coin approximately equal to $0. Apple eats it on all Gratis charging scheme so get it before Gratis goes up with Turkish inflation. I like to make Apple suffer so I get all the Gratis Apps I can.

  • @daveypoo, thanks for the video. Very good Doug imitation, I thought. I had a B3 back in the day, so I am familiar with the concept, but good job.

    I agree @AndyPlankton , @McDtracy , I believe Galileo is responding to the midi info from CB. Maybe there is a midi in I can turn off?

  • @LinearLineman said:
    @daveypoo, thanks for the video. Very good Doug imitation, I thought. I had a B3 back in the day, so I am familiar with the concept, but good job.

    I agree @AndyPlankton , @McDtracy , I believe Galileo is responding to the midi info from CB. Maybe there is a midi in I can turn off?

    Whats is controlling Galileo when you see the Bars move? A MIDI recording you made with the Kawaii? If yes, then I think you need to filter CC's when you make the recording into Cubasis. It's probably had to get them out later. You might have to go into the Piano Roll and pick out CC's. I could be wrong. I am several times a day but like a broken clock I could be "write".

  • @LinearLineman said:
    @daveypoo, thanks for the video. Very good Doug imitation, I thought. I had a B3 back in the day, so I am familiar with the concept, but good job.

    I agree @AndyPlankton , @McDtracy , I believe Galileo is responding to the midi info from CB. Maybe there is a midi in I can turn off?

    You strike me as the kinda cat who knows his way around the vintage keys, so I hope the video wasn't patronizing!

    :smiley:

  • yeAh, i noticed that as well, depending on the keys i was playing. when i used a external midi keyboard it would go crazy, but when i used the onscreen keyboard, it worked fine. I just figured the draw bar controllers on some of the presets had accidentally been midi mapped to note midi vs. cc weird > @LinearLineman said:

    Can someone explain to me why the Drawbars jump all over the place when playing a preset? Also, how do I set my own drawbar configuration. And what is that strange C-V control with the drawbar diagrams next to it? Or just tell me where the manual is! Thanks

    (Seems like a pretty remarkable app)

  • What Galileo Preset demonstrates the Drawbar "automation"? Just to save a bit of time and look at the MIDI Stream from my controller and see if it does this too.

    Galileo might have a setting to turn CC's off. Maybe MIDI Learn is on. MIDI is wonderful except when it's not.

  • @LinearLineman said:
    I had a B3 back in the day

    You had a B3 and a Steinway Grand and lived near NYC and now you're in Turkey. Tax problems or witness protection?

    Nevermind.

    "The Things We Do for Love" by (pun intended) 10CC.

  • @LinearLineman said:
    @daveypoo, thanks for the video. Very good Doug imitation, I thought. I had a B3 back in the day, so I am familiar with the concept, but good job.

    I agree @AndyPlankton , @McDtracy , I believe Galileo is responding to the midi info from CB. Maybe there is a midi in I can turn off?

    Look in the prefs menu, all sorts of midi settings in there.

  • @daveypoo, not patronizing at all. The imitation was worth it and the lesson a good refresh. That B3 was a lot of luggage. This is much better. @McDtracy it happens on all presets. I am sure it is reading the midi info on Cubasis. And, frankly, getting Galileo to play a midi track with a two handed range is pretty wack in itself. Midi makes me Lazi.
    @AndyPlankton , good idea. Will do, @eross sounds like we are on the same page.

  • edited January 17

    I think I found the settings to change:

    1. On the front pages find "PREFS" in the top row
    2. In the Preferences Menu select "Advanced MIDi Settings"
    3. On the Advanced MIDI Settings Page select MIDI MAPS
    4. On the defaultMap Page slide the button over to "CC Map"
    5. All the Drawbars are listening for CC's on Channel 1
    6. Change the Channel to anything other than 1 for every drawbar
      and they will not be automated by Cubasis.

    If then Kawaii is sending out on OMNI (all channels) you need to pick one on the Kawaii that's not the same as the Galileo CC Map.

  • edited January 17

    Deleted text

  • Very cool. Will try that @McDtracy. Will try that. Now listen to my SpaceCraft track!

Sign In or Register to comment.