Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Multiple app issue

I am having a problem getting 2 apps working together. First I am running an iPad 6 with up to date IOS. I have two apps I want to work with—Anytune and Amplitude. I do not want to do any recording or anything fancy just use Amplitude as an amp simulator and Anytune to learn songs on my guitar. When I load Anytune as an input on line one as the only app within Audiobus there is no problem. Once I launch Amplitude as a second input on line 2, I lose all the sound from Anytune. The sound meter in the mixer shows that it is receiving an input but there is only silence at the output which is set as the system speaker / headphones. If I delete Amplitude as an input and close the app right down the sound is still gone. To regain the sound I have to shut everything down and restart again. Any help?


  • I wasn’t able to reproduce your same problem, but I did have other issues. The order of events that worked in the end for me was:

    1. Close all apps
    2. Open Anytune before opening Audiobus
    3. Open Audiobus
    4. Open Amplitube, but don’t just press on the name of the app, press on the arrow at the right of the name, and select “effect”.
    5. Enable the system output in the lane that Amplitube is loaded in. It wasn’t on by default for me.

    You didn’t mention whether you’re using an audio interface for your guitar, but I assumed you are. Also, in my audiobus settings I have “multi-route audio” disabled if that makes any difference.

    Anytune doesn’t seem to be updated to the latest AudioBus SDK. That could be the cause.

  • Thanks for the reply. Unfortunately it did not solve the issue. I spent some time changing the sequence of when apps were launched, got no-where and decided I didn’t need the hassle of trying to make this work. I will have to look for a different setup. And yes I am using the iRig HD 2 for my interface.

  • That's annoying! I'm gonna grab a copy of those apps and see if I can reproduce it here. Maybe there's something I can do from my end.

  • @bbmuddywolf, I think I've figured out what was going on. I added you to the latest beta - you should have a TestFlight invite in your email. Let me know how you go!

  • Micheal, you are my new favourite superhero. I haven’t spent lots of time with it yet but I did plug in for a couple of tunes and everything worked perfect. I really appreciate your time and effort to help me out.

  • Hehe, excellent! Glad to hear it!

Sign In or Register to comment.