weird things happen after changing to ipad headphones out

This is a weird one. I have had a set up in Audiobus 3 that I have used for months. It includes a few Audio Unit effects, Korg Gadget and Galileo organ all going into Group The Loop Looper. I use a Behringer USB sound card with this set up. Never had any major issues (apart from Audiobus starting up in mono). The other day I had to use AUM with a different set up, and a different lightning adapter...just for midi, and using the headphone out socket to get audio out to an amp. Now I have major issues when I go back to my old session in audiobus . Quite often it tries to load, then just crashes. Sometimes it loads but then there is a massive time lag in the audio chain through the AU effects....midi is ok, and if I remove the AUs then there is no lag. (i'm talking Lag of 1/4 second or more, and not latency) If I force quit all apps and even turn the ipad off and on it still makes no difference, it's just like I can't use my old saved Audiobus sessions. All because I disconnected the sound card and plugged the ipad into something else! If I build a new set up from scratch in Audiobus, then it works fine...but the when I come to recall the session the same issues arise again. It's completely unuseable for now. I'd be eternally grateful if anyone could shine any light on this. Thanks

«1

Comments

  • Also..Multiroute audio doesn't appear to work. I turn it on and no sound comes out of the audio interface.

  • edited November 30

    Maybe try disconnecting the inputs/outputs from whichever audio device is loaded.
    Unplug it physically too.
    Save the preset again, maybe a new version.
    If this new saved preset loads ok, then try reloading your preferred audio device.
    Check if it works ok.
    Then save another version.
    Hopefully this will clear out any old audio device connections, and then establish new, clean ones.

    Not sure if this will work, as I am not having this particular issue.
    But if I was, this is what I would try.

  • edited November 30

    And with Multiroute audio unchecked I am getting audio out of the headphone socket even though the us interface is connected ?? Is that meant to happen. Seems like Audiobus or maube the ipad itself is becoming confused by headphones v. usb interface

  • That doesn’t seem too weird. It could be iOS managing the input/output.
    In AUM I can use an audio device input while output is sent to headphone out.
    I don’t have to do anything special, it just works like that.

  • Ok, now it's even impossible to build a new session using Apps and AUs.. Audiobus just crashes all the time. Might it be possible to get an older version of AB please, because this one might be causing these crashes....or could some of the AUs or fx apps have become corrupted??

  • Try restarting your iPad.
    If that doesn’t work, try deleting Audiobus and reinstalling it.
    Backup any sessions you want to keep before you delete Audiobus.
    The saved sessions may be corrupted, though. So try a fresh session after reinstalling to check that it is working, then try one of your saved sessions.

  • edited November 30

    Whoa, that's pretty bizarre, @jazubon. The first step (after rebooting, just in case it's that) is trying to work out wtf changed - it seems extraordinary that all that came about just because you used different hardware one time.

    Did the Audiobus app update recently? Maybe I introduced a bug that you're seeing. You can see all your recent updates in the App Store app. If that's the case, I might hook you up with the previous build first, to see if that does indeed fix the problems you're seeing. If it does, then I'll at least know where to look.

    Oh, and I'd love to see some of those crash logs, too - here's how to find them. Mind emailing them to me? ([email protected]).

  • Thanks for getting back so soon....It'll take me a while to give you the evidence. But in the meantime, what seems to be happening is that I open a session and the AU and fx apps I have inserted between the system audio in and Group The Loop appear to open instantly - like they're not really 'loading'...then there is the time lag problem. If I remove these apps the time lag disappears. Also, if I then insert new versions of these apps, all runs fine.

    Also, I did like Cracklepot said, and reinstalled Audiobus and that did work...but when I subsequently used the headphones out again for another project the same issues came back.

  • Hi Michael...I did update a couple of days ago. to 3.2.6. Could I try going back to 3.2.0 ? thanks a lot

  • Ah! Yep, absolutely: I've added you as a tester, and you should see the TestFlight invitation in your email. Once you've got it setup you should be able to install some older versions. Try the previous version (3.2.5) first, in the hopes I then have less changes to search through in the event that works for you. If it doesn't work, try the one before

  • Thanks very much. In Test Flight I can only see versions: 3.2.6, 3.2.3, and 3.1.4 and some sub variations e.g 3.2.3 (73). So far I've tried 3.1.4 (53) and it's certainly an improvement and workable for me, so I'm grateful for that. If I save an AB session with AU plugins, and their state is turned off, they do all open up on reopening the session, but their state is always turned on...which is weird. Also, the sessions open in mono quite often , but not always.
    I'll try and send more info soon, but for now thanks again.

  • Hi
    This is the only crashlog I can find for Audious near the date of the 'changes'!.. other apps within AB around that time have produced more crash logs. Thanks

  • and also...I thought I'd just re-install the latest AB and give it a go again. Turned iPad off and on, forced quit all apps etc...uninstalled existing AB3, installed latest. I made up my regular session from scratch.

    Strip 1 is system audio in (usb sound card) into blamsoft filter, then blamsoft dub delay, then blamsoft reverb (all AUs) then into Group The Loop.
    Strip 2 is Korg Gadget into new instances of the same 3 Au fx as strip 1) the into Group The Loop
    Strip 3 is Patterning drum machine direct into System audio out.

    This session worked perfectly well, no issues at all (except that it was all in mono. but that's an ongoing niggle with iPads and AB3 )

    So I saved the session . I force quit all apps, then reopened the session. All the elements were present, but there was about a 1 second delay from audio coming from both the system audio strip and the Korg Gadget strip. But no discerneable delay from the drum machine strip.

    mmm seems like some problem handling the aus....

    I'm now going to repeat the same sequence of installing and making the same session i an earlier version of AB3 to see if there is a change....

  • So, did same thing with AB version 3.2.3 (73) and the same thing (i.e time lag) occurred, this time the lag was slightly shorter though!... If I just remove the AUs from the signal path, the lag disappears .

    then I did the whole thing again with AB version 3.1.4 (59) and the lag has got even shorter...but still there.

  • So finally, (for today) I did the whole thing again, installing AB3 version 3.1.4 (54) and the lag disappeared. All good, except that theAus did not remember their states. I had turned them all off and saved, and they came back all on. Still, much better than impossible time lag.

  • Me again...so using 3.1.4 seems ok but there is some weird USB (possibly) behaviour that is new to me. The session sometimes opens in stereo...then after a few minutes there is a hiatus when then sound comes out of the ipad speaker for a few seconds then comes banging back out of the interface output in mono, a few decibels louder! everything has been working pretty well for months...I don't know what has changed. I updated AB3...I used AUM once with different hardware, and I installed iSymphonic ! maybe that's the culprit? even though I'm not using it in these sessions.

  • Thanks for doing all that experimentation! Sorry about the bum steer with the version availability; I've added a few more old versions back, might take a day or so for 3.2.1 and 3.2.2 to become available but 3.2 should be there, and I'd love to hear if the issue is apparent in that!

  • great. will try 'em. thanks

  • trying 3.2 now. i have had the old starting in stereo, crashing to mono routine happen once so far. but the aus now save their states incl. mute/unmute. i saved a session with them muted, reopened the session and there was the time lag again...but i just unmuted the dub delay au and all was well, the lag disappeared. so it seems that lag issue was to do with the muted save state of the delay plugin . i'll keep testing. cheers.

  • Nice one, good sleuthing! Can you make this happen reliably? Could you give me a step-by-step guide (starting with a new session, no other apps running) to reproduce it? I'd love to get it happening here. What would be ideal is if you could work out the minimum configuration necessary to make the lag bug happen - try to pin it down to one AU, for example.

    Thanks heaps, I really appreciate the time you've put into chasing the issue down!

  • I have tried to isolate AUs. I think what's happening is that if one saves the AB session with an AU bypassed and reopens the session, the AU DOES reopen Bypassed, BUT there is an audio time lag. UNTIL one un -bypasses, then re-bypasses (if you want) the AU in the AB mixer. When one has done this, there is no lag! It happens with all my AUs. and it happens in the more recent versions of AB3 that have the Bypass state saving feature. Unfortunately, if you have a string of them in a channel you have to un-bypass and re-bypass each one when you open a session.
    Thanks for your patient responses.

  • Bravo sir!! That's some great bug hunting right there - just what I needed, I should be able to investigate that and fix it in short order. Stand by, I'll take a crack at it in the next day or two.

  • Fixed, build waiting for beta review - you'll get a TestFlight notification once it's ready. I've also submitted to the App Store for release, will wait for your go-ahead before making that live though.

  • Grand. On another, though related thing...I'm finding it impossible to recall an instance of an app called iSymphonic. Have you come across it? it just won't recall. I'll bug Crudebyte about it!

  • @jazubon said:
    Grand. On another, though related thing...I'm finding it impossible to recall an instance of an app called iSymphonic. Have you come across it? it just won't recall. I'll bug Crudebyte about it!

    I'm afraid not! Let me know how it goes.

  • Thanks for latest beta. I'm having fresh woes I'm afraid. It's quite complicated,isolating what might be the problem, but at the moment I can't work with any of my standard sessions! Any combo of aus, apps, loopers etc can be created, but virtually none of these saved sessions will reopen...you can hear audio going in as the apps open inside AB3 , and then....silence....no audio in. Any audio that has been recorded into Loopy or GTL will play back...but no audio in. I've been trying to isolate this to maybe an AU...but it's taking ages....will persevere....at present, its not working for me. Maybe it's my sound card???...but if I set it to direct monitor it always works...

  • I think I'm narrowing it down. I have made about 20 test sessions, and between saving and reopening I force quit all apps..

    So, I make a simple session of 2 strips. Input one is system input (usb interface) going direct to either GTL or Loopy . 2nd strip is either a drum machine (Patterning) or Korg Gadget going direct to another GTL or Loopy. It works when made...but on reopening , very often the audio IN doesnt work...it tries, as the apps are opening, then stops. If I remove the drum machine or gadget from the 2nd strip, audio IN is restored. The audio in on strip 1 is also restored if I remove the Loopy or GTL from the drum machine /gadget strip. That's the kind of thing that's going on. It's baffling and frustrating. I thought it might be some rogue AU, but there seems to be some output /multiple instance conflict???? I'm just a muso...I don't know what it could be.

  • Just to clarify...(ho, ho) the loss of audio IN doesn't happen EVERY time...just, quite a lot. And it does happen more, if the session has more apps/aus in the strips.

  • Ah, lovely - I just reproduced that here. Great, sorting it out now.

  • Okay, pretty sure I've worked out what was going on. New build just uploading now.

Sign In or Register to comment.