DrumJam is live now

edited December 2012 in General Vote Up0

DrumJam is live on the AppStore with Audiobus support


  • 17 Comments sorted by Date Votes
  • And you beat me to it!

  • edited December 2012 Vote Up0

    First glitch. I can't get drumjam to come back to Audiobus unless I make it the second instrument, in which case it's fine. It loads ok and can be played but if I go back to Audiobus manually the dreaded circle of waiting appears. Ipad3
    Edit: I reinstalled drumjam and it seems to be a problem if the multiple input selection doesn't appear. I would have thought the same would be true of thumbjam but it doesn't seem to be

  • I'm having the same problem, except I can't even get drumjam to load at all - even as a second instrument. Thumbjam works ok but doesn't appear in the list of apps, so have to launch via the iTunes Store. All a bit of a pita to be honest.
    Overall my experiences so far on an ipad2 have not been fantastic, still seems quite buggy. Sorry to moan because the concept is great and I'm happy to accept that it might take a while to stabilise.

  • I have the same problem. Drumjam wont load if I select it first in audiobus. However, if I select the output first (loopy) and then do drumjam on the input it works fine.

  • You might experience some of the silly caching problems that appear when apps have been recently updated. The cause is that Apple's servers are still delivering an old version of the app in question even though they're showing the new version on the App Store.

    If that is what actually happened then that means that the app in question will not have the Audiobus library in it and thus be incompatible, even though you as a user think you've just got the new version.

    A solution to this is to simply wait a few hours and try again after deleting the app in question and rebooting your iDevice to make sure all caches are cleared on the device.

    Sorry for the inconvenience!

  • Thanks Sebastian, but I'm not sure this is quite the problem (the one I am having at any rate). This morning I downloaded the drumjam update and the first time I tried it with audiobus it worked fine. Te panel appeared in drumjam and i could record out to loopy no problem. Since then however, I haven't managed to get it working again.

    If I load drumjam from audiobus (selecting the app from the input menu, then tapping on the grey, 'zzz' picture of the app) I get taken to drumjam but...

    1 the audiobus panel does not appear

    2 I am not taken back to audiobus once the app has finished loading, unlike with any other app I load through audiobus.

    Once I go back manually to audiobus, drum jam appears to be 'awake' but no connection to effects of output is possible, no flashing arrows.

    As drumjam worked once, I presume this cant be a problem you mentioned about an old version being downloaded from the App Store. Or have I misunderstood something?

    Other things I have tried to work around this problem which don't work: resetting the ipad, selecting the output (loopy) in audiobus before drumjam, trying main output/instrument output/loop output in drumjam.

    This is not a complaint at all. Obviously there is going to be a couple of little glitches launching something like this and apart from this issue the app is fantastic.

  • It works, but it just doesn't work if you select drumjam first

  • edited December 2012 Vote Up0

    yes, that's what mine did. As I said I could use another app in the input and then activate drumjam with no problem. Just not the initial way. It's minor for me anyway as I can switch off app1 and everything works fine. I'm assuming if it works at all then it's Audiobus compatible, ie the right version.
    Maybe we should be grumbling at Sonarsaurus!

  • This happens for me too. Weird! Ah well. Is there any way to sync recordings from Drumjam to Multitrack DAW, or do I have to hit record in MDAW and play in DJ at the same time for the first track?

  • I don't seem to be able to get drumjam going even if I select it as the second input app. I just tried:

    1 putting loopy as the output
    2 putting soundprisim as the input (they connect no problem)
    3 putting drumjam as a second input (same issues I mentioned in the previous post -panel doesn't appear in app, doesn't switch back to audiobus, the 'waiting' circle spins on the drumjam input square when I go back into audiobus manually)
    4 removed soundprisim as the primary input leaving only drumjam

    But the problems remain.

  • The way I did it earlier was to select Loopy HD first and then Drumjam. The spinning circle did appear for the latter, but it connected OK after 10 seconds or so. There's clearly some kind of issue with Drumjam right now in terms of opening it normally, so I hope Michael and Sonosaurus can have a look and see if they can work out what's happening.

  • WORKAROUND FOR IPAD 2: If Drumjam or Thumbjam are not listed in Audiobus, exit, open them and leave them running in the background. Then return to Audiobus and they should be showing. Make sure background audio is turned off in settings in order for Drumjam to stream freely into Audiobus.

  • @JCannon I think you might have cracked it. It's the background audio in drum jam which is causing the problem. I just turned it off and everything works perfectly now, I don't even have to do any of the above mentioned workarounds.

    So yes, thanks very much.

  • I think this a combination of issues all wrapped up together. First, there is a caching issue in the Audiobus app, which the easiest way to workaround is to delete Audiobus and reinstall. Everyone please try this before anything else.

    The state of the Background Audio option in DJ should not make a difference in a setup that is working properly.... it gets ignored once AB is connected (and turned on internally), and shouldn't cause hangups before connection.

    I have seen these issues before, but only when Audiobus didn't have the app information properly loaded from the network.

  • @sonosaurus I've just managed to replicate the problem and solution.

    1 deleted and then reinstalled thumbjam, made sure background audio was set to on.
    2 deleted and reinstalled audiobus
    3 added drumjam as input, and loopy as output

    Success! It works.


    4 closed drumjam, loopy and audiobus (in that order)
    5 opened audiobus and added drumjam as input, loopy as output.

    Doesn't work, same problems as described above.

    6 switched off audiobus and loopy.
    7 set background audio to off on drum jam
    8 opened audiobus and added drumjam and loopy.

    Problem solved.

    Basically, I'm just happy I've managed to get it working (love drumjam) but you seem pretty certain that it can't be background audio, so if you like I can send you a video of all this so you can make sure I am not doing anything stupid.. This is on an ipad 2 by the way.

  • I'm not certain of anything, clearly it is a race condition of some kind, which ThumbJam seems not to have. I'll find it pretty soon.

    In the meantime the simplest solution that seems to work in most cases is to kill all of the apps (including audiobus), then start DrumJam first (with background on or off), then start Audiobus and make the connection.

Sign In or Register to comment.