PSA: Don't update to iOS 12.4 if you use apps in AB output slot or IAA apps that use the mic.
https://forum.audiob.us/discussion/34030/urgent-psa-hold-off-updating-to-ios-12-4-if-you-use-apps-in-output-slot-in-audiobus

Stagelight is live on the App Store!

13334353638

Comments

  • @wim said:

    @Rodolfo said:

    @ricksteruk said:

    @wim said:

    @ricksteruk said:
    I’ve been trying to use GeoShred in Stagelight - I can add it as an AU instrument in a track - but can’t seem to get any MIDI out of it - either to record on its own track or to send to another track - I was wanting to try to SampleVerse as it has MPE control.

    Any way to connect to GeoShred? @MatthewAtStagelight @OpenLabstechsupport ??

    I also tried with GeoShred as a separate app with MIDI linked - but Stagelight did not make any sounds! (And yes I did have Stagelight background audio turned on. )

    Is there a problem with MIDI and AUs like BeatMaker3

    PS. If you can update so I can set more than one MIDI track into monitor (rather than record mode) in the Loopbuilder screen I will be very happy :smile:

    Stagelight doesn’t support AUv3 midi yet.
    I don’t think Core Midi from other apps is supported yet either.
    Hardware controllers work OK.

    Ahh darn! What a shame! I’m quite liking Stagelight. It’s so close to being able to do what I want for jamming and recording ideas in as Loops / verses / chooses as I’m going along.

    It does support core MIDI from other apps and hardware controllers.
    AUv3 MIDI and MIDI out is coming soon.

    I couldn’t get core midi working from any other apps. Care to share how?

    Examples:
    -Launch Animoog. In Stagelight, go to Settings -> MIDI In, and select Animoog (virtual).
    -Launch Gadget, use Taipei and set output port to Gadget. In StageLight, go to Settings -> MIDI In and select Gadget

  • @Rodolfo said:

    @wim said:

    @Rodolfo said:

    @ricksteruk said:

    @wim said:

    @ricksteruk said:
    I’ve been trying to use GeoShred in Stagelight - I can add it as an AU instrument in a track - but can’t seem to get any MIDI out of it - either to record on its own track or to send to another track - I was wanting to try to SampleVerse as it has MPE control.

    Any way to connect to GeoShred? @MatthewAtStagelight @OpenLabstechsupport ??

    I also tried with GeoShred as a separate app with MIDI linked - but Stagelight did not make any sounds! (And yes I did have Stagelight background audio turned on. )

    Is there a problem with MIDI and AUs like BeatMaker3

    PS. If you can update so I can set more than one MIDI track into monitor (rather than record mode) in the Loopbuilder screen I will be very happy :smile:

    Stagelight doesn’t support AUv3 midi yet.
    I don’t think Core Midi from other apps is supported yet either.
    Hardware controllers work OK.

    Ahh darn! What a shame! I’m quite liking Stagelight. It’s so close to being able to do what I want for jamming and recording ideas in as Loops / verses / chooses as I’m going along.

    It does support core MIDI from other apps and hardware controllers.
    AUv3 MIDI and MIDI out is coming soon.

    I couldn’t get core midi working from any other apps. Care to share how?

    Examples:
    -Launch Animoog. In Stagelight, go to Settings -> MIDI In, and select Animoog (virtual).
    -Launch Gadget, use Taipei and set output port to Gadget. In StageLight, go to Settings -> MIDI In and select Gadget

  • wimwim
    edited April 2

    Thanks. Worked from Gadget. I had only tried from KB-1 and GeoShred without success.
    [edit - working OK from those two now after a restart.]

  • @wim said:
    Thanks. Worked from Gadget. I had only tried from KB-1 and GeoShred without success.

    Not specific for StageLight (but it applies too), when core MIDI from an app does not work for some reason, there’s a workaround with Midiflow. You just create a virtual input port and connect it to a virtual output port (pass through). Then point your MIDI source app to Midiflow virtual input and connect Midiflow virtual output to the input of your MIDI destination app. It usually works perfectly.

  • wimwim
    edited April 2

    I think something must just have been hosed up. After a restart virtual midi in is working from GeoShred and KB-1 standalone, as well as from GeoShred AU in AudioBus using the virtual midi bridge.

    Thanks for sorting that out @Rodolfo
    @ricksteruk, Sorry for steering you wrong about core midi support. You might want to give it another try.

  • Thanks Mister @Rodolfo, some good stuff there.

  • @wim @JohnnyGoodyear Thank you guys, I always learn something new here. Happy to be of help this time.

  • @wim said:
    I think something must just have been hosed up. After a restart virtual midi in is working from GeoShred and KB-1 standalone, as well as from GeoShred AU in AudioBus using the virtual midi bridge.

    Thanks for sorting that out @Rodolfo
    @ricksteruk, Sorry for steering you wrong about core midi support. You might want to give it another try.

    Thanks for the help @Rodolfo !

    @wim - I’ve got GeoShred connected via AB virtual midi - but it won’t connect stand alone.

    What settings are you using in GeoShred - I’m struggling to get the controller version that’s hosted in AB to transmit the correct info to the plug in hosted in Stagelight - all the bends are not working as MPE just regular pitch bends that affect all notes.

    I did go into the channel setting and choose the “MPE plug in” in Stagelight.

    Any other thoughts what’s going on?

  • how do you stop the "loading preset" screen popping up and losing midi every time you change presets?

  • edited April 2

    Has anyone had issues with plugins not showing up and/or the plugin scanning hanging and eventually crashing the app?

    I have numerous plugins not showing up, and when I rescan it never makes it through the plugin scan before crashing.

    When trying to select external audio plugins, it instead only shows MIDI auv3 plug-ins.

    On a 2017 iPad Pro.

  • @bcrichards said:
    Has anyone had issues with plugins not showing up and/or the plugin scanning hanging and eventually crashing the app?

    I have numerous plugins not showing up, and when I rescan it never makes it through the plugin scan before crashing.

    When trying to select external audio plugins, it instead only shows MIDI auv3 plug-ins.

    On a 2017 iPad Pro.

    I have eventually experienced crashes when using the “Rescan All” option, but not with the “Scan For New” option which works fine for me and all my plugins are available (almost 200).

  • @bcrichards said:
    Has anyone had issues with plugins not showing up and/or the plugin scanning hanging and eventually crashing the app?

    I have numerous plugins not showing up, and when I rescan it never makes it through the plugin scan before crashing.

    When trying to select external audio plugins, it instead only shows MIDI auv3 plug-ins.

    On a 2017 iPad Pro.

    Had that problem with the early beta but not now. Just wish they bring in a visual app symbol rather than just a long list.

  • @Jumpercollins said:

    @bcrichards said:
    Has anyone had issues with plugins not showing up and/or the plugin scanning hanging and eventually crashing the app?

    I have numerous plugins not showing up, and when I rescan it never makes it through the plugin scan before crashing.

    When trying to select external audio plugins, it instead only shows MIDI auv3 plug-ins.

    On a 2017 iPad Pro.

    Had that problem with the early beta but not now. Just wish they bring in a visual app symbol rather than just a long list.

    +1 on app icons in the list of au’s

  • @bcrichards said:
    Has anyone had issues with plugins not showing up and/or the plugin scanning hanging and eventually crashing the app?

    I have numerous plugins not showing up, and when I rescan it never makes it through the plugin scan before crashing.

    When trying to select external audio plugins, it instead only shows MIDI auv3 plug-ins.

    On a 2017 iPad Pro.

    When this has happened to me I’ve just kept rescanning until eventually it finishes after a 3-4 times.

    I have a bunch it’s due to Stagelight not being able to distinguish between AU midi plugins, which it doesn’t support, and regular AUs. I’ve noticed AU midi plugins showing in the list though they shouldn’t, then being removed once you try them and they crash.

  • Wim - Greg - Rudolpho - I'll have to try the scan for new option a few more times. I think it has crashed there before too but we'll see. Thanks.

  • Yeah - I've had to go through quite a few restarts / rescans to get all my AUs loaded. The "Scan for new" seems to work reliably to add new AUs.

    On another note - Ableton Link ?? - I assumed it was there - but I cannot see it :disappointed: Nooooooo!

  • @ricksteruk said:
    Yeah - I've had to go through quite a few restarts / rescans to get all my AUs loaded. The "Scan for new" seems to work reliably to add new AUs.

    On another note - Ableton Link ?? - I assumed it was there - but I cannot see it :disappointed: Nooooooo!

    Regarding Link support. It is not available yet, but it is planned. Stay tuned

  • @MatthewAtStagelight said:

    @ricksteruk said:
    Yeah - I've had to go through quite a few restarts / rescans to get all my AUs loaded. The "Scan for new" seems to work reliably to add new AUs.

    On another note - Ableton Link ?? - I assumed it was there - but I cannot see it :disappointed: Nooooooo!

    Regarding Link support. It is not available yet, but it is planned. Stay tuned

    Yay! that's good news - hope it's not to far into the future...

    I'm just getting a new electronic jam / band project going and was hoping to use Ableton live on my mac with my wife using Stagelight on iPad so we can both have our rigs synced and jam / loop together and work up some stuff to perform.

    Also - as I mentioned before - we really need to be able to have more than one MIDI track in "Monitor" mode at one time on the session page - so that maybe she could play a baseline / chord on one keyboard and a melody on another.

    It's good that the Arrange screen can do this - but we'd be wanting to use the Loopbuilder screen for jamming / performing.

  • While you're there @MatthewAtStagelight - is MPE recording working correctly? I've been trying both using SampleVerse's pads and also feeding Geoshred into Stagelight via MIDI.

    I can get the external GeoShred to play the AU Geoshred hosted in Stagelight - but when I try to record it I keep getting weird stuck notes - it sometimes just records one long stuck note and not any of the bends or new notes I play.

    It does something similar recording / playing back MPE via the SampleVerse pads.

  • @ricksteruk said:

    @MatthewAtStagelight said:

    @ricksteruk said:
    Yeah - I've had to go through quite a few restarts / rescans to get all my AUs loaded. The "Scan for new" seems to work reliably to add new AUs.

    On another note - Ableton Link ?? - I assumed it was there - but I cannot see it :disappointed: Nooooooo!

    Regarding Link support. It is not available yet, but it is planned. Stay tuned

    Yay! that's good news - hope it's not to far into the future...

    I'm just getting a new electronic jam / band project going and was hoping to use Ableton live on my mac with my wife using Stagelight on iPad so we can both have our rigs synced and jam / loop together and work up some stuff to perform.

    Also - as I mentioned before - we really need to be able to have more than one MIDI track in "Monitor" mode at one time on the session page - so that maybe she could play a baseline / chord on one keyboard and a melody on another.

    It's good that the Arrange screen can do this - but we'd be wanting to use the Loopbuilder screen for jamming / performing.

    Noted on the feature requests. As far as the stuck notes, can you give me more info about your setup. What iOS device are you using and how you are recording MPE?

  • @MatthewAtStagelight said:

    @ricksteruk said:

    @MatthewAtStagelight said:

    @ricksteruk said:
    Yeah - I've had to go through quite a few restarts / rescans to get all my AUs loaded. The "Scan for new" seems to work reliably to add new AUs.

    On another note - Ableton Link ?? - I assumed it was there - but I cannot see it :disappointed: Nooooooo!

    Regarding Link support. It is not available yet, but it is planned. Stay tuned

    Yay! that's good news - hope it's not to far into the future...

    I'm just getting a new electronic jam / band project going and was hoping to use Ableton live on my mac with my wife using Stagelight on iPad so we can both have our rigs synced and jam / loop together and work up some stuff to perform.

    Also - as I mentioned before - we really need to be able to have more than one MIDI track in "Monitor" mode at one time on the session page - so that maybe she could play a baseline / chord on one keyboard and a melody on another.

    It's good that the Arrange screen can do this - but we'd be wanting to use the Loopbuilder screen for jamming / performing.

    Noted on the feature requests. As far as the stuck notes, can you give me more info about your setup. What iOS device are you using and how you are recording MPE?

    Hi Matthew - I'm running on a regular model 2017 iPad.

    I'm not sure if I'm successfully getting MPE out of GeoShred into Stagelight. I cannot make stand alone GeoShred be recognised by Stagelight as a MIDI source.

    I've tried hosting GS in Audiobus and using Virtual Midi bridge to send to Stagelight - that way I am able to select Audiobus as the MIDI input in Stagelight. I've got GeoShred hosted as an AU in SL and the GS in Audiobus can successfully play the AU plugin. ( It seems that when I use MPE mode in GeoShred the bends that I play in the AB hosted one do not sound as they should played by the Stagelight hosted version - they do not fully bend to where they should... I have found the "Multi Channel" option in GS makes the bends work properly. )

    Whichever setting I use - if I record a performance on the Stagelight timeline it does not sound at all like it should.

    As regards the SampleVerse pads - I have found that if I record on the timeline without loop mode activated it records the pad bends successfully - but if cycle loop is turned on when the loop returns to the beginning it causes havoc!

  • Whichever setting I use - if I record a performance on the Stagelight timeline it does not sound at all like it should.

    Are you recording with the On-screen keys I know there are some MPE pitch issues there that we'll be fixing in a future update

    As regards the SampleVerse pads - I have found that if I record on the timeline without loop mode activated it records the pad bends successfully - but if cycle loop is turned on when the loop returns to the beginning it causes havoc!

    What kind of havoc? stuck notes? incorrect pitch info?

  • edited April 3

    Again, said developer responds almost immediately 😉😀

  • @MatthewAtStagelight said:

    Whichever setting I use - if I record a performance on the Stagelight timeline it does not sound at all like it should.

    Are you recording with the On-screen keys I know there are some MPE pitch issues there that we'll be fixing in a future update

    As regards the SampleVerse pads - I have found that if I record on the timeline without loop mode activated it records the pad bends successfully - but if cycle loop is turned on when the loop returns to the beginning it causes havoc!

    What kind of havoc? stuck notes? incorrect pitch info?

    Yes that’s pretty much it - both stuck notes and incorrect pitch information ( if a note was playing at the end of the loop when it repeats I think it starts from the beginning of the loop and then disappears from the original position. ). I think some of the original notes that were at the start of the loop disappear - or maybe that is just if they were originally created by bends from another note.)

    It’s a bit hard to describe what actually happens as it really doesn’t make much sense musically

    I can try some more testing in the future - but for now I am soldiering on using Ableton live to record my GeoShred jams - with the annoyance of having to set up 7 midi tracks and route them to the iPad as Live does not do MPE.

    @Telstar5 said:
    Again, said developer responds almost immediately 😉😀

    Very true!! It’s service like this that is making me consider trying the Mac version too :smile:

  • @ricksteruk said:

    @MatthewAtStagelight said:

    Whichever setting I use - if I record a performance on the Stagelight timeline it does not sound at all like it should.

    Are you recording with the On-screen keys I know there are some MPE pitch issues there that we'll be fixing in a future update

    As regards the SampleVerse pads - I have found that if I record on the timeline without loop mode activated it records the pad bends successfully - but if cycle loop is turned on when the loop returns to the beginning it causes havoc!

    What kind of havoc? stuck notes? incorrect pitch info?

    Yes that’s pretty much it - both stuck notes and incorrect pitch information ( if a note was playing at the end of the loop when it repeats I think it starts from the beginning of the loop and then disappears from the original position. ). I think some of the original notes that were at the start of the loop disappear - or maybe that is just if they were originally created by bends from another note.)

    It’s a bit hard to describe what actually happens as it really doesn’t make much sense musically

    I can try some more testing in the future - but for now I am soldiering on using Ableton live to record my GeoShred jams - with the annoyance of having to set up 7 midi tracks and route them to the iPad as Live does not do MPE.

    @Telstar5 said:
    Again, said developer responds almost immediately 😉😀

    Very true!! It’s service like this that is making me consider trying the Mac version too :smile:

    I’ve thought about getting the Mac version. Only thing putting me off is if I have a send with an au effect, it won’t work on the Mac presumably?

  • @MatthewAtStagelight seems stagelight is pretty stable now! One thing I was wondering is if it’s possible to add whatever is necessary to sidechain with the NYCompressor app? In its description it says the following:

    What does ‘supported by host’ mean in this instance?

  • Supported by hosts means we would need to enable tow additional channels per tracks to support the extra plugin connections.

    Noted as a feature request!

    Thank you!

    Whichever setting I use - if I record a performance on the Stagelight timeline it does not sound at all like it should.

    Are you recording with the On-screen keys?

    As regards the SampleVerse pads - I have found that if I record on the timeline without loop mode activated it records the pad bends successfully - but if cycle loop is turned on when the loop returns to the beginning it causes havoc!

    @gregsmith said:
    @MatthewAtStagelight seems stagelight is pretty stable now! One thing I was wondering is if it’s possible to add whatever is necessary to sidechain with the NYCompressor app? In its description it says the following:

    What does ‘supported by host’ mean in this instance?

  • @MatthewAtStagelight said:

    Whichever setting I use - if I record a performance on the Stagelight timeline it does not sound at all like it should.

    Are you recording with the On-screen keys?

    As regards the SampleVerse pads - I have found that if I record on the timeline without loop mode activated it records the pad bends successfully - but if cycle loop is turned on when the loop returns to the beginning it causes havoc!

    Hi Mathew - yes I was recording SampleVerse with the Onscreen keys. And I also tested using it (and Synthmaster Player AU) using Geoshred to send MPE.

    I've not tested out MPE again since then.

  • Hi there @MatthewAtStagelight hope you good.any plans on making Stagelight fit the IPad Pro 11 screen?
    I’ve also noticed that when using sample AUv3 apps, Stagelight randomly skips some notes during playback.
    I’ve tried with BeatHawk and AudioLayer same result.
    Here is a lil demonstration.listen closely to the kick and hi hat.

  • edited May 8

    Does anyone have issues with multiple audiolayer instances? I find sometimes if I freeze and unfreeze one instance it loads with the preset from another instance.

    Also I’m working on a track at the moment which keeps crashing on open (I can open it eventually after multiple tries), and it locks up with 100% cpu frequently. I think this might be audiolayer too as I have about 5 instances of it in the project.

    EDIT: the crashing was due to 2 audio tracks I had. I had chopped them up on the timeline and pitched/stretched the different sections up and down to make a new melody. I think this was too much for SL to handle on load sometimes.

Sign In or Register to comment.