Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

Grain Science - Audiobus - Auria = No Sound


I wondered if you could help as both me and @sinapsya have had problems getting these 3 apps to work together.

I have tried the following...

Standard setup with Animoog/Audiobus/Auria background audio working fine when playing Animoog with Animoogs ribbon controls through Auria.

Replaced Animoog with Grain Science in the first and only active tab in Audiobus.

Checked the settings within Auria and all remained the same as they were with Animoog.

Attempted to play Grain Science with Grain Sciences ribbon controls and get nothing.

I noticed that I can't use Auria's play/record buttons in the Audiobus tab at the side of the screen whilst in Grain Science either which is a bit odd ?

I also noticed that if I hold a note down with Grain Sciences ribbon controls i dont hear anything but if i hold the note and then whilst holding the note switch to Auria with the Audiobus tab I hear the end of the note and see the audio metering response within the armed track in Auria ?!

Also if I set Auria to record then switch to Grain Science to play some notes into the recording track, when I switch back to Auria (as I cannot stop recording within Grain Science with the Audiobus tab) to stop recording the only part that records of Grain Sciences audio is the part from when I initialise the switch..

Anyone have the same issues ?



  • not working for me either. I'm on iPad 3, messed with input/output matrix as well and no luck. maybe someone from the audiobus team can take a look?

  • I've had no problems recording Grain Science through Audiobus into both Meteor and Multitrack DAW. The lack of audio until you switch to Auria sounds like it could be an audio engine compatibility issue to me. Have you tried launching Grain Science first, then Audiobus, then Auria?

  • edited January 2013

    @PaulB just tried that and grain science plays just fine until you launch Audiobus, place Auria in the output slot and then add Grain Science to the input slot of Audiobus. no audio coming from grain science at that point.

    when I eject grain science from Audiobus and launch it normally, the audio comes back. looks like it may be incompatible with Auria.

  • Have you also noticed that you cannot use the Audiobus tab for Auria record and playback whilst in Grain Science ?

    Very strange...

  • edited January 2013

    Not sure how Auria would prevent that happening, unless it's up to Auria to supply details about available sidebar functionality and it hasn't detected Grain Science being present on the bus, so it doesn't bother making that call.

  • I've just tried this on an iPad 4 and I can confirm that it does not work. I'm going to notify the Grain Science and Auria developers.

  • Thanks everyone.

    Hopefully they will sort it.

  • glad to hear that @Sebastian!

  • Doesn't work on my end either. Cubasis, however, works fine.

Sign In or Register to comment.