Equator player into Reason 10

Hey folks, recently bought a laptop, reason10 and a seaboard (bit of a birthday splurge). I’ve also downloaded equator player but it doesn’t show up as a plugin in Reason. Do I have to upgrade for it to show up?

Comments

  • @barabajagal said:
    Hey folks, recently bought a laptop, reason10 and a seaboard (bit of a birthday splurge). I’ve also downloaded equator player but it doesn’t show up as a plugin in Reason. Do I have to upgrade for it to show up?

    Are you sure you have downloaded the right version? I did the mistake myself and it took me times to realise that this wasn’t the right one (there are several available on the website of equator)

  • Yes, that’s strange, I have Equator and it’s shows up and works in Reason 10 OK, ROLI gave me the full version for review but I'm pretty sure the Player version worked, however I still haven’t managed to get it to work as a proper MPE with Reason yet although the Seaboard does work as a normal controller in Reason, Strobe is cool too

  • Reason 10 only support the VST2 Spec, not the VST3. You need to make sure you have the VST2 version installed.

  • Thank you so far > @o_imseng said:

    Reason 10 only support the VST2 Spec, not the VST3. You need to make sure you have the VST2 version installed.

    @o_imseng said:
    Reason 10 only support the VST2 Spec, not the VST3. You need to make sure you have the VST2 version installed.

    Thanks I’ll check out what you say but the only option on the Roli site are 2 Downloads - 1. Windows, 2. Windows 32bit. I plumped for the 32bit download

  • @barabajagal said:
    Thank you so far > @o_imseng said:

    Reason 10 only support the VST2 Spec, not the VST3. You need to make sure you have the VST2 version installed.

    @o_imseng said:
    Reason 10 only support the VST2 Spec, not the VST3. You need to make sure you have the VST2 version installed.

    Thanks I’ll check out what you say but the only option on the Roli site are 2 Downloads - 1. Windows, 2. Windows 32bit. I plumped for the 32bit download

    I believe that Reason 10 is 64-bit only, or at least runs in 64-but by default. 64-bit hosts can’t open 32-bit plugins

  • @jrjulius said:

    @barabajagal said:
    Thank you so far > @o_imseng said:

    Reason 10 only support the VST2 Spec, not the VST3. You need to make sure you have the VST2 version installed.

    @o_imseng said:
    Reason 10 only support the VST2 Spec, not the VST3. You need to make sure you have the VST2 version installed.

    Thanks I’ll check out what you say but the only option on the Roli site are 2 Downloads - 1. Windows, 2. Windows 32bit. I plumped for the 32bit download

    I believe that Reason 10 is 64-bit only, or at least runs in 64-but by default. 64-bit hosts can’t open 32-bit plugins

    Yeah cheers chaps, silly old me downloaded the wrong one. Working just fine now. Snowed in in Siberia- sorry Scotland, only one thing for it - make music. Happy days!

Sign In or Register to comment.