Korg Nanokey Studio Custom Scene Setup

edited March 3 in Creations

Awhile back I asked if anyone was discontented by the default Nanokey midi mapping and I got positive replies from a few users. After hours of testing things out to see what worked best and fixing a few bugs this is it. It's just a small zip folder with the two set up files.

For those who are interested in using it the installation is as follows:

Get the Korg software, Bluetooth Driver and Control Editor from the Korg Nanokey Studio website and install them.

Load up the Control Editor and load the two files, one is the Global setup and the other is the scene data, Write the Global file first followed by the Scene data.

What you will get:

8 scenes, each having their own midi channel (1-8). Each control is mapped to the respective midi channel (e.g. the keyboard, the knobs, the xy pad, the chord pads, etc.)

Scenes 1-7 pads are mapped to midi notes C2-G6 on Midi channel 9

The pads on Scene 8 are CC controller mapped to CC 0 on each of the midi channels (1-8, intended as mute controls)

How you can use this:

First and foremost if you like the default Gadget/Nanokey Studio settings then continue to use it. If you want more control however you'll need to reset the midi mappings for your gadgets using this template.

It's recommended when starting out to use the controller in "Easy mode" (Gadget Settings) enabling you to interact with the active gadget only. When you get a better sense of how to use the template you can move up to Advanced. The template is useful for 9 midi channels (1-9) 9 is reserved for the global channel and the pads.

To reiterate, Midi channels 1-8 for the keyboard and the CCs. Midi channel 9 for the chromatic pads.

As for midi mapping, you can map the instrument output to the pad corresponding to the track on scene 8. The CC value is 0. Then the knobs and the other controllers increment from 1-11 if memory serves. Every control on every scene is uniquely mapped so it doesn't matter the CC number, there won't be any conflicts.

Finally the xy pad. For touch scale the veloocity on the y axis has been disabled. Every note plays at a constant value of about 100.

The xy pad fxmapping is fiddly. I reccomend using the xy pad ether along the x axis or the y axis but not both. Use the knobs for fx modulation.

The pads and keys have also had adjustments for their velocity sensitivity.

I will eventually get around to writing a better overview of the template and hopefully a video tutorial, which I'll post here. In the meantime feel free to use it and further develop it.

Tip: try the pads with the drums in M1.

Edit: typos

«134

Comments

  • Wow, thanks for putting in the hard graft and sharing. I found the editor really frustrating to work with, and immediately gave up. Looking forward to having a play with this in the next few days though :)

  • @tomato_juice said:
    Wow, thanks for putting in the hard graft and sharing. I found the editor really frustrating to work with, and immediately gave up. Looking forward to having a play with this in the next few days though :)

    Yeah I consider it a quality update to the hardware. Unlocked potential here B)

  • edited February 27

    Just got to the beach with my iPad Pro and Nanokey Studio. The sun, ocean, apple, Korg and @LucidMusicInc is why I am having a great day. As soon as I figure out what’s what with this here template that is. Thanks, you win the day my dude.

    ImPatiently waiting on the vid tutorials/demo. :#

  • edited February 27

    @WillieNegus said:
    Just got to the beach with my iPad Pro and Nanokey Studio. The sun, ocean, apple, Korg and @LucidMusicInc is why I am having a great day. As soon as I figure out what’s what with this here template that is. Thanks, you win the day my dude.

    ImPatiently waiting on the vid tutorials/demo. :#

    I think it will workout nicely. I've tested it and it's very intuitive. Of course if there are any specific questions or I've missed anything feel free to post. I will make some videos explaining not just the template but the scales and arpeggiator and hopefully some live sets!

    This will work in any other app as well, for example BM3.

  • Again...many thanks! I think I speak for all the midi-challenged when I say I’ve been struggling to get more out of Gadget and my NkS . Just posted about ways to better control/use Gadget with BM3 mostly because I could midi learn BM3 to do more with ext controllers. Now, things have changed. The timing couldn’t be better.

  • Editor won’t let me receive or write anything. I open editor and hit ‘open’ then it won’t let me get to the file?

  • edited February 27

    @WillieNegus said:
    Editor won’t let me receive or write anything. I open editor and hit ‘open’ then it won’t let me get to the file?

    Can you unzip the folder? This may only work for windows users...

  • Yes. I auto unzipped to download folder. When I click open, nothing happens. No dialogue box to click and open file. Weird.

  • Got it! On Mac you just double click your files. It auto launches Editor then just tap write. Question, why change global tempo to 126? Isn’t this set in Gadget anyways?

  • You can see the two files? You might need to check the Korg website. The files unzip and open on this end.

  • @WillieNegus said:
    Got it! On Mac you just double click your files. It auto launches Editor then just tap write. Question, why change global tempo to 126? Isn’t this set in Gadget anyways?

    Ah the tempo you can set to whatever you prefer to work in. And you can tap the shift button to sync the tempo.

  • @LucidMusicInc said:

    @WillieNegus said:
    Got it! On Mac you just double click your files. It auto launches Editor then just tap write. Question, why change global tempo to 126? Isn’t this set in Gadget anyways?

    Ah the tempo you can set to whatever you prefer to work in. And you can tap the shift button to sync the tempo.

    The important global changes are the velocity and sensitivity settings for the pads and keys and the global Chanel was set to 9.

  • I was rushing so I didn’t scrutinize what you did with velocity or sensitivity. Did you turn them up or down. I haven’t really used them much yet because they were kinda useless to me under the default scene. So far feels good. Just curious as to what you adjusted.

    I saved the default in case I wanted to go back. Unnecessary. This is bad ass. 56 pads! I’m gonna lose the last ‘mute’ scene as soon as I find a nanokontrol for cheap.lol. Then I’ll have 64 pads. Niiiiiiice!

    @LucidMusicInc for President!

  • The sustain button has been set to toggle. It works like the latch button in GarageBand. In the CC menu it is labelled Damper. One Of the first things you should map is the sustain button. :)

  • edited February 27

    Why not change ‘sustain’ to dampen globally? Looks like it is cc#64 for all gadgets. If I change ‘sustain’ from #9 to #64 won’t it do this? Otherwise, Gadget must ‘learn’ it each time right?

  • edited February 27

    @WillieNegus said:
    Why not change ‘sustain’ to dampen globally? Looks like it is cc#64 for all gadgets. If I change ‘sustain’ from #9 to #64 won’t it do this? Otherwise, Gadget must ‘learn’ it each time right?

    It's not the same cc for all gadgets. The other reason is as you make more mappings it gets hard to remember the CC numbers. In this template it's Pad, 0, knobs 1-8, sustain 9, xy pads 10-11. Easy to remember and consistent for future mappings.

    I'm not sure what globally is supposed to mean anyway. When you get into advanced midi, meaning each track having 1 channel (you can also combine tracks to share channels) you don't want to have to troubleshoot which controls should get played by what midi channel etc.

    By all means make a copy and tweak it to your needs. One thing I ought to have done is given the touchpad a little expression by setting some moderate velocity. I'd have to do that for all the scenes which wouldn't take too long but I'm gonna leave it for now. By the time I make a tutorial/demo video I'll have come up with the final solution.

    Of course your questions and suggestions are more than welcome.

  • Yeah that.lol. Forget I mentioned it. How do you use the xy pad while creating? Haven’t found a good use for it.

  • @WillieNegus said:
    Yeah that.lol. Forget I mentioned it. How do you use the xy pad while creating? Haven’t found a good use for it.

    Check this out:

    Get a pluck preset like a harp or bell or guitar and set the sustain on.

    Turn the arp on and tap out a tempo that's playable.

    Use the shift keys to adjust the arp range (2 octaves)

    Use the shift key to adjust the arp type (up/down/up down etc) the chord trigger setting works best

    Use the shift to adjust the gate. You can trigger the notes to play on the 16th/8th/4th note.

    Use the shift to find the preferred scale. Pentatonic minor is a good start and the shift octave to get a more interesting key like E or A

    You can now play the touchpad like a guitar.

    The shift button can also turn Key mode on (third pad on the left top row) to always play in time or get a unique arpeggiation with each touch.

    You can get fancy and use your left hand on the keyboard for bass notes and your right in the touch pad

  • edited February 27

    @LucidMusicInc said:

    Check this out:

    You can now play the touchpad like a guitar.

    Aw man. You just spoiled me. This sounds so saucey I gotta go do it now. Nanokey is an air guitar now?! Shiiiiit.

    Any Youtube channel? Force is strong with ya, me thinks you need a Gadget Channel. You and @jakoB_haQ are Korg Jedi.

  • One Of the first things you should map is the sustain button. :)

    Guess I didn’t fully understand what you meant here. I was thinking you meant to assign Dampen in Gadget midi learn (#64) to the sustain button by tapping it in the cc menu then again on NKS.

  • Gadget no longer displays changes (scales, gate, etc) made from NKS or do I still have something off @LucidMusicInc

  • edited February 27

    @WillieNegus said:

    One Of the first things you should map is the sustain button. :)

    Guess I didn’t fully understand what you meant here. I was thinking you meant to assign Dampen in Gadget midi learn (#64) to the sustain button by tapping it in the cc menu then again on NKS. In some g gadgets the Damper is set to 9, others 64, others still have no Damper assignment yet it's assignable. The most consistant value is 64 but it's not entirely consistent (see Marseille, Vancouver and Milipitas)

    On NkS the button is Sustain and in Gadget it's Damper.

    @WillieNegus said:
    Gadget no longer displays changes (scales, gate, etc) made from NKS or do I still have something off @LucidMusicInc

    That feature only works if you set NkS to native mode. You can memorise the scale order and you can also turn also turn scale guide on.

    @WillieNegus said:

    @LucidMusicInc said:

    Check this out:

    You can now play the touchpad like a guitar.

    Aw man. You just spoiled me. This sounds so saucey I gotta go do it now. Nanokey is an air guitar now?! Shiiiiit.

    Any Youtube channel? Force is strong with ya, me thinks you need a Gadget Channel. You and @jakoB_haQ are Korg Jedi.

    Yup! My Youtube is here

    If you like what you hear you can follow me on Bandcamp here

  • Gadget won’t “learn” the sustain button the normal way. Function>tap Gadget Damper>tap Sustain button. Wierd.

    Also, sometimes the scene set doesn’t load in Bluetooth mode. I have to toggle usb mode a few times. Aside from that, loving the upgrades. :p

    Controlling the Gadget display is definitely no biggie. Just an observation. I rarely go into the scale view anyways. Controlling scales, arp from NKS is a big reason I love it.

    Can’t wait to figure out this sustain issue so I can try your strumming tek. It’s probably something dumb I’m overlooking.

  • edited February 28

    @WillieNegus said:
    Gadget won’t “learn” the sustain button the normal way. Function>tap Gadget Damper>tap Sustain button. Wierd.

    Also, sometimes the scene set doesn’t load in Bluetooth mode. I have to toggle usb mode a few times. Aside from that, loving the upgrades. :p

    Controlling the Gadget display is definitely no biggie. Just an observation. I rarely go into the scale view anyways. Controlling scales, arp from NKS is a big reason I love it.

    Can’t wait to figure out this sustain issue so I can try your strumming tek. It’s probably something dumb I’m overlooking.

    Yeah the scale guide is a big help. You can use the shift octave buttons to set the key. The shift buttons for arp range type and gate also make looking in the arp menu unnecessary.

    The other issues you've mentioned have to do with the Gadget software and the NkS hardware. I recommend keeping the NkS plugged in (I don't even have any batteries in the thing) for best results.

    I would advise against "toggling USB mode." That switch is very flimsy and I reccon it will be the first thing to break. Instead try hitting shift and the "wireless" button. (top row on, last one on the right).

    If you mess up your mapping you can just reload the gadget. Everything works best when you have memorised the features you like, for example what controls you want to map and where they sit on the CC assignment list. That way you can quickly and easily map the controls you like and forget about everything else.

    Don't forget you can also use the NkS in other software and with the new template you have the 8 scenes which didn't exist before, meaning you can control more than one app at a time.

  • @LucidMusicInc said:

    Don't forget you can also use the NkS in other software and with the new template you have the 8 scenes which didn't exist before, meaning you can control more than one app at a time.

    Ha. I got frustrated because I still can’t get the sustain button mapped so I fired up BM3 to test the new scene set in there. Nice!

  • @WillieNegus said:

    @LucidMusicInc said:

    Don't forget you can also use the NkS in other software and with the new template you have the 8 scenes which didn't exist before, meaning you can control more than one app at a time.

    Ha. I got frustrated because I still can’t get the sustain button mapped so I fired up BM3 to test the new scene set in there. Nice!

    I'm not sure why the sustain isn't sticking for you. One tap ought to do it. The sustain is set to "toggle" instead of "momentary" if that information helps in any way.

  • It’s maddening. I’ve rebooted iPad. Unplugged NKs. Everything but delete and reinstall Gadget. Looks like I’ll have too.

  • @WillieNegus said:
    It’s maddening. I’ve rebooted iPad. Unplugged NKs. Everything but delete and reinstall Gadget. Looks like I’ll have too.

    Check the settings so that the Nanokey native settings are off. Uninstalling Gadget won't fix the problem. Just be very patient in how you map it. Otherwise you can reload the default mapping from the control editor software.

  • Fixed it by switching Midi to easy mode. Mapped it. Back to advanced. Now, ARP button is killing key/pad audio.

  • I’m thinking I have a faulty NKS @LucidMusicInc

Sign In or Register to comment.