Is it possible to get LoopyHD to work this way?

I've been fighting Loopy today... So far it's winning.

Basically what I want to do is have loop START NOT quantized/counted-in but have a fixed length loop (i.e. count-out ON)...

  1. Imagine I have loop length in Loopy set to 4
  2. I hit my midi pedal that i have mapped to record when the master loop indicator (the thing in the orange "bar", not the track loop indicator) is at the 5 0'clock position.
  3. I want the loop to record to record for 4 bars and end again at the 5 o'clock position 4 bars later

So far I'm pretty sure this is not possible, unless someone can help me figure out how.

If I set record count-in to off, the fixed length thing does not seem to work, even if count-out is turned on...

This seems like a bug to me... If it's not, then why have the ability to set these independently of each other? If seems if it's NOT a bug, then turning off count-in recording should disable the ability to set count-out to on/off since it doesn't seem to make any difference. Unless I'm doing something wrong...?

The use case is when I'm playing into loopy with a lot of delay/reverb FX, the "natural" start of a loop/groove is almost never at the 12 o'clock "top" of loopy's clock... But I know that the loop/groove will repeat every 4 bars for example...

Right now, if I set count in/out to on, it will always wait until it's at top 12 o'clock position before it starts recording...

Help?

Comments

  • 6 Comments sorted by Date Votes
  • If you set your count in quantize to quarter measure, Loopy won’t wait for the whole clock cycle, but will wait for the next beat to start recording. Keep count in and count out recording enabled. You set this in track management settings, just below count in recording option.

  • @CracklePot said:
    If you set your count in quantize to quarter measure, Loopy won’t wait for the whole clock cycle, but will wait for the next beat to start recording. Keep count in and count out recording enabled. You set this in track management settings, just below count in recording option.

    Thanks Mr. Pot! I tried it and maybe I'm doing something else wrong. Is this how it should work?

    Assume 2 bar loop length
    Set quantize to 1/4 bar

    Loopy's "clock" or record head or whatever goes through this cycle in 2 bars

    1.1
    1.2
    1.3
    1.4
    2.1
    2.2
    2.3
    2.4
    ...

    Assume I hit record at the <<

    1.1
    1.2
    1.3<< Hit record
    1.4
    2.1
    2.2
    2.3
    2.4

    The loop should close at ### below right?

    1.1
    1.2
    1.3<< Hit record (beat should NOT record)
    1.4... Recording beat 1
    2.1... Recording beat 2
    2.2... Recording beat 3
    2.3... Recording beat 4
    2.4... Recording beat 5
    3.1... Recording beat 6
    3.2... Recording beat 7
    3.3### Recording beat 8 - Loop close (should be the last beat recorded, right?)
    3.4

    Is the above basically how it should work? It seems like it's recording that way, but the waveform seems to "snap" around so it lines up with the loop's 12:00 position which causes it to get out of whack...

    I feel like I should be able to get what i need. It's like the settings are fighting against each other. :)

  • @Drümünkey said:

    @CracklePot said:
    If you set your count in quantize to quarter measure, Loopy won’t wait for the whole clock cycle, but will wait for the next beat to start recording. Keep count in and count out recording enabled. You set this in track management settings, just below count in recording option.

    Thanks Mr. Pot! I tried it and maybe I'm doing something else wrong. Is this how it should work?

    Assume 2 bar loop length
    Set quantize to 1/4 bar

    Loopy's "clock" or record head or whatever goes through this cycle in 2 bars

    1.1
    1.2
    1.3
    1.4
    2.1
    2.2
    2.3
    2.4
    ...

    Assume I hit record at the <<

    1.1
    1.2
    1.3<< Hit record
    1.4
    2.1
    2.2
    2.3
    2.4

    The loop should close at ### below right?

    1.1
    1.2
    1.3<< Hit record (beat should NOT record)
    1.4... Recording beat 1
    2.1... Recording beat 2
    2.2... Recording beat 3
    2.3... Recording beat 4
    2.4... Recording beat 5
    3.1... Recording beat 6
    3.2... Recording beat 7
    3.3### Recording beat 8 - Loop close (should be the last beat recorded, right?)
    3.4

    Is the above basically how it should work? It seems like it's recording that way, but the waveform seems to "snap" around so it lines up with the loop's 12:00 position which causes it to get out of whack...

    I feel like I should be able to get what i need. It's like the settings are fighting against each other. :)

    Yes I think that is correct. Here is a shot of my settings. I am using Ableton Link for sync, but it should work with IAA sync as well.

  • Got it to work great now. I think the issue was I had play from start which was sort of causing loops to "shift" relative to their start/end points.

  • @Drümünkey said:
    Got it to work great now. I think the issue was I had play from start which was sort of causing loops to "shift" relative to their start/end points.

    Hell yeah! Great to hear you have it working like you want now. B)

  • Thank you for your help!

Sign In or Register to comment.