Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

DM1 in AUM anyone having problems?

RJBRJB
edited January 2018 in General App Discussion

Anyone got this working consistently in AUM while trying to get Rozeta Suite to trigger? It will work once in a blue moon but most of time it doesn’t. I’m pretty sure it’s not Rosetta, I can swap out DM2 and make the connection. Flaky IAA?
I’ve done a re-install of DM1and an iPad reboot, any thoughts?

Comments

  • It is working pretty well for me. I have DM1 set to receive notes and tempo from IAA. DM1 doesn’t work with any of the Midi note mapping presets in Rozeta, so you have to set them up yourself to get DM1 to respond to the Rozeta plugins.

  • Thanks for your.help @Cracklepot. Knew about the IAA but shouldn’ The DM1/DM2 preset in XOX work? How are you sending the Midi notes?

  • Here is a screenshot of how I mapped my DM1 note triggers in the top panel. The bottom panel shows the Rozeta preset mapping so you can compare. There is one extra pad in DM1 that is not mapped in my setup, the low Tom, which is Midi note 43. I have the cowbell mapped in my setup instead. You have to leave one out, or use another instance of Rozeta to trigger them all since DM1 has 9 pads and Rozeta has 8 tracks for the drum modules.

    The thing to remember is the pads in DM1 are always triggered by the same Midi note numbers. The instrument/sound may not match the labels in Rozeta or standard Midi drum mapping. That is why I shuffled the notes around to better match the pads in DM1.
    You can copy my mapping in a blank pattern and save it as a preset to recall it easily. By that I mean a Rozeta preset for the overall module you are using, not a midi mapping preset.

    Let me know if any of this came out confusing, and I will try and help get it sorted.




  • Thanks again Cracklepot, The only thing that’s confusing is why am I not hearing any drums. I’ve changed my OXO midi settings to yours, is there some other setting in DM1 I missing?

  • Maybe check that your Midi is on as well in DM1. Keep the IAA stuff on, make sure Link is off, and Midi is on, under the other 2 buttons on the Song page.

  • All set correctly, when I hit play in AUM there isn’t any sound but when I go into DM1 it has triggered the pattern and plays what ever song is loaded. Stopping it doesn’t give me the XOX Midi triggered events. Background sound is on but I only hear the DM1 pattern playing when in the drum app, not in AUM.

  • That is strange. If I switch Bg audio off while in DM1 as it is playing Rozeta input, the switch has no effect. I hear DM1 either way. I think this is the opposite of your experience, yes?
    I have an iPad Air2 running 11.2.2, all apps are current versions. Maybe hit up Jonathan, AUM dev, he is very helpful. I don’t know how helpful Fingerlab is, but hit them up too.
    I am not sure what to try next since our experiences are different with the same apparent settings. Still willing to help though, so if you want me to test something out just ask. :)

  • I’ve reloaded everything again this time turned off the background audio and it’s back, Rosetta is triggering DM1. Not sure what’s going on but I don’t want to quit out of AUM now and risk losing it! :# If it does it again I’ll reach out to the developers. Thanks for your help, really appreciate it.

  • DM1 has been regularly ‘fritzing’ out in AUM for an age now for me, just crashes out every time I attempt to load it. Is seemingly still stable in standalone. Shame, it was such a reliable workhorse.

  • It is actually fixed!!! 🤩🤩🤩

  • Anyone using DM1 in Audiobus DO NOT update latest as it breaks contrary to what it says. AUM seems ok. Fingerlab.....

  • Seems like this may be broken again or could be user error. Does anyone who has DM1 have problems with it accepting midi?
    I mainly use Xequence but have also tried with Fugue machine.
    Tried in both AB and AUM with no luck.
    Have previously had it working. DM1 had a recent update…
    iPhone 8+ iOS 14.8

  • edited October 8

    @Zerozerozero said:
    Seems like this may be broken again or could be user error. Does anyone who has DM1 have problems with it accepting midi?
    I mainly use Xequence but have also tried with Fugue machine.
    Tried in both AB and AUM with no luck.
    Have previously had it working. DM1 had a recent update…
    iPhone 8+ iOS 14.8

    It works in AUM for me driven by Rozeta XOX (808 mode off) but doesn’t maintain a steady beat. iPad 8 iOS 15.0.1

  • Hmm, wonder if it’s an iOS version thing…
    Yes, remember the timing was off in either AB or AUM.
    They keep updating it so fingers crossed it should work for all use cases but always seems to have some glitches.
    I’ve sent them an email anyway…

  • @Zerozerozero said:
    Hmm, wonder if it’s an iOS version thing…
    Yes, remember the timing was off in either AB or AUM.
    They keep updating it so fingers crossed it should work for all use cases but always seems to have some glitches.
    I’ve sent them an email anyway…

    I just use it to make and export loops these days. At least that's reliable! :*

  • I’ve just got this going now after reading the thread and after failing in the past. It’s great with the randomise for the pattern in XOX and the parameters in DM1 - plus you can get quite a large sample in for each drum to edit down within DM1.
    Anyway I have only been playing around with patterns but I haven’t noticed any timing issues. Very exited about the prospects. How do the timing issues manifest themselves? Is it eventual drift or some notes playing off the actual beat? or what is happening?
    I’m on an Air4 iOS 14.2

  • I think for me it was drifting from the other instruments but can’t check as I can’t get it to run anymore.
    If it’s running with Rozeta for others then it must be user error on my part. Is it possible to screenshot midi settings if you get a chance? Thanks!

  • @Zerozerozero said:
    I think for me it was drifting from the other instruments but can’t check as I can’t get it to run anymore.
    If it’s running with Rozeta for others then it must be user error on my part. Is it possible to screenshot midi settings if you get a chance? Thanks!

    Here you go







  • @robosardine said:
    I’ve just got this going now after reading the thread and after failing in the past. It’s great with the randomise for the pattern in XOX and the parameters in DM1 - plus you can get quite a large sample in for each drum to edit down within DM1.
    Anyway I have only been playing around with patterns but I haven’t noticed any timing issues. Very exited about the prospects. How do the timing issues manifest themselves? Is it eventual drift or some notes playing off the actual beat? or what is happening?
    I’m on an Air4 iOS 14.2

    DM1 driven by Rozeta XOX in AUM. Sounds randomly play off beat. No mod is being used and 808 mode is off. Using DM1 sequencer everything is correct.

  • @robosardine said:

    @Zerozerozero said:
    I think for me it was drifting from the other instruments but can’t check as I can’t get it to run anymore.
    If it’s running with Rozeta for others then it must be user error on my part. Is it possible to screenshot midi settings if you get a chance? Thanks!

    Here you go







    Thanks very much for taking the time to shot those.
    I don’t have rozeta but have mimicked your settings best I can with fugue and still no joy.
    I think the only option is to get a rough pattern going in the internal DM1 sequencer and then sample the sounds out individually. Pretty frustrating…

  • @Zerozerozero You may need to enable Network Access for both DM1 and the host that connects to it. Check in Settings–>Privacy–>Local Network.

  • Thanks @uncledave
    Good shout but all seems ok in those settings…

Sign In or Register to comment.