PSA: Don't update to iOS 12.4 if you use apps in AB output slot or IAA apps that use the mic.
https://forum.audiob.us/discussion/34030/urgent-psa-hold-off-updating-to-ios-12-4-if-you-use-apps-in-output-slot-in-audiobus

Problems with Animoog/AUFX/Cubasis :(

Just stumbled across a great sound using Animoog and AUFX:Dub and decided to record a tune in Cubasis (on my 32GB iPad2) but got some clicks/artefacts.
Decided to start again, unloaded and closed all apps, deleted a couple of unused apps to free some more space (over 4GB free now), went to Airplane mode and did a hard reset just to be sure!
Loaded Audiobus, added Animoog in Input slot, AUFX:Dub in FX slot and Cubasis in Output slot again. Set up my preset in Animoog and tried to record my tune again but about 1 minute in I got a big stutter and everything crashed and goes back to "desktop" icons - although the apps are still open if I double-click the Home button.
Repeated the whole procedure and same thing happens - completely crashes out whilst recording after about 1 minute.
Tried it is AUFX:Space instead but got the same problem!

I have also noticed that some apps in the input slot sometimes don't produce any sounds e.g Drumspace and even Amplitube but when I load a different app but not in Audiobus, I can get sound!

Never had this problem before upgrading to iOS 7! :(

Comments

  • edited October 2013

    There are known bugs in iOS7 that haven't been mentioned publicly. For example, there is a bug that affects StepPolyArp's internal sounds. It is an iOS7 bug, as I've confirmed with the author. I've never seen this particular bug mentioned here or elsewhere, and only learned of it after discovering it myself and contacting the developer. There are many bugs like this, so it is certainly possible that iOS7 could be a culprit.

    Also, there are still many compatibility issues between iOS7 and the music apps that we use and love. As time goes on, these are getting fixed...

    One thing that comes to mind is how you mention that you get a big stutter and then everything crashes and goes back to "desktop" icons....and only after things have been going on for about a minute. With iOS, as I understand it, everything runs in RAM, and when RAM is exhausted or the system is unable to handle the load, iOS shuts things down to recover. This is what I suspect may be going on. While a nice tablet, the iPad 2 is getting really old (I use one myself and won't be able to upgrade for a while). It has been suggested that iOS7 uses more RAM than iOS6, even if tuning the OS by turning off various settings helps control CPU and battery usage.

    I would suggest trying to record in phrases rather than doing a whole track at once. Get a phrase printed to audio, and then copy/paste it as needed. You'll use a LOT less resources this way. For example, rather than recording a 3.5 minute song, you might record a 20 sec verse and a 10 sec chorus, etc., and copy/paste the parts throughout the song.

    I think you were on the right track with the resource saving things you tried. It has been documented by the developers that Cubasis needs at least 3GB of space to work in, so clearing up 4Gb of space was a great idea. Also, going to airplane mode was a great thing to do. In fact everything you did was exactly what I would have first recommended trying. :-) However, I recommend also trying several things from the following thread and modifying your recording approach to help with resource usage:

    http://forum.audiob.us/discussion/2092/post-your-tips-to-get-the-most-out-of-your-system-#Item_1

    Also, remember, you may indeed still be running up against some iOS7 and audio app bugs too, so hopefully those will get sorted with time as well. I hope some of this helps! :-)

    --Sean

  • edited October 2013

    @AlterEgo_UK - I've noticed the issue when you close apps then do a hard reset and it loads back up there are still up. What I've done to get rid of this is; I'll close the apps then go back to the home screen, switch to next icon home page, double click button again, go back home....I do this a about three times total (initial app closing, open/close, open/close) then do a hard reset and there not open when iOS loads back up. Not sure if it's the time or what that causes it....

  • Good point @JMSexton! Several developers have mentioned how crashed apps will sometimes load up again, even after a hard reset, because the OS doesn't consider them closed if they are in the background when the system is rebooted--they will often get loaded again after a reboot. So after a reset, it's important to confirm that the apps are really closed, and if necessary, reboot again!

  • Thank @Audiojunkie and @JMSexton will give your suggestions a go. 20 sec phrases is a bit of a challenge to make a natural sounding tune though! :)

  • mmpmmp
    edited November 2013

    Don't have Cubasis but tried it with Animoog>AUFX:DUB>Auria: also quite a bit of crackling.

    Setting AB hardware buffer to 512 frames helped a lot, as did removing the AB icon strip from view whilst playing, you can see the Animoog XY-pad display becoming smoother as well when you hide the strip.

  • Thanks @mmp. I think I actually tried that as well but still got a crash. Not had a chance yet to try again today though as yet.

  • Now I am not happy! I just went to try these suggestions and Audiobus crashes every time I try to start it up! (Sent the crash reports when prompted). Will try uninstall/reinstall.

  • Well, after deleting and re-installing Audiobus, it now starts. I tried the same setup as before and successfully recorded a short phrase (about 30 seconds) OK from Animoog. However, when I tried to record the next bit I only got a few seconds before the jitter and complete crash again! I presume it must be an iOS 7 bug to do with that combination. I will try a different combo or go back to using my PC!

  • edited November 2013

    @AlterEgo_UK How many tracks does your current project have? If you are using several tracks, bounce down to a single track and start a new project with that. Use that new project (containing just the single audio track of your song) to record the Animoog part. Once the part is done, export the Animoog audio track and import it back into your original project.

    Another thing to try. Record the Animoog part dry. Once you have the full audio track, do a Cubasis to AUFX:Dub to Cubasis recording and print your effects.

    These things should get you past this problem if it isn't bug related.... Let us know how it goes! :-)

  • AlterEgo have you tried MultiTrack DAW ?

  • Thanks, @Audiojunkie my project has only 1 track containing a single 2 bar Audio loop copied and pasted over 4 bars! My Animoog recording is the 2nd (empty) track.
    Recording the Animoog dry is one of the things I was going to try anyway and put the effect on afterwards.
    @mandrakonian: yes I have used MTD a couple of times but there is no real editing available (and no midi) and I don't really like it for full projects. I have used MTD to record an audio track and copy to Cubasis though so maybe I will try that as well. Thanks. :)

  • edited November 2013

    FWIW, as awesome as Animoog is, it is a total memory hog. I am still on iOS6 but in my tests it regularly chews up about 230MB of RAM! Being that the iPad 2 has only 512MB of RAM, I am surprised it can run it at all.

  • @AlterEgo_UK Maybe you can just get the Animoog part done by using Multitrack DAW, and then export it back over to Cubasis afterwords.....

  • @Ringleader Based on what I've heard of about the symptoms, I too am suspecting RAM may be at least one major cause of the problems here. One has to get creative sometimes to get by with just an iPad 2.....I'm in the same boat. :-(

  • OK, managed to finally record the tune I have been trying to do!
    Recorded the Animoog tune into Cubasis without extra effects (there was already a reasonable amount of delay so it sounded OK) and then added some DrumStudio drums through AUFX:Space into Cubasis. So I guess it could have been the combination of Animoog and AUFX:Dub into Cubasis in Audiobus that ate up the RAM.
    I have posted the tune in the Soundcloud thread if anyone wants to hear the end result :)

  • Glad you got it recorded! I'll go check it out! :-)

Sign In or Register to comment.