Xequence completely bugged since last ios update

I can't even start the app anymore. It says 'Could not load project 'Library/close.xeq' on my ipad pro 10.5.
Is anyone else encountering this bug? I tried to install the app again, lost all my tracks in the process. It worked ok the first time I used it then back to this bug. I can't do anything with this app for now.


  • 10 Comments sorted by Date Votes
  • All good here iPad Air 2 iOS 11.2.1

  • No problems here on Air2 and iPhone 7. Haven’t heard of anyone else having problems either.

  • edited December 2017 Vote Up0

    Thanks for your feedback guys. I suspect it has something to do with icloud saves. Changed to 'Save to this ipad' and I will monitor how it goes in the coming days.

  • @Norbert: thanks for your report, I also sent you an email. "Store documents and data in iCloud" may actually be the culprit. It's always nice when Apple secretly introduces some extremely "innovative", obscure feature behind your back that goes against all good practices in IT and software development and breaks basic assumptions about operating systems, like, errr, file systems :o

  • No bother I understand. I had the same problems in the past with the apps I created. I agree, it's a real pain. Thanks anyway. It seems to be working fine now. Fingers crossed.

  • @Norbert said:
    No bother I understand. I had the same problems in the past with the apps I created. I agree, it's a real pain. Thanks anyway. It seems to be working fine now. Fingers crossed.

    Thanks and nice to know you're in the same boat. It's funny because at the point where it tries to load close.xeq, it calls [[NSFileManager defaultManager] attributesOfItemAtPath:path], and upon (successful!) return and confirmation that the file exists, it immediately tries to read the file with [NSString stringWithContentsOfFile], which then appearently fails. I presume files can be locked for reading because of this iCloud stuff going on. I've just revised all code that deals with project loading to actually load the project before even pretending it tries to! :#

  • edited December 2017 Vote Up0

    Yeah I guess it's the case. You can execute path finding functions but reading is locked. What is this close.xeq file by the way? Is it where you store the data upon closing the app? Like last minute saves?

    I disabled most of my icloud functionalities on my ipad but could it be that icloud still allows apps to save there anyway? Like a saving glitch or something.

    it seems like when installing the app, the default behavior is 'Save to iCloud'. It might be better to put it to 'Save to this ipad'.

  • Yes close.xeq stores the project state when the app goes into the background. There's also a separate once-per-minute autosave to a different file. As you can see, we're trying really hard to prevent data loss, but you still made it happen! :D

    I will have a closer look at this iCloud stuff when I got the time...

  • edited December 2017 Vote Up0

    The bug is still happening to me. I can't open Xequence anymore again. The same message. So I am not even sure it's linked to icloud cause in the settings, I am on 'On my ipad'. I have no clue how it is caused.

    Hope it gets fixed soon cause it's pretty annoying.

  • edited December 2017 Vote Up0

    @Norbert, sorry to hear. I'm pretty sure I've fixed it for the next update, and it should be out in a matter of 2-3 weeks. I'm still curious how this happens, because this must be some kind of device or iCloud setting that neither I nor any of the testers ever use, because it has never happened here. However, the underlying reason clearly must be that while the file (close.xeq) exists, it isn't readable or corrupted.

Sign In or Register to comment.