Quantum mini-tutorials

edited November 2017 in App Tips and Tricks Vote Up3

A tiny slideshow on some aspects of Quantum midi sequencer.

Midi recording

Audiobus3 is hosting Aum sending its keyboard via MidiflowAdapter through Quantum to Animoog and bs-16i.

Open Audiobus, go to midi page, for output select Aum Port 1. For input, select Quantum, in the next row select Quantum for output, and MidiFlowAdapter for input.

In ab3 audio page, add Aum as output (in the row with Aum as input). Add an IAA app like Animoog next to Aum input (+).

Tap the Aum icon to open and the IAA audio channel is there already. Add an AU app like bs-16i.

Tap the Quantum icon to open, add a new rack, tap 'Midi input' and then the white circle and tap 'Set Note manual advance' and 'Record single notes &/or CC'.
Go to devices, tap 'Input' and on 'Audiobus Midi Input' device tap 'Active', set 'Ignore Transpose' to Off, and 'Midi Thru' to on. Go to setup, and set AB link to 'phase'.

Change back to Aum, where in the Menu, 'Midi Route', you connect the upper row outputs to the side row inputs: IAA port 1 to Animoog (virtual) and [email protected] 2, and keyboard to MF Adapter In 1.

Tap the Aum keyboard icon and play some notes. Have a look at the faders in Quantum, they should be recorded! Hit 'Play', done :)
You can select rec, play from the ab sidebar too - oh, and you can record chords in Quantum ...

If you like, you can load StepPolyarp as midi effect in ab3 (in the row with MFAdapter and Quantum) ...

Save the audiobus preset, and when finished, clear your session. MidiflowAdapter or IAA's could stay in zombie mode, so reboot before the next session, or load and swipe up to delete.

Thanks for your interest,
Crs

Comments

  • 13 Comments sorted by Date Votes
  • edited November 2017 Vote Up2

    Another topic would be CC Automation and FX:

    As before, the setup is: Aum is the mixer, where an IAA and an AU (Moog Model15) are hosted, the midi goes from Aum's keyboard to MidiflowAdaper and through Quantum back to the AU in Aum and to the IAA in Audiobus via the IAA Port.

    In Quantum, in the setup AB link, global CC and FX are enabled.
    A tap on the left side brings up the Global Define Controller Types, where the various cc's can be activated, and then, in the fader section, selected and drawn.

    For the AU cc automation, a midi source needs to be ticked (IAA port), and the parameters defined/learned.
    For the IAA, it can be midi-learnt (keep in mind to only have one cc active).

    As for the FX, they are brought up like the controller types by tapping (fx), and in the Global Midi FX window drag and drop 'em into a slot (interchangable), and activate.

    In this example, there's 'echo' and 'velocity channel switching' - that's why the IAA and AU have defined specific channels (1 and 2) in their respective settings. On the sequencer rack the midi channel can be changed.

    These manipulations in Quantum are happening automagically via midi-thru, but can be recorded and played back, of course.

    Exchange the keyboard in Aum with your controller.

    &/or, for full joy, with Rozeta.

  • Thanks for sharing.

  • like the 'automagically' :)

  • [MidiSequencer] and a Beatstep:






  • edited December 2017 Vote Up1

    Audiobus preset 'Barbed Twigs': http://preset.audiob.us/XWApks3B6wcNkjC

    (remember to toggle 'midi in' and set the input to midi thru in 'devices', just in case, tap on midiflowadapter to wake up)

    In this variation of all of the above a bcr2000 controller unit is mapped to Quantum, and Rozeta Particles driving a Rozeta Arpeggiator and Aum keyboard going into Quantum in record mode, running through midi fx rotator. The resulting sequence is playing in Animoog and Phasemaker. Hosted in audiobus3 for statesaving et al.

    The bcr2000 mapping covers the 16 faders, mute on/off buttons of the steps, tempo, transpose, activate & play (parts A,B,C,D), stop, cycle, and cc's ...

    Listen to Barbed Twigs byCrz on hearthis.at

    Greetz,
    Crs

  • Nice to see something about midiSequencer! Its still popular (probably because Quantum is a a lot deeper).

  • If I follow your instructions in the first example exactly, if I play three notes in succession, only the last is recorded in the first step of the sequence. I assume that’s because note auto advance is off. That means I would have to manually select the second step and press the next key, right? I tried turning note advance on. If I play three notes, every one of them enters TWO steps in the sequence. I’ve tried other connection methods (MF Keyboard as input to quantum without all of the Audiobus/AUM SETUP) and the same thing happens.

    When I view the midi stream in Midiflow, I see that it’s sending the note off message as a note with 0 velocity. I wonder if the note off message is being treated as another midi note event by quantum. I’ve started to look for a way to filter out note off messages...

    Anyway, the idea of having to use auto advance OFF to get this to work makes the process pretty slow, because you have to keep switching from the keyboard back to quantum so you can manually select the next step to be entered.

    I’m going to try connecting my hardware coremidi keyboard to see if the results are different.

    Any help would be appreciated.

    THANKS for your examples!

  • @motmeister that appears to be a mini-bug, if you re-engage 'record' in Quantum after having played a sequence once, tapping 'Note auto-advance'' sometimes can be ineffective; just tap on 'record' and select 'Note auto-advance'' again.
    Greetings

  • Thanks! A record button is mentioned in this thread, but I don’t see a record button in the Quantum interface. If you mean the record button in AUM, ok... But I came to this thread looking for a solution to the problem of note double entry. If all I wanted to do is just input notes to the Quantum sequences, I can just hook up a virtual keyboard to the Quantum input with the usual settings. It works the way you’d expect with one exception. If you press a note on the virtual keyboard it adds the note to the next TWO steps in the sequence. It doesn’t happen with my coremidi hardware keyboard. In that scenario it only adds ONE note. I did a little research and discovered what I think is the reason. Most hardware keyboards send a true MIDI note off message when you release the key. At least SOME of the iOS virtual keyboards send a note on msg with a velocity 0. That velocity zero msg is being treated by Quantum as another note instead of a note off. I wrote the developer and he acknowledges that the velocity zero message should be treated as a note off and ignored. He’s looking into it.

    The MIDI standard allows this velocity zero msg as a valid note off, so in cases like this developers must be aware of it as an alternative to a true note off msg. Interestingly, not all iOS virtual keyboards are created equal. When I send the output from Cubasis to Quantum and play notes on its virtual keyboard, it must be sending real note-offs, because Quantum registers them once, not twice.

    It never ceases to amaze me how helpful everyone is on this forum, so once in a while I try to give back whatever nuggets I can when I learn something. The other thing that amazes me is that when you consider how expensive it can be to host one of these forums (internet bandwidth and disk storage, for example), I’m very grateful that the Audiobus folks provide this platform for us all to share our experiences!

  • @motmeister said:
    Thanks! A record button is mentioned in this thread, but I don’t see a record button in the Quantum interface.

    I rarely use record in Quantum for some reason and I'm not in front of it at the moment but I think "record" is the button with a big circle in the lower right set of buttons.

  • @ccs2 said:
    @motmeister that appears to be a mini-bug, if you re-engage 'record' in Quantum after having played a sequence once, tapping 'Note auto-advance'' sometimes can be ineffective; just tap on 'record' and select 'Note auto-advance'' again.
    Greetings

    added to my list to fix :)
    Will also look at option to treat Midi Note On vel=0 as Note Off. It needs to be per device.

  • tjatja
    edited May 22 Vote Up0

    @ccs2 How did you do this slideshow? Directly on iOS? Which App did you use?

    Seems to be a good alternative to multiple images or movies.

  • @tja with the 'workflow' app, ('make gif'), and some experimentation ;)

Sign In or Register to comment.