Cubasis Midi Transpose Channel Input

Guys is there a way to Transpose midi inside Cubasis? I have Midiband sending midi to a midi track in Cubasis. I have Beathawk as the Bass Preset but the pitch is too deep. When I select one of Cubasis built in Synths the pitch is perfect.

So how can I Transpose the incoming midi data?

Comments

  • 20 Comments sorted by Date Votes
  • How about adjusting the pitch in Beathawk? You can raise it 2 octaves?

  • It's quite easy to transpose the sections after recording using the transpose button under tempo next to the quantise button. There is no built-in real-time transpose of incoming midi for now...

  • If you have it, you could use the MidiFlow effect (MF Transposer) if you need it in real-time too.

  • Hopefully we'll some day get the MidiFlow stuff as pure 'AU-Midi' Plug-ins so we don't have to route everything thru AudioBus which I've not used in ages (I see no real need/use for it).

  • Thanks so much guys!
    I forgot to mention that Midiband is only core midi so how can it work with sending to Cubasis via AB3?

  • @jcdream said:

    Hope it helps you :)

    Cool hand font!

  • wimwim
    edited October 2017 Vote Up0

    [deleted]

  • wimwim
    edited October 2017 Vote Up0

    @MusicMan4Christ said:
    Thanks so much guys!
    I forgot to mention that Midiband is only core midi so how can it work with sending to Cubasis via AB3?

    MidiFlow Adapter plugin ... gets a little complicated though.

  • I have them and tried to use offline outside AB3 but froze my entire system. It could have been me creating some kind of midi loop. But then I tried the setup like the pics but got no midi into Cubasis. I know Midiband is sending midi out via channel 13 [bass] but it just would go into Cubasis if Cubasis was in the input midi slot. If I selected core midi in Cubasis as the input then the midi would come in from Midiband via Channel 13. However, the Midiflow Transposer wouldn’t apply its effect of Transposing.

    I might have to purchase the standalone Midiflow but kind of feel bummed that I have to if I already purchased the whole bundle for AB3. :neutral:

    @wim said:

    @MusicMan4Christ said:
    Thanks so much guys!
    I forgot to mention that Midiband is only core midi so how can it work with sending to Cubasis via AB3?

    MidiFlow Adapter plugin ... gets a little complicated though.

  • O.K. Let me see if I can help you out.

    1. Load Audiobus and put MF adapter in the input and output of a midi lane. Put MF transposer in the Midi fx slot.
    2. In Midiband, set your midi output to MF Adapter channel 1. In the MF Adapter in the Audiobus midi output slot,
      make sure output channel 1 in paired to input channel 1. It should be already, but I like to check it.
    3. In Cubasis, load up Beathawk as a Midi track. In the Midi routing section, select MF Adapter Out 1 as the Midi
      input.
    4. In Audiobus, go into MF Transposer and enter +12 to transpose up an octave. You should hear the effect on
      Beathawk when you playback.
  • Thanks bro! Gonna try it and report back.

    @CracklePot said:
    O.K. Let me see if I can help you out.

    1. Load Audiobus and put MF adapter in the input and output of a midi lane. Put MF transposer in the Midi fx slot.
    2. In Midiband, set your midi output to MF Adapter channel 1. In the MF Adapter in the Audiobus midi output slot,
      make sure output channel 1 in paired to input channel 1. It should be already, but I like to check it.
    3. In Cubasis, load up Beathawk as a Midi track. In the Midi routing section, select MF Adapter Out 1 as the Midi
      input.
    4. In Audiobus, go into MF Transposer and enter +12 to transpose up an octave. You should hear the effect on
      Beathawk when you playback.
  • @jcdream said:

    Hope it helps you :)

    This does not work that great because in Cubasis you cannot easily pass Midi input to Audiobus using Midi thru. The only data Cubasis will pass to the Midi output section is the data in the track, not whatever is coming in live.
    To have data in the track, you have to create/record it, and if that's the case, just move the notes in the piano editor.
    Midi thru seems able to pass the live Midi data coming in, but this gets disabled as soon as Audiobus gets hooked up to Cubasis Midi, so it is a no-go.

  • edited October 2017 Vote Up0

    @CracklePot said:

    @jcdream said:

    Hope it helps you :)

    This does not work that great because in Cubasis you cannot easily pass Midi input to Audiobus using Midi thru. The only data Cubasis will pass to the Midi output section is the data in the track, not whatever is coming in live.
    To have data in the track, you have to create/record it, and if that's the case, just move the notes in the piano editor.
    Midi thru seems able to pass the live Midi data coming in, but this gets disabled as soon as Audiobus gets hooked up to Cubasis Midi, so it is a no-go.

    maybe you can try it,in my ipad it work,and the note in the piano editor was move when i adjust in mf(and play/record in cubasis) :)

  • edited October 2017 Vote Up0

    @CracklePot said:

    @jcdream said:

    Hope it helps you :)

    This does not work that great because in Cubasis you cannot easily pass Midi input to Audiobus using Midi thru. The only data Cubasis will pass to the Midi output section is the data in the track, not whatever is coming in live.
    To have data in the track, you have to create/record it, and if that's the case, just move the notes in the piano editor.
    Midi thru seems able to pass the live Midi data coming in, but this gets disabled as soon as Audiobus gets hooked up to Cubasis Midi, so it is a no-go.

    maybe you can try it,in my ipad it work,when i adjust in mf,play in cubasis and record,the note just move like the mf transposer set. :)

  • edited October 2017 Vote Up0

    It worked!

    But, for some weird reason Midiband re-enables all Midiflow adapter inputs so if I don’t watch it, a huge ugly midi loop happens :s

    I have to go back to Midiband settings and disable them again. But at least I know they’re working. Saved it as a AB3 preset.

    Hopefully @Ksh Kateryna the developer fixes the midi settings such a great app for guitar players wanting to create quick backing tracks.

    @MusicMan4Christ said:
    Thanks bro! Gonna try it and report back.

    @CracklePot said:
    O.K. Let me see if I can help you out.

    1. Load Audiobus and put MF adapter in the input and output of a midi lane. Put MF transposer in the Midi fx slot.
    2. In Midiband, set your midi output to MF Adapter channel 1. In the MF Adapter in the Audiobus midi output slot,
      make sure output channel 1 in paired to input channel 1. It should be already, but I like to check it.
    3. In Cubasis, load up Beathawk as a Midi track. In the Midi routing section, select MF Adapter Out 1 as the Midi
      input.
    4. In Audiobus, go into MF Transposer and enter +12 to transpose up an octave. You should hear the effect on
      Beathawk when you playback.
  • @MusicMan4Christ said:
    It worked!

    But, for some weird reason Midiband re-enables all Midiflow adapter inputs so if I don’t watch it, a huge ugly midi loop happens :s

    I have to go back to Midiband settings and disable them again. But at least I know they’re working. Saved it as a AB3 preset.

    Hopefully the developer fixed the midi settings such a great app for guitar players wanting to create quick backing tracks.

    @MusicMan4Christ said:
    Thanks bro! Gonna try it and report back.

    @CracklePot said:
    O.K. Let me see if I can help you out.

    1. Load Audiobus and put MF adapter in the input and output of a midi lane. Put MF transposer in the Midi fx slot.
    2. In Midiband, set your midi output to MF Adapter channel 1. In the MF Adapter in the Audiobus midi output slot,
      make sure output channel 1 in paired to input channel 1. It should be already, but I like to check it.
    3. In Cubasis, load up Beathawk as a Midi track. In the Midi routing section, select MF Adapter Out 1 as the Midi
      input.
    4. In Audiobus, go into MF Transposer and enter +12 to transpose up an octave. You should hear the effect on
      Beathawk when you playback.

    Glad to hear you were successful. Yeah I remember when Jakob Haq did his MF adapter tutorial he had the same thing happen and had to disable a bunch of channels or ports that auto-connected. Easy enough to do if you know it is happening, but could be weird if you don't know that it does that.

  • Guys is there a way to make the built in Bass preset instrument mono in Cubasis?

  • @MusicMan4Christ said:
    Guys is there a way to make the built in Bass preset instrument mono in Cubasis?

    As far as I know the Cubasis Microsonic instrument has no Mono/Poly switch.
    It might be helpful to tag @LFS with all the issues we bump into?

  • edited October 2017 Vote Up0

    Thanks Samu, I realized that the reason why I’m getting stuck notes in Cubasis is because the Bass midi track is playing Poly and not mono.
    But when I use Beathawk Bass Preset it’s mono so works perfect with the incoming midi from Midiband.
    However I can’t get Beathawk to transpose at least +12. Is there a way to tell by sliding the pitch in Beathawk?

    @Samu said:

    @MusicMan4Christ said:
    Guys is there a way to make the built in Bass preset instrument mono in Cubasis?

    As far as I know the Cubasis Microsonic instrument has no Mono/Poly switch.
    It might be helpful to tag @LFS with all the issues we bump into?

Sign In or Register to comment.