Drum perfect pro maxing out cpu in cubasis on 1st gen iPad Pro?

I’ve not used it in cubasis in a while and come to think of it I usually program the pattern in drum perfect pro itself but I’ve put it on a midi track in cubasis and it’s crashing cubasis. It’s only a simple project I have jamup pro on one of the audio tracks and cubasis bass on the other midi track but my iPads having none of it. Is there a setting I’m missing somewhere or are these 3 tracks just too much for my iPad to handle? (I can’t imagine they are...)

Cheers

Comments

  • 25 Comments sorted by Date Votes
  • In Auria, I’d say increase the latency to 512 (Apple won’t let you to increase further for software instruments, and it would become unplayable anyway). Find the correspondent latency settings in Cubasis and increase the latency to the maximum allowed.

  • LFSLFS
    edited October 2017 Vote Up0

    Hi Extnctn6,

    Using Cubasis on the 1st Gen iPad Pro myself in the office, be assured the device can easily take up much more tracks than three - which is near to nothing. I've sent Marinus (Drum Perfect Pro) a message to swap promo codes in checking the issue. So let's await his feedback.

    Please give it a try to unload either Drum Perfect Pro and/or Jamup Pro, to find out which app creates the CPU overload issue in the project.

    There should be absolutely no problem to run much bigger Cubasis projects on an iPad Pro (1st Gen).

    P.S.: Please make sure to inform third party app providers always, to make them aware about the issues as well.

    Thanks,
    Lars

  • Hi Extnctn6 again,

    Here comes an additional request:
    Please provide me with the crash report via private message.

    In case, you're not aware how to get the crash files off the iPad, please look here:
    https://help.getpocket.com/article/1098-how-to-find-the-iphone-ipad-app-crash-logs

    Thanks for your support!

    Best,
    Lars

  • Hi thanks for your responses

    @LFS is there a way I can send you a crash report straight from my iPad? Only computer I have is an old laptop running vista and iTunes doesn’t support it anymore..

    I’m still having trouble with it. It’s definitely drum perfect pro and not jam up pro.

    To run through my set up:

    I have all drums programmed on one cubasis midi track

    Drum perfect pro loaded as iaa instrument on said midi track

    Cubasis midi track routing: no midi input, thru is off, midi output is set to ch10, stereo output 1/2

    Cubasis setup:

    Sample rate 44.1
    bit resolution 24
    Output latency 0ms
    Send midi clock on

    Drum perfect pro set up:

    Empty song
    My own kit loaded (have tried it with several other factory kits as well)
    Audio buffer size 256
    Midi source cubasis, channel 10,
    Midi destination drum perfect pro
    Clock source cubasis

    If I load the project in cubasis and press play it’ll play but the moment I do anything else while it’s playing cubasis cpu goes straight to 100% then cubasis crashes..

    It does it every time.

    At the moment I’m freezing the drum track so I that can work on other parts of the project..

    @Marinus are you able to help please mate?

    Thanks for your help guys!

  • It would be more easy, if you could upload this Cubasis project somewhere.

  • Just 2 MIDI tracks... DPP running a default preset.

  • @tja said:

    Just 2 MIDI tracks... DPP running a default preset.

    I’m sending cubasis midi to drum perfect though mate..

  • @tja said:

    Just 2 MIDI tracks... DPP running a default preset.

    So it could be user error?

  • @ginandjuice said:

    @tja said:

    Just 2 MIDI tracks... DPP running a default preset.

    So it could be user error?

    Wouldn’t be surprised!

  • Hi Extnctn6,

    Marinus and me gave the issue a check, and CPU usage seems similar to tja's results above.
    Could it be possible that other apps previously assigned via IAA are still running in background, stealing CPU?

    Here is what Marinus wrote about it:
    Could it be that the user at hand has other IAA inputs in the setup while running under iOS11? I noticed earlier that there’s a bug in iOS11 with retrieving the app host icon. The particular call besides not delivering the proper icon also seems to stall the cpu for some time. There may be apps around that suffer from that issue. (Apple solved this bug in iOS11.1)

    Best,
    Lars

  • Thanks for your help.

    I’ve noticed that the drum perfect pro icon doesn’t always come up properly it’s sort of shaded out unless I load drum perfect pro before cubasis so that may have something to do with it..

    The only other iaa app I’m using is jam up pro which I’ve already tried removing from the project so I’m pretty sure it’s not that and I’ve got no other apps running in the background.

    I’m wondering if I’ve not updated to iOS 11.1 is the cause. I think I have but it may be that I did my phone and not my iPad but I’m at work today and I’m taking my son out tonight so I won’t be able to check until I get back late tonight but I’ll update you when I do

    Many thanks

  • @Extnctn6 said:
    Thanks for your help.

    I’ve noticed that the drum perfect pro icon doesn’t always come up properly it’s sort of shaded out unless I load drum perfect pro before cubasis so that may have something to do with it..

    The only other iaa app I’m using is jam up pro which I’ve already tried removing from the project so I’m pretty sure it’s not that and I’ve got no other apps running in the background.

    I’m wondering if I’ve not updated to iOS 11.1 is the cause. I think I have but it may be that I did my phone and not my iPad but I’m at work today and I’m taking my son out tonight so I won’t be able to check until I get back late tonight but I’ll update you when I do

    Many thanks

    Does it also happen if you load DPP (All Instruments) as IAA generator (for clock sync) and then send midi to DPP from Cubasis via coremidi?

    Marinus

  • @Marinus said:

    @Extnctn6 said:
    Thanks for your help.

    I’ve noticed that the drum perfect pro icon doesn’t always come up properly it’s sort of shaded out unless I load drum perfect pro before cubasis so that may have something to do with it..

    The only other iaa app I’m using is jam up pro which I’ve already tried removing from the project so I’m pretty sure it’s not that and I’ve got no other apps running in the background.

    I’m wondering if I’ve not updated to iOS 11.1 is the cause. I think I have but it may be that I did my phone and not my iPad but I’m at work today and I’m taking my son out tonight so I won’t be able to check until I get back late tonight but I’ll update you when I do

    Many thanks

    Does it also happen if you load DPP (All Instruments) as IAA generator (for clock sync) and then send midi to DPP from Cubasis via coremidi?

    Marinus

    Hi @Marinus thanks for chiming in.

    How exactly do I do that mate? I’m not sure what an iaa generator exactly is off the top of my head and I’ve not got my iPad with me but I’d like to work this out when I get home tonight if possible.

    Cheers

  • Hi @Marinus and @LFS I’ve checked and I’m on ios 11.03 so that’s not the issue.

    I’ve started a new project in cubasis with one midi track and programmed a 4 bar basic beat with drum perfect pro loaded as iaa instrument.

    No other apps running in the background and started by switching iPad off and back on again so definitely no other apps are in use.

    It’s still doing it I had to tap rewind several times for it to crash but I recorded a video on my phone and shared it to drop box so you can see it happening.

    Is my setup i posted yesterday correct?

    Thanks again

  • @Extnctn6: thanks for the video. I was able to reproduce the issue. Will investigate this further.

    In case you're using DPP only as a midi sound module (without the sequencer I mean) a workaround could be to just start DPP next to Cubasis and drive DPP via coremidi from Cubasis, which will avoid the issue.

  • @Marinus glad you could reproduce it. How do I drive it with core midi mate?

  • @Extnctn6 said:
    @Marinus glad you could reproduce it. How do I drive it with core midi mate?

    In Cubasis, set the midi outport of the midi track to DrumPerfect Pro, and choose a channel. Mute the corresponding Cubasis track in the mixer. In DPP, goto Settings view, longpress DrumPerfect Pro midi port button and make sure the same channel is selected. That's all.

  • That’s what I’m doing already though mate I’ve just not got it muted. Is that the issue then, cubasis and drum perfect pro are both playing it back at the same time and I’m just not realising it and I need to mute cubasis?

  • Ah think I understand actually, you mean don’t load drum perfect pro as iaa instrument just send the midi data :-)

  • @Extnctn6 said:
    Ah think I understand actually, you mean don’t load drum perfect pro as iaa instrument just send the midi data :-)

    Exactly!

  • @Extnctn6: Fix for this issue will be in the next update. We are currently bringing some major extensions to DPP's sample engine, so no release date yet.

    OT, but maybe of interest to some: the new sample engine will allow for up to 8 velocity layers and multiple sample groups per instrument, but still within the 16 samples per instrument limit. So, in a single instrument we could have two 8-layer sample groups, e.g. for left-handed and right-handed drum strokes, or eight 2-layer sample groups triggered by 8 different drum stroke attributes. Or a 1-layer sample group with 16 randomly selected samples. Or anything in between..

  • Great info, thanks!

Sign In or Register to comment.