PSA: Don't update to iOS 12.4 if you use apps in AB output slot or IAA apps that use the mic.
https://forum.audiob.us/discussion/34030/urgent-psa-hold-off-updating-to-ios-12-4-if-you-use-apps-in-output-slot-in-audiobus

Blank

The user and all related content has been deleted.
«1

Comments

  • Is Background Audio turned on? If so, could it be a bug? Can anyone else reproduce the issue?

  • Have you tried starting DM1 before loading into AB?

  • Yes, I have all of the apps. I'll try to check this out when I get home from work tonight. If it is easily reproducible, it should be easy for developers to find the bug and fix it.

  • Good to know! Maybe you could post step by step instructions for repeating the issue, so that developers and others can quickly try and repeat the issue...

  • Just stick an app in the effects slot. You don't even have to wake it up...

  • edited January 2017
    The user and all related content has been deleted.
  • edited January 2017
    The user and all related content has been deleted.
  • Confirmed. It happens with my iPad 2 with iOS 6.1.3. Now we need some developers to determine which app is at fault (or maybe it's a problem with all of the apps)... Either way, I don't know who to report this to. I suppose it is possible that Audiobus could be just as guilty as the other apps, so hopefully Sebastion will chime in with some information.......

  • edited January 2017
    The user and all related content has been deleted.
  • No, you should definitely be able to run multiple apps, especially on an iPad 4. But you should probably check if you're not running more than the necessary apps in the background, because that can cause issues when you're running out of Ram/CPU. Use the Multitasking menu to close apps that you don't need in your current setup.

  • I'm currently playing DM1 through Audiobus into Audioshare. No problems. IPad 2 64GB, iOS 6.1.3

  • @afxtwn the main problem is that you are trying to "get little loops going" without LoopyHD ! you should check out that app for super easy looping (that can also be very powerful/ complex). It works great in Audiobus output slot.

    seriously though, since many apps have updated for iOS 7 it seems some of the basic functions in iOS 6 (ipad 2) are slightly less stable, or at least less forgiving. I haven't tinkered enough to figure out why... it just doesn't feel quite as smooth. I've had DM1 audio drop out sometimes too.

  • edited January 2017
    The user and all related content has been deleted.
  • @AfxTwn, I just tried DM1 > Echo PAd > Audioshare and it worked fine until I added Cube Synth as another input. It crashes Echo Pad. When I remove Cube Synth, it works fine again.

    This is on my red-headed stepchild iPad 3 and iOS 6.

  • edited January 2017
    The user and all related content has been deleted.
  • I'm having immediate crashes with DM-1 to Echopad to Speaker Output, nothing else though with different combos of those apps. Seems like it must be something related between the two? @holdernessmedia, any ideas?

  • @CSwinn - I'm not experiencing any crashes when I try that combo. I'm running latest versions of both apps on my iPad 2, running iOS 7.0.3

    What device and iOS version are you running, as well as app versions?

  • edited October 2013

    @CSwinn Might have found the problem. When I try DM-1 for iPad I have no problems.
    When I try DM-1 for iPhone it crashes immediately. Seems to be an issue with DM-1 as I force closed all apps, then tried opening DM-1 for iPhone on it's own and it crashes immediately. I can't get it to open at all, whether it's in Audiobus or not.

    The iPad version is working fine for me though, can you confirm whether you're running the iPad or iPhone version of DM-1?

    UPDATE: I just tested DM-1 on my iPhone and it works fine, both with or without Audiobus, and any combo with Echo Pad. Seems it might be an issue specific to running the iPhone version of DM-1 on the iPad?

    Anyone else can confirm?

  • @holdernessmedia, now I can't replicate the crash unless I add a second something to the input. I've just tried DM-1/ Thumbjam, DM-1/ Addictive, and then Addictive/ Animoog and it seems to be inserting the second app that causes the crash. iPad 4 with 7.0.2

  • @CSwinn Hmm... let me try a few combos and see what's up.

  • Just tried waking two input apps first, then speaker out, waking Echo Pad last... still crashing.

    No hurry, headed to the airport now. Absolutely love the quick communication though!

  • edited October 2013

    @CSwinn - I just tested with Echo Pad in the Output slot with DM-1 and Animoog, then replaced Animoog with DrumJam, then replaced DrumJam with Bebot and no crashing.
    However, once I disconnected Echo Pad from the Output slot, the second input app keeps going to sleep. I then force closed Echo Pad and tried using just the regular AB Speaker app in the Output slot and it still caused the 2nd input app to go to sleep.

    Not sure exactly what's going on there but it was easy to get everything working again by simply force closing all apps, then start Audiobus fresh and make your connections.
    That is the quickest and most reliable solution I've found to most problems I've ever had with different apps connected to Audiobus. Same goes for Inter-app Audio. It's normally a matter of an app(s) audio session becoming inactive for one reason or another, sometimes related to bugs inherent in iOS. I always try this solution first before anything else, and far more often than not it correct any issues.

    Hopefully this solves it for you, if it still doesn't, try force closing all apps and do a hard reset on the device, though I doubt that will be necessary.

  • I've only been trying echo pad in the fx slot with the speaker as my output. I also always force close everything before retrying, haven't hard reset though. Will try again later, thanks.

  • @CSwinn Ok, let me know how it goes.

  • I've had some time to test while my flights delayed (grrrr). I did a hard reset and it doesn't matter what inputs or outputs I use or the order I launch them, anytime echo pad is in the effects slot, it crashes with two input apps.

    It works just fine with one, but two is an instant fail. All my apps are the latest versions though I am still on 7.0.2 iOS.

  • @CSwinn - Strange, I don't believe 7.0.3 fixed any audio issues in iOS but perhaps that could be the difference? I'm still on an iPad 2 so you definitely have more than enough power. Unfortunately all my devices that are running iOS 7 are on 7.0.3 so I can't test that directly on my own device.

    I'm a bit confused though, originally you said the problem was with Echo Pad in the Output slot only, but now it's happening in effects slot also?

  • No, I've always had speaker (and just now tried Audioshare) as the output, and echo pad in the middle. It's only happening with two input apps and echo pad in the effects slot.

  • Ahh ok, I think I misread your initial post, sorry about that.

    Let's continue this via email or PM so it doesn't blow up this post.

  • edited January 2017
    The user and all related content has been deleted.
  • edited November 2013

    @AfxTwn - Sorry you and @CSwinn are having this problem, I will do some more thorough testing tonight. If possible, can you confirm whether or not you experience this with ANY combo of two inputs + Echo Pad in the effect slot, or is it only when using a combo of DM-1 and another input app?

Sign In or Register to comment.