Audiobus: Use your music apps together.

What is Audiobus?Audiobus is an award-winning music app for iPhone and iPad which lets you use your other music apps together. Chain effects on your favourite synth, run the output of apps or Audio Units into an app like GarageBand or Loopy, or select a different audio interface output for each app. Route MIDI between apps — drive a synth from a MIDI sequencer, or add an arpeggiator to your MIDI keyboard — or sync with your external MIDI gear. And control your entire setup from a MIDI controller.

Download on the App Store

Audiobus is the app that makes the rest of your setup better.

echo pad + grain science - autosleep - bug or lack of power?

i have ipad 3
i put echo pad in output
when i put Orphion or DrumJam in input all is good

but when i try Grain Science then Echo Pad is going to sleep in any case
also i had bad luck with PPG. (no sound)

Animoog as input also puts echo pad to sleep
and even thumbjam

Is that ipad 3 so weak?
or some another reason..

Also, i'm still on 5.1.1.
maybe it's also the cause? though i'm afraid i cant move to 6.0 cause i'm not sure that some ultracool apps that i love and use which are abandoned now (Hexatone, for example) shall work in iOS 6..


  • I don't have grain science but I don't have any problems running ppg with Animoog into echo pad (ipad3 ios6)

  • edited December 2012

    Hi Qmishery, sorry you're having this problem with Echo Pad. I haven't had any other reports of this sleeping issue so far, and I am trying now to recreate the problem.

    This is what I've found so far. I have been testing with Echo Pad connected as the Output app, with the following Input app combos. The testing was done on an iPad 2 running iOS 6.01.

    Output app: Echo Pad

    Input app combinations:

    -Animoog + iElectribe

    -Animoog + iElectribe + Sir Sampleton

    -Sunrizer + iElectribe

    -Magellan + Funkbox + Sir Sampleton

    -Glitchbreaks + Sir Sampleton

    -Loopy HD + iElectribe

    With any of these combinations, I do not experience Echo Pad, or any other apps going to sleep. I tried disconnecting and reconnecting all the apps one by one with iElectribe playing back a pattern the whole time, and still had no problems.

    However after more testing I did find an issue that I am able to consistently reproduce that causes one or more apps to go to sleep.
    I had Animoog + iElectribe connected as Input apps, with Echo Pad as the Output. I then switched over to the Appstore, and after a few seconds of the AppStore trying to load, the sound from Audiobus apps cuts out, and I experienced the sleeping issue with all 3 apps that were connected, though not all at the same time.

    It has been random for me, each time switching over, once the Appstore has been loading for a few seconds it puts a different app to sleep. Sometimes it's just Echo Pad, or just iElectribe, other times its all Input apps. On one or two tries, switching to the Appstore did not put any apps to sleep, but more often than not it put at least one of them to sleep.

    At this point of testing it does not seem to be a bug with Echo Pad, or any app in particular.
    I will test further and see what else I can find, and will report back here. For the time being, I would suggest trying one of the following solutions to easily fix the problem.

    1.) Close Echo Pad, Audiobus, and any other music apps you have running, and remove them for the multi-taskbar to ensure they're closed completely. If you have a lot of other apps also in the taskbar, close them out as well. Once all the apps are closed, launch Audiobus and connect Echo Pad and the other apps you want to use in Audiobus and see if the problem persists.

    2.) If the problem does persist, close all the apps and remove them from the multi-task bar, and re-boot your iPad. Once the iPad restarts, try connecting Audiobus, Echo Pad, etc. and see if the problem persists.

    Also, you can fill out a support ticket here if you continue experiencing the issue.

  • Thanks for reply!

    I'll try suggested methods and write about results either here or contact you directly.

    And, happy new year, after all..

  • I've been testing further and I've experienced the issue with or without Echo Pad connected in Audiobus. Simply removing the apps from the taskbar and relaunching them easily fixes the problem.

  • Thanks! And yes, Happy New Years to everyone!

  • I just checked and have the same issue. I cannot get those synths to work with echopad

  • edited December 2012

    @Eastwood Which synths in particular, and have you tried what I suggested in the post above?

  • Sorry for my late reply. I've tried grain science and magellan and both of them put echo pad to sleep. I closed all apps and reset the ipad, but echo pad still just sleeps. I'm using an ipad 3 running ios 5.1

  • I am not able to recreate this on my end so far. Could you fill out a quick support ticket?

    In the details section just reference this post on the forum.

Sign In or Register to comment.